2004 6.0L Stalling/Dies Randomly - Diesel Forum - TheDieselStop.com
6.0L Power Stroke Engine and Drivetrain Discussion of the 6.0L Power Stroke diesel engine and drivetrain in the 2003-Up Super Duties and Excursions. No gas engine discussion allowed except on transmissions and drivetrain that pertain to all models. Please confine discussion of topics in this forum to those items that are specific to the 6.0L Power Stroke engine.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 24 (permalink) Old 04-18-2017, 10:00 PM Thread Starter
Junior Member
 
Join Date: Oct 2014
Posts: 22
My Photos: (0)
Feedback Score: 0 reviews
2004 6.0L Stalling/Dies Randomly

Hello Diesel Friends,

I have a problem that seems sort of specific and after searching several other threads and forums I haven't come up with an exact match. I have also watched countless videos of Diesel Tech Ron.

Truck: 2004 F350 6.0
EGR DELETE
Replaced Oil Cooler
ARP Head Studs
New Injectors
New Glow Plugs
Western V-Plow
Aftermarket Exhaust/Air Intake
170,000 Miles

All of the above except the intake, exhaust, and egr delete was done by me about 2 years ago. Truck has ran fine until now.

Current Situation:

I have a landscaping business and this truck is used to pull a 16' trailer and lawn mowers. About a week ago I was pulling with it (rare occasion, my employees use it most of the time) and it stalled on a very VERY slight incline. The truck just died and I pulled over. I tried to crank but no start, I got out, lifted the hood, glanced around, googled my problem, found nothing specific, tried to start it up and it fired. I went on about my business driving it another 10-15 miles that day with no problems. The next day my employees had it die on them in the middle of the day after using it from 8am to about 1pm. I was running a skid steer so my business partner went out and after about 10 minutes it started back up. They got about 3 miles down the road and it happened again. This time they unplugged the batteries for about a minute, plugged them back in and it fired right up. Another 5 miles down the road it happened a 3rd time with the same battery unplug/replug results. They got it back to the our shop. I drove it home that evening and gunned it all the way home, ran like a scalded dog, no problems. The next day they took it out again and got about 10 miles from our shop and it died. We got it back to the shop and haven't used it to pull since. However, I have driven it over 200 miles since then without a single hiccup. I've got my scan gauge 2 in it and I'm trying to recreate the problem. Today I put the 16' trailer on it empty and pulled it uphill hard, drove it around town and tried to give it a lot of work and it never stalled. The only difference now is I didn't have the 2 mowers on the trailer. I'm stumped.


Current Scanguage Readings -

Key On Engine Off:
IPR - 14.8%
SYN - 0
FMP - 48.5v
ICP - 55 ***(I think this is weird, Diesel Tech Ron said it should be between 0-15) With the ICP unplugged it obviously reads 0

Pulling the trailer at 45mph at 2500 RPM's:

IPR - 63.6 %
SYN - 1
FMP - 49.0v
ICP - 2603


Any suggestions? Thank you all for taking the time to read all of that!
NightcrawlerF350 is offline  
Sponsored Links
Advertisement
 
post #2 of 24 (permalink) Old 04-19-2017, 01:54 PM
Senior Member
 
Phil G.'s Avatar
 
Join Date: May 1999
Location: Ontario, Canada
Posts: 2,093
My Photos: (2)
Feedback Score: 0 reviews
I'm wondering about fuel starvation, dirty filters, weak pump. I would suggest you get a fuel pressure gauge on it while you are driving it before tearing into anything on the engine.

2007 F350 SRW 6.0L Auto, 3.73LS, 172"WB 4x4. Viper Alarm/RS, WD pillar Guages,AutoEnginuity, 100gal polished alum fuel tank.
All Sold: 99.5, early03 , 2004 - all were 172" wb 4x4 lariat's.

My Worklog:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Phil G. is offline  
post #3 of 24 (permalink) Old 04-19-2017, 05:07 PM Thread Starter
Junior Member
 
Join Date: Oct 2014
Posts: 22
My Photos: (0)
Feedback Score: 0 reviews
We are trying to get ahold of a fuel pressure tester that will fit my truck. In the meantime we were able to get the truck to stall out today. The readings on the scan Guage are as follows:

IPR - 84.7%
ICP - 229
Ficm - 48.5v
Sync - 1

These readings are when we were trying to restart the truck during crank. If we let the truck set for around 5 minutes it would fire back up like normal. This happened 3 times today while we were out testing it. I'm sort of leaning away from the fuel or fuel filters because the thing literally shuts off like you turned off the key, no sputter or warning signs like it's running out of fuel.
NightcrawlerF350 is offline  
 
post #4 of 24 (permalink) Old 04-19-2017, 06:27 PM
Senior Member
 
Phil G.'s Avatar
 
Join Date: May 1999
Location: Ontario, Canada
Posts: 2,093
My Photos: (2)
Feedback Score: 0 reviews
Ya, your IPR is wide open on those numbers you just posted... sure seems to point to HP oil system. Next step would be an air test, don't forget to command the IPR closed or turn it off with Bat+ for short periods of time.

2007 F350 SRW 6.0L Auto, 3.73LS, 172"WB 4x4. Viper Alarm/RS, WD pillar Guages,AutoEnginuity, 100gal polished alum fuel tank.
All Sold: 99.5, early03 , 2004 - all were 172" wb 4x4 lariat's.

My Worklog:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Phil G. is offline  
post #5 of 24 (permalink) Old 04-19-2017, 06:48 PM Thread Starter
Junior Member
 
Join Date: Oct 2014
Posts: 22
My Photos: (0)
Feedback Score: 0 reviews
Good news, the scanguage gave some codes

P0069
P006A
P2285
P2623
NightcrawlerF350 is offline  
post #6 of 24 (permalink) Old 04-19-2017, 06:58 PM
Senior Member
 
Join Date: Sep 2005
Posts: 4,043
My Photos: (0)
Feedback Score: 0 reviews
late or early 04? (where is the ICP located)

My bet is on a failing HPOP, but a short in the ICP sensor or wiring can also make it stall/shutdown while running.

Mark
06 F250 CC SB FX4 Lariat;ARP studs;OEM gaskets;Banks exhaust;DynaTrac Ball joints;Coolant filter;High-Idle mod;RACCCV6000;JimmiJammers;Ravelco;SynchroMax xfer case;Fumoto valve;Harpooned;CPOhighwayProducts toolbox;tracrac;Fox Weatherboots;Wet Okole Seat Covers;BriteBox;Re-flashed;Quadzilla Recon XZT Fuel Press;Blue FPR spring;DashDAQ;PHP FICM;RiffRaff boots;DCPower270A XP;PowerInverter;Rancho7000's;BPD EGR cooler;One-piece HPOP fitting;D-plugs&standpipes;BPD Billet WaterPump;SCT w/ Matts SRL+;ELC Ultra;DuraTracs
bismic is offline  
post #7 of 24 (permalink) Old 04-19-2017, 07:04 PM
Senior Member
 
Join Date: Sep 2005
Posts: 4,043
My Photos: (0)
Feedback Score: 0 reviews
P0069: MAP Barometric Pressure Correlation. MAP, BARO, EBP, ICP, APP (throttle pedal), EGR, and MAF are all tied into the same circuit (vreference). Post your MAP and Baro readings at KOEO.

P006a: MAF sensor code - part of Inferred EBP strategy. Will throw a wrench light. Because of this, I bet you have an early 04 w/ the ICP behind the turbo.

P2285: ICP Sensor - Circuit Low. Visually inspect the ICP sensor harness and connector for damage, corrosion, or incorrect routing. This is what you get when you disconnect the ICP, so that may be it if you try to start w/ it disconnected.

P2623: Stuck turbo, MAP sensor, MAP hose plugged or leaking, CAC hose disconnected or leaking, intake leaks, exhaust restriction, exhaust leaks, EBP sensor or EBP tube plugged, or bad VGT solenoid. This code is set when MGP does not go over 15kPa or 2.2 psi when the following conditions are met: rpm must be over 2800; VFDES above 35; and EGRVP above 0.10. All of these conditions must be met for 5 seconds for the code to be set. This code can also be set if there is ANY condition that would produce low power.

Mark
06 F250 CC SB FX4 Lariat;ARP studs;OEM gaskets;Banks exhaust;DynaTrac Ball joints;Coolant filter;High-Idle mod;RACCCV6000;JimmiJammers;Ravelco;SynchroMax xfer case;Fumoto valve;Harpooned;CPOhighwayProducts toolbox;tracrac;Fox Weatherboots;Wet Okole Seat Covers;BriteBox;Re-flashed;Quadzilla Recon XZT Fuel Press;Blue FPR spring;DashDAQ;PHP FICM;RiffRaff boots;DCPower270A XP;PowerInverter;Rancho7000's;BPD EGR cooler;One-piece HPOP fitting;D-plugs&standpipes;BPD Billet WaterPump;SCT w/ Matts SRL+;ELC Ultra;DuraTracs
bismic is offline  
post #8 of 24 (permalink) Old 04-19-2017, 07:25 PM Thread Starter
Junior Member
 
Join Date: Oct 2014
Posts: 22
My Photos: (0)
Feedback Score: 0 reviews
Its a late build '04. The ICP code is probably because I unplugged it to see if it would fix my issue. The P0069 code has been pulled before, its not new along with the current problem.
NightcrawlerF350 is offline  
post #9 of 24 (permalink) Old 04-19-2017, 07:28 PM
Senior Member
 
Join Date: Sep 2005
Posts: 4,043
My Photos: (0)
Feedback Score: 0 reviews
MAP, Baro, and EBP readings at KOEO?

Mark
06 F250 CC SB FX4 Lariat;ARP studs;OEM gaskets;Banks exhaust;DynaTrac Ball joints;Coolant filter;High-Idle mod;RACCCV6000;JimmiJammers;Ravelco;SynchroMax xfer case;Fumoto valve;Harpooned;CPOhighwayProducts toolbox;tracrac;Fox Weatherboots;Wet Okole Seat Covers;BriteBox;Re-flashed;Quadzilla Recon XZT Fuel Press;Blue FPR spring;DashDAQ;PHP FICM;RiffRaff boots;DCPower270A XP;PowerInverter;Rancho7000's;BPD EGR cooler;One-piece HPOP fitting;D-plugs&standpipes;BPD Billet WaterPump;SCT w/ Matts SRL+;ELC Ultra;DuraTracs

Last edited by bismic; 04-19-2017 at 07:37 PM.
bismic is offline  
post #10 of 24 (permalink) Old 04-19-2017, 08:59 PM Thread Starter
Junior Member
 
Join Date: Oct 2014
Posts: 22
My Photos: (0)
Feedback Score: 0 reviews
how do you find BARO value? Never looked at that. Thanks
NightcrawlerF350 is offline  
post #11 of 24 (permalink) Old 04-19-2017, 09:04 PM
Senior Member
 
Join Date: Sep 2005
Posts: 4,043
My Photos: (0)
Feedback Score: 0 reviews
Barometric Pressure (PSI)
TXD: 07E0221442
RXF: 046285140642
RXD: 3010
MTH: 001D0050000
NAM: BAR

Mark
06 F250 CC SB FX4 Lariat;ARP studs;OEM gaskets;Banks exhaust;DynaTrac Ball joints;Coolant filter;High-Idle mod;RACCCV6000;JimmiJammers;Ravelco;SynchroMax xfer case;Fumoto valve;Harpooned;CPOhighwayProducts toolbox;tracrac;Fox Weatherboots;Wet Okole Seat Covers;BriteBox;Re-flashed;Quadzilla Recon XZT Fuel Press;Blue FPR spring;DashDAQ;PHP FICM;RiffRaff boots;DCPower270A XP;PowerInverter;Rancho7000's;BPD EGR cooler;One-piece HPOP fitting;D-plugs&standpipes;BPD Billet WaterPump;SCT w/ Matts SRL+;ELC Ultra;DuraTracs
bismic is offline  
post #12 of 24 (permalink) Old 04-20-2017, 08:21 PM
Senior Member
 
STMPDUST's Avatar
 
Join Date: Mar 2001
Location: RESEDA,CALIFORNIA,USA
Posts: 741
My Photos: (0)
Feedback Score: 0 reviews
Did you replace the fuel filter UNDER the truck, i had stalling issues before and it was that little bugger right there.

2015 KR Dually CC 4X4 Bronze Fire HC
2011 KR Dually CC 4X4 Royal Red
2005 Eddie Bauer Excursion 4X4 ,White
STMPDUST is offline  
post #13 of 24 (permalink) Old 04-20-2017, 09:13 PM Thread Starter
Junior Member
 
Join Date: Oct 2014
Posts: 22
My Photos: (0)
Feedback Score: 0 reviews
Quote:
Originally Posted by STMPDUST View Post
Did you replace the fuel filter UNDER the truck, i had stalling issues before and it was that little bugger right there.
Did it shut off with no warning signs or did it sputter and stuff first in this situation?
NightcrawlerF350 is offline  
post #14 of 24 (permalink) Old 04-20-2017, 09:20 PM Thread Starter
Junior Member
 
Join Date: Oct 2014
Posts: 22
My Photos: (0)
Feedback Score: 0 reviews
I have been slammed with work this week and I didn't have a chance to get the BARO code put on my scanguage II however, I did want to check my EBP. The EBP used to give me a reading that was proper (about 3 years ago was the last time I checked it. Since my motor was rebuilt I had used an SCT excalibrator that came with the truck to make sure it was put back into stock mode. I'm not sure if it was in stock mode before or not, when I bought it from the guy he just had the tuner and gave it to me with the truck. Any idea why I would no longer get an EBT reading. I know the scan gauge is programmed correctly because I can hook it up to my other 6.0 and it'll read EBT correctly. When its plugged into the truck I'm having problems with there is no number whatsoever beside EBP, everything else I have programmed in is reading normally. I'll get back to you on my BARO. Thanks everyone.
NightcrawlerF350 is offline  
post #15 of 24 (permalink) Old 04-20-2017, 09:41 PM
Senior Member
 
Join Date: Sep 2005
Posts: 4,043
My Photos: (0)
Feedback Score: 0 reviews
If you have an early 04 engine (ICP behind turbo), AND the PCM has been reflashed, then you won't get an EBP reading because a TSB eliminated that in 03 and early 04 engines (it just uses an inferred EBP value).

Mark
06 F250 CC SB FX4 Lariat;ARP studs;OEM gaskets;Banks exhaust;DynaTrac Ball joints;Coolant filter;High-Idle mod;RACCCV6000;JimmiJammers;Ravelco;SynchroMax xfer case;Fumoto valve;Harpooned;CPOhighwayProducts toolbox;tracrac;Fox Weatherboots;Wet Okole Seat Covers;BriteBox;Re-flashed;Quadzilla Recon XZT Fuel Press;Blue FPR spring;DashDAQ;PHP FICM;RiffRaff boots;DCPower270A XP;PowerInverter;Rancho7000's;BPD EGR cooler;One-piece HPOP fitting;D-plugs&standpipes;BPD Billet WaterPump;SCT w/ Matts SRL+;ELC Ultra;DuraTracs
bismic is offline  
Sponsored Links
Advertisement
 
Reply

  Diesel Forum - TheDieselStop.com > 1999-2007 Ford Super Duties > 6.0L Power Stroke Engine and Drivetrain

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Forum - TheDieselStop.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome