6.0 runs rough when cold - Diesel Forum - TheDieselStop.com
Ford Diesel Forum / Powerstroke Forum
Ford Diesel Forum / Powerstroke Forum
Go Back   Diesel Forum - TheDieselStop.com > 1999-2007 Ford Super Duties > 6.0L Power Stroke Engine and Drivetrain

6.0L Power Stroke Engine and Drivetrain Discussion of the 6.0L Power Stroke diesel engine and drivetrain in the 2003-Up Super Duties and Excursions. No gas engine discussion allowed except on transmissions and drivetrain that pertain to all models. Please confine discussion of topics in this forum to those items that are specific to the 6.0L Power Stroke engine.

TheDieselstop.com is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 07-13-2010, 08:16 PM   #1 (permalink)
Junior Member
 
Join Date: Jul 2010
Location: charlotte
Posts: 7
My Photos: (0)
Feedback Score: 0 reviews
6.0 runs rough when cold

My '04 runs very rough when i just start it up for the day. I let it warm up for a couple of minutes (even in summer) then leave out and it acts like it has no power and runs like a gas engine would if the plugs were fouling. After a few miles everything works fine. I do have a bully dog PMS but it does it no matter what setting its on. I have heard that the problem is anywhere from the EGR to the enjectors. Does anyone have any idea whats going on? It only smokes on setting 4 and on setting 3 when i really get on it. It also accelerates very slowly from a dead stop to about 10 mph no matter how long i drive it. Wonder if its related?
strokin318 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 07-14-2010, 06:17 PM   #2 (permalink)
Senior Member
 
sarnott140's Avatar
 
Join Date: May 2008
Location: B.C. Canada
Posts: 529
My Photos: (0)
Feedback Score: 0 reviews
the accelerating slowly part is normal, its just turbo lag. the rough running cold part sounds like injectors to me, i had the same problem and i had 2 bad one's. but forst try cleaning your egr valve, its a cheaper place to start. what colour is the smoke??
__________________
'06 F350 CC, SB, 6.0
Oxford white, scangauge 2, 3" lift, egr delete, stc upgrade, dieselsite coolant filter, high idle mod, skyjacker s/s,deezee nerf bars and drybox, 305/65-18 BFG all terrains, Hella driving lights and fog lights.
sarnott140 is offline   Reply With Quote Quick reply to this message
Old 07-14-2010, 08:58 PM   #3 (permalink)
Junior Member
 
Join Date: Jul 2010
Location: charlotte
Posts: 7
My Photos: (0)
Feedback Score: 0 reviews
the smoke is still black for now but it is only a puff in first gear. After i run it a few miles the roughness goes away for the rest of the day even if it sits for hours. was your problem like that or did it last all day?

Last edited by teamroper60; 07-14-2010 at 09:01 PM. Reason: Removed reference to an illegal modification.
strokin318 is offline   Reply With Quote Quick reply to this message
Old 07-14-2010, 11:08 PM   #4 (permalink)
Senior Member
 
sarnott140's Avatar
 
Join Date: May 2008
Location: B.C. Canada
Posts: 529
My Photos: (0)
Feedback Score: 0 reviews
the black smoke is unburnt fuel and is directly related to your progeammer, not a big deal.yes my problem was the same as yours, ran real rough untill it was warmed up then ran good. you should get your codes scanned
__________________
'06 F350 CC, SB, 6.0
Oxford white, scangauge 2, 3" lift, egr delete, stc upgrade, dieselsite coolant filter, high idle mod, skyjacker s/s,deezee nerf bars and drybox, 305/65-18 BFG all terrains, Hella driving lights and fog lights.
sarnott140 is offline   Reply With Quote Quick reply to this message
Old 07-14-2010, 11:11 PM   #5 (permalink)
Senior Member
 
sarnott140's Avatar
 
Join Date: May 2008
Location: B.C. Canada
Posts: 529
My Photos: (0)
Feedback Score: 0 reviews
also how old and what weight of oil are you running
__________________
'06 F350 CC, SB, 6.0
Oxford white, scangauge 2, 3" lift, egr delete, stc upgrade, dieselsite coolant filter, high idle mod, skyjacker s/s,deezee nerf bars and drybox, 305/65-18 BFG all terrains, Hella driving lights and fog lights.
sarnott140 is offline   Reply With Quote Quick reply to this message
Old 07-15-2010, 09:02 AM   #6 (permalink)
Junior Member
 
Join Date: Jul 2010
Location: Idaho
Posts: 2
My Photos: (0)
Feedback Score: 0 reviews
what flash is your engine at? ive heard vxcf5 can cause injector problems. and also heard that the engine will run rough when it first starts up if your injectors are bad
Blackcloud556 is offline   Reply With Quote Quick reply to this message
Old 07-15-2010, 09:25 AM   #7 (permalink)
Junior Member
 
Join Date: Jul 2010
Location: charlotte
Posts: 7
My Photos: (0)
Feedback Score: 0 reviews
Just had the local dealer change oil and filter about 500 miles ago. I not sure what you mean by (flash) but about how much am i looking at to change injectors? and should i go back with stock or something different?
strokin318 is offline   Reply With Quote Quick reply to this message
Old 07-15-2010, 08:32 PM   #8 (permalink)
Senior Member
 
sarnott140's Avatar
 
Join Date: May 2008
Location: B.C. Canada
Posts: 529
My Photos: (0)
Feedback Score: 0 reviews
blackcloud makes a good point, you should go get the rescent flash, it may help some, they just reprogram the computer and it'll be around 100 bucks. you'll have to get the dealer to hook up the laptop to find out which injectors are bad, once you find that out just take a weekend and replace them yourself, its not very hard, just time consuming. if you do some searching there's probly a write up on here somewhere
__________________
'06 F350 CC, SB, 6.0
Oxford white, scangauge 2, 3" lift, egr delete, stc upgrade, dieselsite coolant filter, high idle mod, skyjacker s/s,deezee nerf bars and drybox, 305/65-18 BFG all terrains, Hella driving lights and fog lights.
sarnott140 is offline   Reply With Quote Quick reply to this message
Old 07-18-2010, 01:23 PM   #9 (permalink)
Junior Member
 
Join Date: Jul 2010
Location: charlotte
Posts: 7
My Photos: (0)
Feedback Score: 0 reviews
thanks guys! my nieghbor works at the local ford place, i'll see if he can take it up there and look at those things. I'll post when i find out and let you know if it helps. Also, can someone tell me if stock injectors will do for replacement or should i look at a performance upgrade as a option. i use the truck for work and don't need to make it stupid fast just reliable.
strokin318 is offline   Reply With Quote Quick reply to this message
Old 07-18-2010, 05:50 PM   #10 (permalink)
Junior Member
 
Join Date: Jan 2009
Posts: 5
My Photos: (0)
Feedback Score: 0 reviews
Check to see if the HPOP is making enough pressure
Mine used to rough in the morning and when the HPOP went out, now its not rough in the morning anymore
__________________
2005 F-250 FX4 Diesel
pepewatt is offline   Reply With Quote Quick reply to this message
Old 07-21-2010, 09:29 PM   #11 (permalink)
Junior Member
 
Join Date: Jul 2010
Location: charlotte
Posts: 7
My Photos: (0)
Feedback Score: 0 reviews
alright, i just dropped the truck off at the shop to get the computer reflashed, the injector pressure checked, and new fuel filters.........cross your fingers!
strokin318 is offline   Reply With Quote Quick reply to this message
Old 07-23-2010, 09:26 AM   #12 (permalink)
Senior Member
 
cmirabile's Avatar
 
Join Date: Sep 2005
Location: Maryland
Posts: 792
My Photos: (9)
Feedback Score: 0 reviews
When I had this issue, my FICM was toast
__________________
2005 F-350 XLT PowerStroke Diesel FX4
SCT Xcalibrator2 with Tunes from Innovative Diesel
37 X 12.5 BFG Mud Terrains
5% 3M Tinting
Viper 791XV with Remote Start
152dB Kleinn 3-Trumpet Horn System
Dakota Digital Gauges
T409 MBRP Straight Pipe
AFE Stage II Intake
HARPOONED Fuel Tank
2003 10 Vane Turbocharger
Blacked Out Harley-Davidson Edition Headlamps
ARP Head Studs
AVIC-Z2 In-Dash Navigation System
205cc Elite Sticks
Coolant Filter
Elite Regulated Return Fuel System
FS2500 Oil Filter
HPOP STC Replaced

My Pictures
cmirabile is offline   Reply With Quote Quick reply to this message
Old 07-27-2010, 09:14 PM   #13 (permalink)
Junior Member
 
Join Date: Jul 2010
Location: charlotte
Posts: 7
My Photos: (0)
Feedback Score: 0 reviews
just got it back from the dealer and they updated the computer and put on a new fuel pressure regulator. they said i had 4 "lazy" injectors and that should help to "wake them back up" , but the problem is now worse despite a little more power after warm up. the sputter is worse under normal driving and driving before the water temp gets to 160+ is frustrating to say say the lest. Absolutely NO power!
strokin318 is offline   Reply With Quote Quick reply to this message
Old 07-28-2010, 05:42 PM   #14 (permalink)
Senior Member
 
sarnott140's Avatar
 
Join Date: May 2008
Location: B.C. Canada
Posts: 529
My Photos: (0)
Feedback Score: 0 reviews
better get those injectors replaced
__________________
'06 F350 CC, SB, 6.0
Oxford white, scangauge 2, 3" lift, egr delete, stc upgrade, dieselsite coolant filter, high idle mod, skyjacker s/s,deezee nerf bars and drybox, 305/65-18 BFG all terrains, Hella driving lights and fog lights.
sarnott140 is offline   Reply With Quote Quick reply to this message
Old 07-28-2010, 11:23 PM   #15 (permalink)
Banned
 
Join Date: Jul 2010
Location: Pocatello, Idaho
Posts: 168
My Photos: (0)
Feedback Score: 0 reviews
what did the dealer say about it now being worse?
BullyDogJason is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Diesel Forum - TheDieselStop.com > 1999-2007 Ford Super Duties > 6.0L Power Stroke Engine and Drivetrain

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Diesel Forum - TheDieselStop.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



Wheel & Tire Center

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 03:17 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.