Error Code P2285 2003 6.0L Diesel - Diesel Forum - TheDieselStop.com
Ford Diesel Forum / Powerstroke Forum
Ford Diesel Forum / Powerstroke Forum
Go Back   Diesel Forum - TheDieselStop.com > 1999-2007 Ford Super Duties > 6.0L Power Stroke Engine and Drivetrain

6.0L Power Stroke Engine and Drivetrain Discussion of the 6.0L Power Stroke diesel engine and drivetrain in the 2003-Up Super Duties and Excursions. No gas engine discussion allowed except on transmissions and drivetrain that pertain to all models. Please confine discussion of topics in this forum to those items that are specific to the 6.0L Power Stroke engine.

TheDieselstop.com is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 06-02-2008, 04:04 PM   #1 (permalink)
Member
 
Join Date: Dec 2005
Posts: 47
My Photos: (0)
Feedback Score: 0 reviews
Error Code P2285 2003 6.0L Diesel

I have a 2003 F250, with the 6.0L diesel, that I have had problems with it running correctly in the past few weeks. The service engine light came on and I had the codes read and it read code # P2285 which read "injector control pressure sensor circuit low". What does this actually mean? It has been idling rough from time to time and it has actually died on me 3 times. I was coasting down a hill one time and it just quit. It never gives any sign that is going to die. It will fire right back up every time. The idle will also idle high around 1000 rpm sometimes also. The service engine light doesn't stay on all the time, sometimes it goes off and other times it is on. I had an injector replace about a year ago and I thought this was another going the same direction. I wanted the dealership to replace all 8 but they wouldn't do that. They have had problems with those injectors, so when the warranty is up it is my problem. Should the dealer repladce all the injectors since they know there has been a problem? Is this something that is in the wiring harness? I have heard that there has been problems with those also.

Thanks for your help.
Nathan
ford861 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 06-02-2008, 05:58 PM   #2 (permalink)
Senior Member
 
Join Date: Sep 2005
Posts: 3,268
My Photos: (0)
Feedback Score: 0 reviews
ICP sensor and wiring harness are both common failure items on a 2003.
__________________
Mark
06 F250 CC SB FX4 Lariat;ARP studs;OEM gaskets;Banks exhaust;DynaTrac Ball joints;Coolant filter;High-Idle mod;RACCCV6000;JimmiJammers;Ravelco;SynchroMax xfer case;Fumoto valve;Harpooned;CPOhighwayProducts toolbox;tracrac;Fox Weatherboots;Wet Okole Seat Covers;BriteBox;Re-flashed;Quadzilla Recon XZT Fuel Press;Blue FPR spring;DashDAQ;PHP FICM;RiffRaff boots;DCPower250A;PowerInverter;Rancho7000's;BPD EGR cooler;One-piece HPOP fitting;D-plugs&standpipes;BPD Billet WaterPump;SCT w/ Matts SRL+;ELC Ultra;DuraTracs
bismic is offline   Reply With Quote Quick reply to this message
Old 06-04-2008, 12:19 PM   #3 (permalink)
Senior Member
 
my03psd's Avatar
 
Join Date: May 2007
Location: Swansea,Ma
Posts: 679
My Photos: (0)
Feedback Score: 0 reviews
I second the ICP sensor and harness.Had the same symptoms, had them changed and no problems since.Good luck.
__________________
3/28/03 F250 6.0L PSD ,TORQSHIFT,CC,SB,FX4,LARIAT
Charcoal Gray/Black,
Tint,RhinoLined,Sirius,Roll&Lock,Strobes,
SCT X3 Custom Tuned by Innovative,
58v FICM Tuned by Innovative,
MBRP Stainless 4" Turbo Back,
ISSPRO Pyro,Boost, & Trans Gauges
Prodigy Brake Controller,Remote Start and Turbo Cooldown,
High Idle Mod., PM-13A on the Oil Pan,
HFCM Plug Upgrade,DieselSite Coolant Filter,
Blue Spring Mod, 08 Diff Cover,
Banjo Bolt Mod, Energy Suspension Bushings,& Stanadyne every tank
my03psd is offline   Reply With Quote Quick reply to this message
Old 06-04-2008, 03:38 PM   #4 (permalink)
Member
 
Join Date: Dec 2005
Posts: 47
My Photos: (0)
Feedback Score: 0 reviews
Is the wiring harness to the ICP sensor the one that has had problems? Could the IPC sensor and/or wiring harness cause the engine to die all of a sudden? It has only done this at idle, but quite frequent.

Thanks
Nathan
ford861 is offline   Reply With Quote Quick reply to this message
Old 06-04-2008, 07:18 PM   #5 (permalink)
Senior Member
 
my03psd's Avatar
 
Join Date: May 2007
Location: Swansea,Ma
Posts: 679
My Photos: (0)
Feedback Score: 0 reviews
I was told that oil leaks around the sensor and runs down the pigtail,swells the wires and causes the sensor to get false readings.This causes problems for firing the injectors.
__________________
3/28/03 F250 6.0L PSD ,TORQSHIFT,CC,SB,FX4,LARIAT
Charcoal Gray/Black,
Tint,RhinoLined,Sirius,Roll&Lock,Strobes,
SCT X3 Custom Tuned by Innovative,
58v FICM Tuned by Innovative,
MBRP Stainless 4" Turbo Back,
ISSPRO Pyro,Boost, & Trans Gauges
Prodigy Brake Controller,Remote Start and Turbo Cooldown,
High Idle Mod., PM-13A on the Oil Pan,
HFCM Plug Upgrade,DieselSite Coolant Filter,
Blue Spring Mod, 08 Diff Cover,
Banjo Bolt Mod, Energy Suspension Bushings,& Stanadyne every tank
my03psd is offline   Reply With Quote Quick reply to this message
Old 06-04-2008, 07:25 PM   #6 (permalink)
Member
 
PSV8TD's Avatar
 
Join Date: Sep 2006
Location: Green Cove Springs, FL
Posts: 43
My Photos: (0)
Feedback Score: 0 reviews
The main wiring harness that runs around the EGR, FICM, and top fuel filter may be chaffed. Check the harness for cuts. Tape up anything that touches metal. My truck would just die all of a sudden then I replaced the ICP and harness then taped up all points the harness would touch metal and it runs fine. Good Luck, AJ
__________________
2003 F250, 6.0L, Fx4, CC, SB, Lariat, Arizona Beige, MBRP Turbo Back Straight Pipe 4inch, Bilstein shocks, Isspro pyro and boost gauges, Banks Six Gun & Speedloader, Auxillary idle, XM radio, CB, Backup lights, Recon Smoke cab & mirror lights, Timbrens
PSV8TD is offline   Reply With Quote Quick reply to this message
Old 02-11-2009, 01:30 PM   #7 (permalink)
Junior Member
 
Join Date: Feb 2009
Posts: 2
My Photos: (0)
Feedback Score: 0 reviews
I have the same problem with my truck. 2003 6.0l 4x4. But something that has happened along with the idle problem is when I have the cruise set it tries to down shift then can't find it and slams back in to gear. I was wondering if these two would be related. I called the Ford dealership to see what it would run for a complete diagnostic and that's $80 bucks starting out. And I just don't want to do that. Autozone didn't have the any help for the code though. They didin't have any associated parts with it.
Snoman03 is offline   Reply With Quote Quick reply to this message
Old 02-12-2009, 10:50 AM   #8 (permalink)
Lifetime Supporting Member
 
teamroper60's Avatar
 
Join Date: Feb 2003
Location: Troy, MO
Posts: 7,173
My Photos: (0)
Feedback Score: 0 reviews
P2285 is the code you get when the ICP sensor is bad.
__________________
2003 Toreador Red/Arizona Beige CC, DRW, Lariat, FX4, 6.0 PSD, Torqshift, born early Feb. 03; AIC; Silverline turbo-back dual exhaust; 155cc injectors from Full Force Diesel (Casserly); SCT with tuning by Tony Wildman (Total Diesel Performance) & Innovative Diesel; ARP studs; Dfuser regulated return; AFE PG7; Fumoto valve; B&W hitch, Di-Pricol gauges; DIESELSITE Coolant filter; Timbrens; Rancho RSXs; Michelin XPS Traction's; a whole bunch of "bling"; Connex 4300hp; Pioneer DEH6100BT; JL Audio 275w amp driving a 12" sub; JL Audio 50wx4 amp driving the Alpine door and rear seat speakers. 380.3hp/786.7ft-lbs (on my tow tune!)

pics

#43

SLAPS President and Webmaster
teamroper60 is offline   Reply With Quote Quick reply to this message
Old 02-13-2009, 07:42 AM   #9 (permalink)
Junior Member
 
Join Date: Feb 2009
Posts: 2
My Photos: (0)
Feedback Score: 0 reviews
Yeah, I understood the ICP, and I have that part figured out. But my question I guess is, it would seem if this is the problem, would that be causing the tranny miss-shift. It's believeable to think, the ICP sends out a bad input, the motor stalls for an instance, thus causing the tranny to try to downshift and then catch right back up. Any of this seem logical?
Snoman03 is offline   Reply With Quote Quick reply to this message
Old 02-13-2009, 01:59 PM   #10 (permalink)
Lifetime Supporting Member
 
teamroper60's Avatar
 
Join Date: Feb 2003
Location: Troy, MO
Posts: 7,173
My Photos: (0)
Feedback Score: 0 reviews
Quote:
Originally Posted by Snoman03 View Post
Yeah, I understood the ICP, and I have that part figured out. But my question I guess is, it would seem if this is the problem, would that be causing the tranny miss-shift. It's believeable to think, the ICP sends out a bad input, the motor stalls for an instance, thus causing the tranny to try to downshift and then catch right back up. Any of this seem logical?
Theoretically, I guess it would be possible that if your ICP is so out of whack that your rpms fall to a certain point, the trans might want to downshift, but I have never seen that happen and I have had my ICP replaced twice.

To the OP:

Even though the early 03 injector issue is well documented, Ford's stance is that they will only replace injectors under warranty upon a failure. Your dealer has no choice in the matter. They have to follow what Ford tells them or they eat the cost of the repair (including the parts cost).
__________________
2003 Toreador Red/Arizona Beige CC, DRW, Lariat, FX4, 6.0 PSD, Torqshift, born early Feb. 03; AIC; Silverline turbo-back dual exhaust; 155cc injectors from Full Force Diesel (Casserly); SCT with tuning by Tony Wildman (Total Diesel Performance) & Innovative Diesel; ARP studs; Dfuser regulated return; AFE PG7; Fumoto valve; B&W hitch, Di-Pricol gauges; DIESELSITE Coolant filter; Timbrens; Rancho RSXs; Michelin XPS Traction's; a whole bunch of "bling"; Connex 4300hp; Pioneer DEH6100BT; JL Audio 275w amp driving a 12" sub; JL Audio 50wx4 amp driving the Alpine door and rear seat speakers. 380.3hp/786.7ft-lbs (on my tow tune!)

pics

#43

SLAPS President and Webmaster
teamroper60 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Diesel Forum - TheDieselStop.com > 1999-2007 Ford Super Duties > 6.0L Power Stroke Engine and Drivetrain

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Diesel Forum - TheDieselStop.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



Wheel & Tire Center

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 07:56 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.