No start! - Page 2 - Diesel Forum - TheDieselStop.com
Ford Diesel Forum / Powerstroke Forum
Ford Diesel Forum / Powerstroke Forum
Go Back   Diesel Forum - TheDieselStop.com > 1999-2007 Ford Super Duties > 6.0L Power Stroke Engine and Drivetrain

6.0L Power Stroke Engine and Drivetrain Discussion of the 6.0L Power Stroke diesel engine and drivetrain in the 2003-Up Super Duties and Excursions. No gas engine discussion allowed except on transmissions and drivetrain that pertain to all models. Please confine discussion of topics in this forum to those items that are specific to the 6.0L Power Stroke engine.

TheDieselstop.com is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 10-19-2012, 08:56 AM   #16 (permalink)
Lifetime Supporting Member
Lifetime Supporting Member
 
04redstroker's Avatar
 
Join Date: Oct 2012
Location: Plymouth MN
Posts: 30
My Photos: (0)
Feedback Score: 0 reviews
Well I know that the ICP is bad the pigtail foresure broke the conn. when removing it, so I know that I'm going to have to remove the top half of the motor to replace it. Also I'm pushing 180,000 so I also want to clean the turbo.
But my AE scan tool should be here top of next week and I will check out the live data.
I know the price of those HPOP its insane! Now here is a question I have if it ends up being the HPOP should I just replace with a stocker or a upgraded one?
I really only plan on adding 175cc injectors in the future?
04redstroker is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 10-19-2012, 06:50 PM   #17 (permalink)
Junior Member
 
Join Date: Dec 2011
Location: Callao, Virginia
Posts: 22
My Photos: (0)
Feedback Score: 0 reviews
Dieselmac-how do I start my own thread? I have some questions about my 2003 excursion with a 6.0? Thanks-it's been a long time since I have been on here and need a little help getting going.
mugsbuttons is offline   Reply With Quote Quick reply to this message
Old 10-19-2012, 09:55 PM   #18 (permalink)
Senior Member
 
dieselmac's Avatar
 
Join Date: Apr 2009
Location: ByGod, Texas
Posts: 3,076
My Photos: (0)
Feedback Score: 0 reviews
Quote:
Originally Posted by 04redstroker View Post
Well I know that the ICP is bad the pigtail foresure broke the conn. when removing it, so I know that I'm going to have to remove the top half of the motor to replace it. Also I'm pushing 180,000 so I also want to clean the turbo.
But my AE scan tool should be here top of next week and I will check out the live data.
I know the price of those HPOP its insane! Now here is a question I have if it ends up being the HPOP should I just replace with a stocker or a upgraded one?
I really only plan on adding 175cc injectors in the future?
A stock pump will work fine with 175cc injectors.
__________________
Scott

2006 F-250 PSD, Lariat
Mods: All the usual stuff


"Let us endeavor so to live that when we come to die even the undertaker will be sorry" - Mark Twain
dieselmac is offline   Reply With Quote Quick reply to this message
Old 10-19-2012, 09:57 PM   #19 (permalink)
Senior Member
 
dieselmac's Avatar
 
Join Date: Apr 2009
Location: ByGod, Texas
Posts: 3,076
My Photos: (0)
Feedback Score: 0 reviews
Quote:
Originally Posted by mugsbuttons View Post
Dieselmac-how do I start my own thread? I have some questions about my 2003 excursion with a 6.0? Thanks-it's been a long time since I have been on here and need a little help getting going.
On the main page of the the 6.0L Engine and Drivetrain page, look just under the page number selection on the top right, right under that is a drop down for Thread Tools. The New Post link is in there.
__________________
Scott

2006 F-250 PSD, Lariat
Mods: All the usual stuff


"Let us endeavor so to live that when we come to die even the undertaker will be sorry" - Mark Twain
dieselmac is offline   Reply With Quote Quick reply to this message
Old 10-25-2012, 02:46 PM   #20 (permalink)
Lifetime Supporting Member
Lifetime Supporting Member
 
04redstroker's Avatar
 
Join Date: Oct 2012
Location: Plymouth MN
Posts: 30
My Photos: (0)
Feedback Score: 0 reviews
Alright, my AE arrived today and now I'm ready took hook it up to the truck, now the icp is still disconnected ( broke the end of the pig tail) now what sensors should I be looking at? And what values should they be at?

Thanks
04redstroker is offline   Reply With Quote Quick reply to this message
Old 11-13-2012, 11:26 AM   #21 (permalink)
Lifetime Supporting Member
Lifetime Supporting Member
 
04redstroker's Avatar
 
Join Date: Oct 2012
Location: Plymouth MN
Posts: 30
My Photos: (0)
Feedback Score: 0 reviews
It's been awhile!
Ok So I tore the truck down to the HPOP and when I popped of the cover I saw that the snap ring was only half on. Now could this be the cause of my problem? Also is there a way that you can tell or see if the HPOP is bad? It looks good from the outside, the ball is still inthere and I see nothing bad with the gear and no play either. The Ipr had little specs of dirt but I will be replacing that and the ICP, also will be repacing the pigtails.
04redstroker is offline   Reply With Quote Quick reply to this message
Old 11-13-2012, 06:24 PM   #22 (permalink)
Senior Member
 
Join Date: Dec 2002
Location: South Dakota
Posts: 1,170
My Photos: (0)
Feedback Score: 0 reviews
Not sure what snap ring you are referring to? How is the D-ring on the discharge tube that seals on pump cover?-have seen these blown before. Use blow gun with rubber tip to air test the discharge tube, branch tube, and high pressure oil rails and injectors-this will eliminate any air leaks from the hp pump to the oil rails/injectors. I would have air tested the system before tearing apart to verify the ipr is functioning and if there were any obvious air leaks.
djshum is offline   Reply With Quote Quick reply to this message
Old 11-17-2012, 10:41 PM   #23 (permalink)
Lifetime Supporting Member
Lifetime Supporting Member
 
04redstroker's Avatar
 
Join Date: Oct 2012
Location: Plymouth MN
Posts: 30
My Photos: (0)
Feedback Score: 0 reviews
Well I thought I would just finish up this thread. It ended up being the hpop the d ring did blow out. Also the ipr was & bad screen was torn. Icp pigtail was broken. So I pulled the top half of the motor apart change the pigtail, hpop, all the gaskets, changed the icp,ipr, cleaned the reservoir screen, cleaned clean and clean. Installed a oil bypass system now runs great!
04redstroker is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Diesel Forum - TheDieselStop.com > 1999-2007 Ford Super Duties > 6.0L Power Stroke Engine and Drivetrain

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Diesel Forum - TheDieselStop.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



Wheel & Tire Center

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 07:33 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.