2001 7.3L no oil pressure on guage - Diesel Forum - TheDieselStop.com
'99 & up 7.3L Power Stroke Engine and Drivetrain Discussion of the '99 & up 7.3L Power Stroke diesel engine and drivetrain in the 1999-Up Super Duty trucks and Excursions. No gas engine discussion allowed except on transmissions and drivetrain that pertain to all models. Please confine discussion of topics in this forum to those items that are specific to the 7.3L Power Stroke engine.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 05-19-2017, 08:37 AM Thread Starter
Junior Member
 
Join Date: May 2017
Posts: 1
My Photos: (0)
Feedback Score: 0 reviews
2001 7.3L no oil pressure on guage

A little back ground I have a 2001 f350 4x4 auto with 700,000 plus miles. The truck started needing to be plugged in to start and would fire right up after being plugged in for a couple hours. I did all that I knew how which was check the HPOP changed the sensor on top ICM I believe and never had luck however I always had oil pressure. I took the truck to the mechanic and he said the injectors would not pass a buzz test none of them. He then told me the computer on the fender needed to be changed and that would solve the problem now 900 dollars later he tells me the injectors are working with no issues and they passed the buzz test also the glow plugs were working correctly. Then he says we have something else going on now we have no oil pressure on the gauge when you try and turn over. Now it's going to cost me another 400 dollars for a new oil pump. I need help and guidance any thing would be greatly appreciated for I don't have allot of money to just throw away by parts changing.

Thanks , Dugan
Attached Thumbnails
Click image for larger version

Name:	IMG_0223.jpg
Views:	18
Size:	1.29 MB
ID:	109618   Click image for larger version

Name:	IMG_0230.jpg
Views:	22
Size:	795.3 KB
ID:	109642  
Dashry1 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 05-21-2017, 02:06 PM
Senior Member
 
petwolf's Avatar
 
Join Date: Apr 2013
Location: Moss Point, MS
Posts: 521
My Photos: (0)
Feedback Score: 0 reviews
First, get a new mechanic. Second the gauge on the dash just shows if there is pressure present. Could be a wire unpluged and oil pressure sensor or the sensor went bad. ICP is injection control pressure and it needs to read 500 psi to fire injectors. This is not the gauge on the dash. You need some one who understands these trucks and has proper equipment to read them. At 700k i would say you have some injector issues but not 1k worth.

2000 F350 Lariat auto 4x4 cc Dually hutch/harpoon mod, zoodad mod, prepump filter/separator, billet fpr gold spring DIY Tymar intake
petwolf is offline  
Sponsored Links
Advertisement
 
Reply

  Diesel Forum - TheDieselStop.com > 1999-2007 Ford Super Duties > '99 & up 7.3L Power Stroke Engine and Drivetrain

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Forum - TheDieselStop.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome