getting P0640 code??? - Diesel Forum - TheDieselStop.com
Ford Diesel Forum / Powerstroke Forum
Ford Diesel Forum / Powerstroke Forum
Go Back   Diesel Forum - TheDieselStop.com > 1999-2007 Ford Super Duties > 99 & up 7.3L Power Stroke Engine and Drivetrain

99 & up 7.3L Power Stroke Engine and Drivetrain Discussion of the 99 & up 7.3L Power Stroke diesel engine and drivetrain in the 1999-Up Super Duty trucks and Excursions. No gas engine discussion allowed except on transmissions and drivetrain that pertain to all models. Please confine discussion of topics in this forum to those items that are specific to the 7.3L Power Stroke engine.

TheDieselstop.com is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 08-13-2009, 03:12 PM   #1 (permalink)
Senior Member
 
Join Date: Jan 2006
Posts: 424
My Photos: (0)
Feedback Score: 0 reviews
getting P0640 code???

ok i just got this code 2 times. i figured out if i break torque it a little bit it will throw this code? P0640. its flashing the overdrive light when it trips it. the other day i got a code about the speed sensor or somethin but i had my old computer xle4 in it when it threw that code and the od light started flahing. i can't find any good code list and this is getting the best of me.........the tranny only has 8k on it. if anyone has any ideas please speak before my truck takes a joy ride off a cliff.....
__________________
early 99 f-250 315/75/16 3.5 inch fabtech shackle lift,intake,4" exhaust 5" single stacked,DIY t/c lock, billet t/c and shift kit on a fresh rebuild,beans tunes ,4 hella lights, 05 head light, 05 chrome grill,red wire pluged, HID lights 200k

other toys
2008 ltr450
2002 440ex
blandproud is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 08-13-2009, 03:15 PM   #2 (permalink)
Senior Member
 
Join Date: Jan 2006
Posts: 424
My Photos: (0)
Feedback Score: 0 reviews
this is what the code is

P0640 Manifold Intake Air Heater


WHY would the trans light be flashin for this code?????????????????
__________________
early 99 f-250 315/75/16 3.5 inch fabtech shackle lift,intake,4" exhaust 5" single stacked,DIY t/c lock, billet t/c and shift kit on a fresh rebuild,beans tunes ,4 hella lights, 05 head light, 05 chrome grill,red wire pluged, HID lights 200k

other toys
2008 ltr450
2002 440ex
blandproud is offline   Reply With Quote Quick reply to this message
Old 08-13-2009, 04:05 PM   #3 (permalink)
Senior Member
 
Join Date: Jan 2006
Posts: 424
My Photos: (0)
Feedback Score: 0 reviews
other code was

p0720 OSS Sensor circuit malfunction

od light also flashed on this one
__________________
early 99 f-250 315/75/16 3.5 inch fabtech shackle lift,intake,4" exhaust 5" single stacked,DIY t/c lock, billet t/c and shift kit on a fresh rebuild,beans tunes ,4 hella lights, 05 head light, 05 chrome grill,red wire pluged, HID lights 200k

other toys
2008 ltr450
2002 440ex
blandproud is offline   Reply With Quote Quick reply to this message
Old 08-13-2009, 05:43 PM   #4 (permalink)
Lifetime Supporting Member
Lifetime Supporting Member
 
Flywheel's Avatar
 
Join Date: Jul 2003
Location: Austin, TX
Posts: 3,404
My Photos: (6)
Feedback Score: 0 reviews
The OD did not flash on the air intake heater code, which has likely been removed, thus the reason for the code.

your VSS issue will trigger the flashing OD light. I would remove and clean the VSS.
__________________

99.5 F-250 CC LB 4x4 7.3 Red
Trail Boss Replacement Bumpers, Tool Box, Headache Rack, Full Length Running Boards, BFG AT/KO 285/75x16E, 2003 Cup Holder, Marinco Heater Plug, Weather Tech Rain Vents / Hood Guard, B&W GN Hitch, X-Springs, Rear 4" F350 Blocks, Hellwig front and rear sway bars, Airlift / Wireless, Duraflaps

Isspro A-Pillar Gauges, Isspro TTM, Ford AIS, Magnaflow 3.5" DP - 4" Exhaust, Garrett GTP38R Turbo, Turbo-Master, High Flow Outlet, Non EBV Pedestal, IH Up-Pipes, DS 203 degree Stat, OA, BTS Tranny, 6.0L Tranny cooler, DP-Tuner F6, FRX, Cass Stage 1s, T500 HPOP, DieselSite HPX

99 F-250 CC SB 4x4 7.3 White
Ranch Truck, Ranch Hand brush Guard, Original Cup Thrower, DP-TUner F6, 4" Turbo Back Magnaflow, AIS Intake, 6.0 Tranny Cooler, Ford 4R100HD, CM Flatbed

Autoenginuity
Flywheel is offline   Reply With Quote Quick reply to this message
Old 08-13-2009, 05:54 PM   #5 (permalink)
Member
 
YAMAHAMMER's Avatar
 
Join Date: Jul 2009
Location: London, Ohio
Posts: 50
My Photos: (3)
Feedback Score: 0 reviews
Send a message via Yahoo to YAMAHAMMER
Sorry, whats the OSS/VSS?
__________________
2001 F-250 4X4 140k
HOME MADE RESISTOR MOD (potentiometer type)
EDGE EVOLUTION
"TWEAKED" WASTEGATE
EBPV DELETE
CCV DELETE
AIH DELETE
SUNPRO PHANTOM II GAUGES
4" STRAIGHT TURBO BACK
DIESELSITE BOOST FOOLER
HOME MADE INTAKE
BULLYDOG SPRING KIT
YAMAHAMMER is offline   Reply With Quote Quick reply to this message
Old 08-13-2009, 05:59 PM   #6 (permalink)
Lifetime Supporting Member
Lifetime Supporting Member
 
Flywheel's Avatar
 
Join Date: Jul 2003
Location: Austin, TX
Posts: 3,404
My Photos: (6)
Feedback Score: 0 reviews
OSS - Output shaft speed sensor
VSS - vehicle speed sensor

so you may need to clean the OSS - not the VSS - do both....
__________________

99.5 F-250 CC LB 4x4 7.3 Red
Trail Boss Replacement Bumpers, Tool Box, Headache Rack, Full Length Running Boards, BFG AT/KO 285/75x16E, 2003 Cup Holder, Marinco Heater Plug, Weather Tech Rain Vents / Hood Guard, B&W GN Hitch, X-Springs, Rear 4" F350 Blocks, Hellwig front and rear sway bars, Airlift / Wireless, Duraflaps

Isspro A-Pillar Gauges, Isspro TTM, Ford AIS, Magnaflow 3.5" DP - 4" Exhaust, Garrett GTP38R Turbo, Turbo-Master, High Flow Outlet, Non EBV Pedestal, IH Up-Pipes, DS 203 degree Stat, OA, BTS Tranny, 6.0L Tranny cooler, DP-Tuner F6, FRX, Cass Stage 1s, T500 HPOP, DieselSite HPX

99 F-250 CC SB 4x4 7.3 White
Ranch Truck, Ranch Hand brush Guard, Original Cup Thrower, DP-TUner F6, 4" Turbo Back Magnaflow, AIS Intake, 6.0 Tranny Cooler, Ford 4R100HD, CM Flatbed

Autoenginuity
Flywheel is offline   Reply With Quote Quick reply to this message
Old 08-13-2009, 07:00 PM   #7 (permalink)
Senior Member
 
Join Date: Jan 2006
Posts: 424
My Photos: (0)
Feedback Score: 0 reviews
Quote:
Originally Posted by Flywheel View Post
The OD did not flash on the air intake heater code, which has likely been removed, thus the reason for the code.

your VSS issue will trigger the flashing OD light. I would remove and clean the VSS.

i have a early 99 which i believe does not have the intake heater.

Also what do you mean by the OD did not flash on the p0640 code? i can have it in park rev it and it will trip the OD light. ??? i just put in a newer pcm. it was a nvk4 but Jody flashed it to a Pmt1. could this have somethin to do with it? i don't get why it sets off the OD light for this code? only thing i can guess is the newer PCM has somethin to do with it?

Where are these sensores located ?
__________________
early 99 f-250 315/75/16 3.5 inch fabtech shackle lift,intake,4" exhaust 5" single stacked,DIY t/c lock, billet t/c and shift kit on a fresh rebuild,beans tunes ,4 hella lights, 05 head light, 05 chrome grill,red wire pluged, HID lights 200k

other toys
2008 ltr450
2002 440ex
blandproud is offline   Reply With Quote Quick reply to this message
Old 08-13-2009, 07:29 PM   #8 (permalink)
Senior Member
 
tbpower's Avatar
 
Join Date: Dec 2008
Posts: 856
My Photos: (0)
Feedback Score: 0 reviews
The code 640 is going to show up anytime you read the codes so don't necessarily link it with the overdrive flashing. If you have a newer computer it is going to be looking for the air intake heater that you said you don't have. The vss is on the rear differential on top of the "pumpkin".
__________________
2000 7.3 powerstroke. PHP 6 position chip (stock,high idle,60tow,80dd,100hp,no start) . 6637 riffraff filter kit . AIH delete. Oil crossover. 6.0 tranny cooler. In tank mods. Wicked Wheel. EBPV delete. Walker 21470 muffler. Riffraff FRX
tbpower is offline   Reply With Quote Quick reply to this message
Old 08-13-2009, 07:53 PM   #9 (permalink)
Senior Member
 
tbpower's Avatar
 
Join Date: Dec 2008
Posts: 856
My Photos: (0)
Feedback Score: 0 reviews
The oss is on the top rear of the tranny.
__________________
2000 7.3 powerstroke. PHP 6 position chip (stock,high idle,60tow,80dd,100hp,no start) . 6637 riffraff filter kit . AIH delete. Oil crossover. 6.0 tranny cooler. In tank mods. Wicked Wheel. EBPV delete. Walker 21470 muffler. Riffraff FRX
tbpower is offline   Reply With Quote Quick reply to this message
Old 08-13-2009, 11:33 PM   #10 (permalink)
Senior Member
 
Join Date: Jan 2006
Posts: 424
My Photos: (0)
Feedback Score: 0 reviews
so what should i do about the OD light? truck shifts fine and the OD light don't come on while driven either?? i am using a SCT to pull the codes. anybody have any advice?
__________________
early 99 f-250 315/75/16 3.5 inch fabtech shackle lift,intake,4" exhaust 5" single stacked,DIY t/c lock, billet t/c and shift kit on a fresh rebuild,beans tunes ,4 hella lights, 05 head light, 05 chrome grill,red wire pluged, HID lights 200k

other toys
2008 ltr450
2002 440ex
blandproud is offline   Reply With Quote Quick reply to this message
Old 08-13-2009, 11:39 PM   #11 (permalink)
Senior Member
 
tbpower's Avatar
 
Join Date: Dec 2008
Posts: 856
My Photos: (0)
Feedback Score: 0 reviews
re

Quote:
Originally Posted by Flywheel View Post
OSS - Output shaft speed sensor
VSS - vehicle speed sensor

so you may need to clean the OSS - not the VSS - do both....
I think I would go with the oss first and go from there.
__________________
2000 7.3 powerstroke. PHP 6 position chip (stock,high idle,60tow,80dd,100hp,no start) . 6637 riffraff filter kit . AIH delete. Oil crossover. 6.0 tranny cooler. In tank mods. Wicked Wheel. EBPV delete. Walker 21470 muffler. Riffraff FRX
tbpower is offline   Reply With Quote Quick reply to this message
Old 08-14-2009, 12:43 AM   #12 (permalink)
Senior Member
 
MilitiaAir's Avatar
 
Join Date: Jul 2008
Location: Fairbanks, AK
Posts: 178
My Photos: (4)
Feedback Score: 0 reviews
Send a message via MSN to MilitiaAir Send a message via Yahoo to MilitiaAir
I would clean the sensors and see if help. It might have something to do with the new PCM tho.
__________________
2000 F350 Lariat CC SRW 4x4 7.3 Turbo 4R100, 130K, Icon 8in Lift, EPBV Delete, AIH plug, HPO X-over line, CCV Mod, TS 6 pos Chip, 37x13.50x18 toyo MT's, Coolant filter kit, spin on trans filter kit, 203tstat w/ billet housing, MBRP 4in turbo back, 03 power heated tow mirrors, S&B Intake, Dpictol boost,pyro,tranny,hpop gauges, HID headlights, 08 rear bumper 95 F-350 CC SRW 4x4 7.3L Turbo E4OD 305K, Transgo Shift kit, Edge 100hp program, Warn Premium Hubs, K&N drop in, Blue Cam sensor, 105 gal Aux Tank, FPR Mod, CCV Mod. New Injectors than will be sold...
MilitiaAir is offline   Reply With Quote Quick reply to this message
Old 08-14-2009, 11:32 AM   #13 (permalink)
Senior Member
 
Join Date: Jan 2006
Posts: 424
My Photos: (0)
Feedback Score: 0 reviews
it just worries me cause it did it with the old pcm at first. i do have warrenty on tranny but i don't want to deal with the guy that built it cause he prob doesn't want to see my truck again after how long it was in the shop lol
__________________
early 99 f-250 315/75/16 3.5 inch fabtech shackle lift,intake,4" exhaust 5" single stacked,DIY t/c lock, billet t/c and shift kit on a fresh rebuild,beans tunes ,4 hella lights, 05 head light, 05 chrome grill,red wire pluged, HID lights 200k

other toys
2008 ltr450
2002 440ex
blandproud is offline   Reply With Quote Quick reply to this message
Old 08-14-2009, 03:23 PM   #14 (permalink)
Senior Member
 
Join Date: Jan 2006
Posts: 424
My Photos: (0)
Feedback Score: 0 reviews
hmmm i just got back from tranny shop..no codes present for the tranny. i also pulled the dp before i went over there. i could trip the od light when i had the dp in by barely giving it gas while on the break. i also pulled the plug off and reconected it, but i still got the od light after that....but now with the dp off it wont do it? i got over there told him what to do and bam nothin worked fine. ....so i still have dp off and MIGHT reconnect it and see if it happens but i don't know.....
__________________
early 99 f-250 315/75/16 3.5 inch fabtech shackle lift,intake,4" exhaust 5" single stacked,DIY t/c lock, billet t/c and shift kit on a fresh rebuild,beans tunes ,4 hella lights, 05 head light, 05 chrome grill,red wire pluged, HID lights 200k

other toys
2008 ltr450
2002 440ex

Last edited by blandproud; 08-15-2009 at 04:57 PM.
blandproud is offline   Reply With Quote Quick reply to this message
Old 08-15-2009, 12:10 PM   #15 (permalink)
Senior Member
 
TransBrain's Avatar
 
Join Date: Aug 2006
Location: Pacific NW
Posts: 196
My Photos: (0)
Feedback Score: 0 reviews
It sounds like the parameters for the output speed sensor circuit are corrupted with the tune or there may be some wierd electrical noise the tune is picking up.

When you're in Park, and you rev the engine, the output shaft which is what the OSS is reading should be zero. If it sets an OSS code in this situation, then the PCM is detecting a circiut problem or actual movement of the output shaft which we know is impossible. I have run into electrical noise problems in these type of situations and have installed noise suppression filters to get rid of them, however this kind of sounds like a tune, possible sensitivity issue. I'd still check

If you can monitor the output shaft speed data with your scan tool, try running your tune again to diagnois what the PCM is seeing. This is not an internal trans issue so your trans tech should be okay. It might be a good idea to let him know about the particulars in your case (the tune) so if a future problem were to arise, you/he aren't chasing your tail.

The guys are correct, the PO 640 will not cause trans limp mode
TransBrain is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Diesel Forum - TheDieselStop.com > 1999-2007 Ford Super Duties > 99 & up 7.3L Power Stroke Engine and Drivetrain

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Diesel Forum - TheDieselStop.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



Wheel & Tire Center

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 06:05 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.