idle fine, dead pedal when SES light on, light off- everything fine - Diesel Forum - TheDieselStop.com
Ford Diesel Forum / Powerstroke Forum
Ford Diesel Forum / Powerstroke Forum
Go Back   Diesel Forum - TheDieselStop.com > 1999-2007 Ford Super Duties > 99 & up 7.3L Power Stroke Engine and Drivetrain

99 & up 7.3L Power Stroke Engine and Drivetrain Discussion of the 99 & up 7.3L Power Stroke diesel engine and drivetrain in the 1999-Up Super Duty trucks and Excursions. No gas engine discussion allowed except on transmissions and drivetrain that pertain to all models. Please confine discussion of topics in this forum to those items that are specific to the 7.3L Power Stroke engine.

TheDieselstop.com is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 12-19-2007, 10:22 PM   #1 (permalink)
Junior Member
 
Join Date: Oct 2006
Location: New Orleans Metro
Posts: 9
My Photos: (0)
Feedback Score: 0 reviews
idle fine, dead pedal when SES light on, light off- everything fine

2001 F350 7.3 starts fine every time. Idles fine. Service engine soon light comes on; still idles good but accelerator is dead. SES light goes off and I can rev engine fine. Read a bazillion forums and changed the EBP tube, EBP sensor, gutted the EBP valve at the turbo and unplugged the two wire sensor there. Nothing, notta, nill...still having same problem. Can't stealership or shop it as I pull a trailer daily with my construction co in south Louisiana.

What's my next suggestion or step?

240,000 miles and not even considering a different vehicle [img]/forums/images/%%GRAEMLIN_URL%%/smile.gif[/img]
Clippercliff is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 12-19-2007, 10:28 PM   #2 (permalink)
Lifetime Supporting Member
Lifetime Supporting Member
 
Join Date: Oct 2006
Location: Muskegon ,Michigan
Posts: 8,051
My Photos: (1)
Feedback Score: 1 reviews
Re: idle fine, dead pedal when SES light on, light off- everything fine

Get the code ....
__________________
Rick.....
97 F 350 ...Lucky 13
"Most stuff's just stuck & needs hittin with a hammer .Supporter/End user of ShiftSolutions THE CURE E4/4R Trans Control. Helping Cancer patients and families
Special thanks to RacerX USA

action4478 is offline   Reply With Quote Quick reply to this message
Old 12-19-2007, 10:29 PM   #3 (permalink)
Senior Member
 
whitjo's Avatar
 
Join Date: Jun 2007
Location: East Tennessee
Posts: 1,126
My Photos: (0)
Feedback Score: 0 reviews
Re: idle fine, dead pedal when SES light on, light off- everything fine

<div class="ubbcode-block"><div class="ubbcode-header">Originally Posted By: clippercliff</div><div class="ubbcode-body">2001 F350 7.3 starts fine every time. Idles fine. Service engine soon light comes on; still idles good but accelerator is dead. SES light goes off and I can rev engine fine. Read a bazillion forums and changed the EBP tube, EBP sensor, gutted the EBP valve at the turbo and unplugged the two wire sensor there. Nothing, notta, nill...still having same problem. Can't stealership or shop it as I pull a trailer daily with my construction co in south Louisiana.

What's my next suggestion or step?

240,000 miles and not even considering a different vehicle [img]/forums/images/%%GRAEMLIN_URL%%/smile.gif[/img] </div></div>
X2 with ACTION get code.
TPS assembly is most likely faulty and the IVS is sticking.
IVS (idle validation switch) tells PCM "no pedal we are idling"
press the pedal and the switch don't say "PCM time to go!" so it just sits there thinking you still want to idle.
IIRC you replace the pedal assy, about 125.00 to your door.
Some have wd-40'ed the switch and loosened it up, worth a try!
it's on the pedal bracket, easy to see!
__________________
Early '99 F250 SD, 4X4, SuperCab, Long Bed, 7.3L "PowerStroke" Diesel, Auto, PMT1 PCM w/DPTuner 80 tow, 190K miles,
Volant intake, ISSPRO gauges, BDS front leveling kit, 4" straight piped, Dick Cepek 18x9 DC1-Chrome, Nitto Terra Grappler 325/65R18,

Pro GOD, Pro Guns, Pro Life Important Notice, Pro Life changes when someone breaks in.
whitjo is offline   Reply With Quote Quick reply to this message
Old 12-19-2007, 10:31 PM   #4 (permalink)
Junior Member
 
Join Date: Oct 2006
Location: New Orleans Metro
Posts: 9
My Photos: (0)
Feedback Score: 0 reviews
Re: idle fine, dead pedal when SES light on, light off- everything fine

no codes on my scangauge or my other code reader when ses light is on or off. Perhaps I have crappy code readers; not sure. Do you recommend one?
Clippercliff is offline   Reply With Quote Quick reply to this message
Old 12-19-2007, 10:36 PM   #5 (permalink)
Lifetime Supporting Member
 
klhansen's Avatar
 
Join Date: Jan 2003
Location: Eagle River, Alaska
Posts: 20,842
My Photos: (178)
Feedback Score: 0 reviews
Re: idle fine, dead pedal when SES light on, light off- everything fine

Most generic code readers won't get the codes off a PSD.

AutoEnginuity is a good one. http://www.autoenginuity.com

About $350 for hardware (DTC connector to laptop) and Enhanced Ford software package. Reads ALL PSD codes and will do nearly all the tests that Ford can do.
__________________
First truck -- 1929 Model A Ford pickup, restored from ground up. Wish I still had it!
99.5 F250 PSD Supercab LB 4x4, ZF-6 w/SB Con OFE, 3.73LS, Boost & pyro gauges, Swamps S175/146 injectors, DP 80 HP Econo PCM (classic version), AIS, coolant filter w/"hokum" bracket, regulated return, heated mirror mod, lighted cupholder, Marinco heater plug-in.

Hard or no-start? Check Here
klhansen is offline   Reply With Quote Quick reply to this message
Old 12-19-2007, 10:37 PM   #6 (permalink)
Senior Member
 
whitjo's Avatar
 
Join Date: Jun 2007
Location: East Tennessee
Posts: 1,126
My Photos: (0)
Feedback Score: 0 reviews
Re: idle fine, dead pedal when SES light on, light off- everything fine

<div class="ubbcode-block"><div class="ubbcode-header">Originally Posted By: clippercliff</div><div class="ubbcode-body">no codes on my scangauge or my other code reader when ses light is on or off. Perhaps I have crappy code readers; not sure. Do you recommend one? </div></div>

scanners:
cheap ones ain't good and
good ones ain't cheap!
AE is what I use, PC based, USB connection, very detailed data "grabber".
You can select the IVS output and watch it changed state from closed to open as you push the pedal down to verify proper operation. Invaluable to a "shade-tree" like me! [img]/forums/images/%%GRAEMLIN_URL%%/grin.gif[/img]
__________________
Early '99 F250 SD, 4X4, SuperCab, Long Bed, 7.3L "PowerStroke" Diesel, Auto, PMT1 PCM w/DPTuner 80 tow, 190K miles,
Volant intake, ISSPRO gauges, BDS front leveling kit, 4" straight piped, Dick Cepek 18x9 DC1-Chrome, Nitto Terra Grappler 325/65R18,

Pro GOD, Pro Guns, Pro Life Important Notice, Pro Life changes when someone breaks in.
whitjo is offline   Reply With Quote Quick reply to this message
Old 12-19-2007, 10:40 PM   #7 (permalink)
Junior Member
 
Join Date: Oct 2006
Location: New Orleans Metro
Posts: 9
My Photos: (0)
Feedback Score: 0 reviews
Re: idle fine, dead pedal when SES light on, light off- everything fine

Wow, thank you all for such a rapid response. It definately makes sense. I typically jump under the hood with problems but this is the component attached to the fuel pedal under the dash with wires going into it?

I'm heading outside now to try the wd-40 thing. Is that a part I can find locally or internet only?

Thank you and have a constructive day!
Clippercliff is offline   Reply With Quote Quick reply to this message
Old 12-19-2007, 10:47 PM   #8 (permalink)
Lifetime Supporting Member
Lifetime Supporting Member
 
Join Date: Oct 2006
Location: Muskegon ,Michigan
Posts: 8,051
My Photos: (1)
Feedback Score: 1 reviews
Re: idle fine, dead pedal when SES light on, light off- everything fine

Do you have a DVO meter?..
__________________
Rick.....
97 F 350 ...Lucky 13
"Most stuff's just stuck & needs hittin with a hammer .Supporter/End user of ShiftSolutions THE CURE E4/4R Trans Control. Helping Cancer patients and families
Special thanks to RacerX USA

action4478 is offline   Reply With Quote Quick reply to this message
Old 12-19-2007, 10:47 PM   #9 (permalink)
Senior Member
 
whitjo's Avatar
 
Join Date: Jun 2007
Location: East Tennessee
Posts: 1,126
My Photos: (0)
Feedback Score: 0 reviews
Re: idle fine, dead pedal when SES light on, light off- everything fine

on mine you can get down close to the pedal with the motor off and hear a faint "click" as the IV switch opens.

here is a good place
I would call to insure you get the correct part if you need it.
__________________
Early '99 F250 SD, 4X4, SuperCab, Long Bed, 7.3L "PowerStroke" Diesel, Auto, PMT1 PCM w/DPTuner 80 tow, 190K miles,
Volant intake, ISSPRO gauges, BDS front leveling kit, 4" straight piped, Dick Cepek 18x9 DC1-Chrome, Nitto Terra Grappler 325/65R18,

Pro GOD, Pro Guns, Pro Life Important Notice, Pro Life changes when someone breaks in.
whitjo is offline   Reply With Quote Quick reply to this message
Old 12-19-2007, 11:25 PM   #10 (permalink)
Junior Member
 
Join Date: Oct 2006
Location: New Orleans Metro
Posts: 9
My Photos: (0)
Feedback Score: 0 reviews
Re: idle fine, dead pedal when SES light on, light off- everything fine

I tried CRC screwloose on the "coils" by the pedal. It has helped quite a bit. The light goes off sooner and on-off more intermittently then before. I believe it has something to do with it. Thanks for the link; I'll make an order tonight. Question...the throttle position sensor came up around $35. Is that different than the IVS and pedal assembly ($125)? What's the correlation among them and how do I know which one to order?
Clippercliff is offline   Reply With Quote Quick reply to this message
Old 12-19-2007, 11:31 PM   #11 (permalink)
Junior Member
 
Join Date: Oct 2006
Location: New Orleans Metro
Posts: 9
My Photos: (0)
Feedback Score: 0 reviews
Re: idle fine, dead pedal when SES light on, light off- everything fine

I don't have a DVO meter and I am researching a new code reader. Hooking up to a laptop tells me these scanners mean business and I like that. Seven years old and high milage I need to invest in a good scanner. Thanks for all the leads!
Clippercliff is offline   Reply With Quote Quick reply to this message
Old 12-19-2007, 11:32 PM   #12 (permalink)
Senior Member
 
whitjo's Avatar
 
Join Date: Jun 2007
Location: East Tennessee
Posts: 1,126
My Photos: (0)
Feedback Score: 0 reviews
Re: idle fine, dead pedal when SES light on, light off- everything fine

<div class="ubbcode-block"><div class="ubbcode-header">Originally Posted By: clippercliff</div><div class="ubbcode-body">I tried CRC screwloose on the "coils" by the pedal. It has helped quite a bit. The light goes off sooner and on-off more intermittently then before. I believe it has something to do with it. Thanks for the link; I'll make an order tonight. Question...the throttle position sensor came up around $35. Is that different than the IVS and pedal assembly ($125)? What's the correlation among them and how do I know which one to order? </div></div>
See if it has one switch or two seperate ones. The earlier models had two and you have to replace the entire assy pedal and all(I did)
Later had one switch and IDK maybe it's just the switch you can R&R? Someone here should know, but you can call tomorrow and ask Bob for the correct part#. I can't say for sure that's it.
__________________
Early '99 F250 SD, 4X4, SuperCab, Long Bed, 7.3L "PowerStroke" Diesel, Auto, PMT1 PCM w/DPTuner 80 tow, 190K miles,
Volant intake, ISSPRO gauges, BDS front leveling kit, 4" straight piped, Dick Cepek 18x9 DC1-Chrome, Nitto Terra Grappler 325/65R18,

Pro GOD, Pro Guns, Pro Life Important Notice, Pro Life changes when someone breaks in.
whitjo is offline   Reply With Quote Quick reply to this message
Old 12-19-2007, 11:38 PM   #13 (permalink)
Senior Member
 
whitjo's Avatar
 
Join Date: Jun 2007
Location: East Tennessee
Posts: 1,126
My Photos: (0)
Feedback Score: 0 reviews
Re: idle fine, dead pedal when SES light on, light off- everything fine

<div class="ubbcode-block"><div class="ubbcode-header">Originally Posted By: clippercliff</div><div class="ubbcode-body">I don't have a DVO meter and I am researching a new code reader. Hooking up to a laptop tells me these scanners mean business and I like that. Seven years old and high milage I need to invest in a good scanner. Thanks for all the leads! </div></div>

It will pay for itself many times over! and get you some buddies you never knew you had!LOL

On edit: get you a DVO meter too.
__________________
Early '99 F250 SD, 4X4, SuperCab, Long Bed, 7.3L "PowerStroke" Diesel, Auto, PMT1 PCM w/DPTuner 80 tow, 190K miles,
Volant intake, ISSPRO gauges, BDS front leveling kit, 4" straight piped, Dick Cepek 18x9 DC1-Chrome, Nitto Terra Grappler 325/65R18,

Pro GOD, Pro Guns, Pro Life Important Notice, Pro Life changes when someone breaks in.
whitjo is offline   Reply With Quote Quick reply to this message
Old 12-25-2007, 06:58 PM   #14 (permalink)
Junior Member
 
Join Date: Dec 2007
Posts: 1
My Photos: (0)
Feedback Score: 0 reviews
Re: idle fine, dead pedal when SES light on, light off- everything fine

Same Problem........Idle Only!!! SES light is displayed .....tried using my code reader but pulled up nothing , Do I Need A Special Scan Tool????

I have the Actron CP1935 OBD II Auto Scanner
*BMW* is offline   Reply With Quote Quick reply to this message
Old 12-25-2007, 07:10 PM   #15 (permalink)
Lifetime Supporting Member
Lifetime Supporting Member
 
Kanman's Avatar
 
Join Date: Dec 2004
Location: Wichita, Ks.
Posts: 5,119
My Photos: (2)
Feedback Score: 0 reviews
Re: idle fine, dead pedal when SES light on, light off- everything fine

<div class="ubbcode-block"><div class="ubbcode-header">Originally Posted By: FordSuperDuty02DieselF250</div><div class="ubbcode-body">Same Problem........Idle Only!!! SES light is displayed .....tried using my code reader but pulled up nothing , Do I Need A Special Scan Tool????

I have the Actron CP1935 OBD II Auto Scanner </div></div>

Sounds like a TPS (throttle position sensor) gone bad. In other words, you need a new fuel pedal, they are fly by wire.

I don't know a thing about that scanner, but Ill bet ya it does not work with our trucks.
Kanman is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Diesel Forum - TheDieselStop.com > 1999-2007 Ford Super Duties > 99 & up 7.3L Power Stroke Engine and Drivetrain

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Diesel Forum - TheDieselStop.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



Wheel & Tire Center

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 01:15 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.