PCM "keep alive memory" error? 2000 PSD - Diesel Forum - TheDieselStop.com
Ford Diesel Forum / Powerstroke Forum
Ford Diesel Forum / Powerstroke Forum
Go Back   Diesel Forum - TheDieselStop.com > 1999-2007 Ford Super Duties > 99 & up 7.3L Power Stroke Engine and Drivetrain

99 & up 7.3L Power Stroke Engine and Drivetrain Discussion of the 99 & up 7.3L Power Stroke diesel engine and drivetrain in the 1999-Up Super Duty trucks and Excursions. No gas engine discussion allowed except on transmissions and drivetrain that pertain to all models. Please confine discussion of topics in this forum to those items that are specific to the 7.3L Power Stroke engine.

TheDieselstop.com is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 07-31-2006, 02:07 PM   #1 (permalink)
Member
 
Join Date: Aug 2005
Posts: 64
My Photos: (0)
Feedback Score: 0 reviews
PCM "keep alive memory" error? 2000 PSD

I'm geting VERY rough running and stalling on my 2000 Excursion PSD.


The code reader says " pcm keep alive memory" error...


I never had any problems with the trucks running until now...


Last week I put a CPS in it as it stalled out ( no rpm showing on tach while cranking) and at that time it show some code about the CPS sensor....


Today this new issue happened , it will start but, it idles rough and you can't rev the engine up very much at all....


I cleared the "pcm keep alive memory" code out and upon restart it just throws the same code and runs bad again.....


Do you guys have any ideas where I should be loking to fix this?


Thanks..... [img]/ubbthreads/images/graemlins/grin.gif[/img]
DynoTom is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 07-31-2006, 02:12 PM   #2 (permalink)
Banned
 
Join Date: Dec 2005
Location: Cheyenne WY - The Cowboy State
Posts: 6,292
My Photos: (38)
Feedback Score: 0 reviews
Re: PCM "keep alive memory" error? 2000 PSD

That KAM code can come from a few things, but doesn't cause any running issues. If you disconnect batteries, install/uninstall a chip, it will give the KAM code.

Do you get an SES light? If so, your code reader may not be capable of pulling the P codes, what kind of scanner are you using?
gregrob is offline   Reply With Quote Quick reply to this message
Old 07-31-2006, 02:17 PM   #3 (permalink)
Member
 
Join Date: Aug 2005
Posts: 64
My Photos: (0)
Feedback Score: 0 reviews
Re: PCM "keep alive memory" error? 2000 PSD

I have the Edge Evo that has the scanner on it, It really seems to have a hard time even at idle, when I give it throttle it really winds up slow, like its starving for fuel, I took the fuel filter cover off and the fuel look real clean?
DynoTom is offline   Reply With Quote Quick reply to this message
Old 07-31-2006, 02:24 PM   #4 (permalink)
Banned
 
Join Date: Dec 2005
Location: Cheyenne WY - The Cowboy State
Posts: 6,292
My Photos: (38)
Feedback Score: 0 reviews
Re: PCM "keep alive memory" error? 2000 PSD

Do you get the Check Engine Light?
gregrob is offline   Reply With Quote Quick reply to this message
Old 07-31-2006, 05:24 PM   #5 (permalink)
Senior Member
 
CSIPSD's Avatar
 
Join Date: Jan 2004
Location: Bend, Oregon
Posts: 4,743
My Photos: (52)
Feedback Score: 0 reviews
Re: PCM "keep alive memory" error? 2000 PSD

Sounds like the under valve cover harness has come unpluged, or is loose. The RAM code is just left over from reading and clearing the codes...
__________________
01 F-250 SC PSD,260k,16 Isspro Gauges, AFE-2,CCV Mod,IAH delete,map reg,Modded H2e, 6.0 IC, 230/100 from P.I.S, Studs, 910 springs, Forged rods, Water injection,Swamps Tuning and IDM, MBRP 4" dual's, Aero, 6" tip's, 4" Revtek lift, 37/12.5/16.5 MT's
Joe
CSIPSD is offline   Reply With Quote Quick reply to this message
Old 07-31-2006, 08:20 PM   #6 (permalink)
KRP
Senior Member
 
Join Date: Jan 2003
Location: Kuna, ID
Posts: 774
My Photos: (0)
Feedback Score: 0 reviews
Re: PCM "keep alive memory" error? 2000 PSD

CPSs are sometimes bad right out of the box. Might put the new spare in and see what it does.
__________________
2000 F-250 Ex.Cab 4x4 Auto with Homemade Intake, 4" Exhaust, DP Tuner Chip, Tugger Kit, 2 HPOPs, ITP Fuel System/Boost Regulator, AC injectors, and Van Turbo/WW
KRP is offline   Reply With Quote Quick reply to this message
Old 07-31-2006, 08:48 PM   #7 (permalink)
Senior Member
 
Join Date: May 2005
Location: Hawaii/ Las Vegas
Posts: 144
My Photos: (0)
Feedback Score: 0 reviews
Re: PCM "keep alive memory" error? 2000 PSD

I have been getting the KAM code also. But mine idels fine. It just stalls out and runs again. I checked the UVC harness and plugs and it seems fine. Changed the CPS twice and still the same problem. I got the KAM code today again and a TPS code. Going to change the TPS and see what happens. I changed the ICP sensor and will also be changing the IPR. Hope that cures the problem, I just hate throwing money around.
__________________
00 "X" Limited 7.3L PSD 4X4, 4" Turbo Back Exhaust w/BTM, Edge Juice W/Attitude, EVO, Pro Comp Ultra Lite Trans Temp Gauge, Pyro, and Boost, Pro Comp 4"Lift, 35's w/Welds 16.5X10, Exhaust Brake, Airaid Cold Intake, Clear Headlights and Turn signals, Billet Overlay Grill, Centric Slotted Rotors, Zoodad, IC Wrap Delete, CCV Mod, WW, Nathan K3LA Horns w/5gal tank, 6.0 Trans cooler,.

2003 18FT Wanderer TB
HWNSTYLX is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Diesel Forum - TheDieselStop.com > 1999-2007 Ford Super Duties > 99 & up 7.3L Power Stroke Engine and Drivetrain

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Diesel Forum - TheDieselStop.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



Wheel & Tire Center

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 05:52 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.