Rough Idle, Bad Acceleration when warm HELP 2000 f-350 7.3L - Diesel Forum - TheDieselStop.com
Ford Diesel Forum / Powerstroke Forum
Ford Diesel Forum / Powerstroke Forum
Go Back   Diesel Forum - TheDieselStop.com > 1999-2007 Ford Super Duties > 99 & up 7.3L Power Stroke Engine and Drivetrain

99 & up 7.3L Power Stroke Engine and Drivetrain Discussion of the 99 & up 7.3L Power Stroke diesel engine and drivetrain in the 1999-Up Super Duty trucks and Excursions. No gas engine discussion allowed except on transmissions and drivetrain that pertain to all models. Please confine discussion of topics in this forum to those items that are specific to the 7.3L Power Stroke engine.

TheDieselstop.com is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 03-14-2005, 09:29 AM   #1 (permalink)
Junior Member
 
Join Date: Mar 2005
Posts: 7
My Photos: (0)
Feedback Score: 0 reviews
Rough Idle, Bad Acceleration when warm HELP 2000 f-350 7.3L

Out of the blue, our great running 7.3L started acting up. Upon start up (engine warm) the idle was very rough and when driving, acceleration was very sluggish. The entire truck vibrated, expecially when we hit 50.

Looking for ideas. Going to change the fuel filter and thermastat this evening. Appreciate input from anyone with experience with this problem.

Thanks
Rebecca
Becca4U is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 03-14-2005, 10:54 AM   #2 (permalink)
Junior Member
 
Join Date: Mar 2005
Posts: 7
My Photos: (0)
Feedback Score: 0 reviews
Re: Rough Idle, Bad Acceleration when warm HELP 2000 f-350 7.3L

Still looking for input on this problem!

Thanks
Becca4U is offline   Reply With Quote Quick reply to this message
Old 03-14-2005, 11:00 AM   #3 (permalink)
Member
 
Join Date: Jul 2002
Location: Michigan
Posts: 42
My Photos: (0)
Feedback Score: 0 reviews
Re: Rough Idle, Bad Acceleration when warm HELP 2000 f-350 7.3L

I am having similar problems and am trying the ICP sensor to check injector preasure. I will let you know if that helps me before you tear up your rig.
__________________
00/250 CREW, SWB, WD FLIP CHIP, A-PLR GAUGES.
250TANK is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Diesel Forum - TheDieselStop.com > 1999-2007 Ford Super Duties > 99 & up 7.3L Power Stroke Engine and Drivetrain

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Diesel Forum - TheDieselStop.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



Wheel & Tire Center

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 01:44 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.