Turn signal problem - Diesel Forum - TheDieselStop.com
Ford Diesel Forum / Powerstroke Forum
Ford Diesel Forum / Powerstroke Forum
Go Back   Diesel Forum - TheDieselStop.com > 1999-2007 Ford Super Duties > 99 & up 7.3L Power Stroke Engine and Drivetrain

99 & up 7.3L Power Stroke Engine and Drivetrain Discussion of the 99 & up 7.3L Power Stroke diesel engine and drivetrain in the 1999-Up Super Duty trucks and Excursions. No gas engine discussion allowed except on transmissions and drivetrain that pertain to all models. Please confine discussion of topics in this forum to those items that are specific to the 7.3L Power Stroke engine.

TheDieselstop.com is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 12-09-2005, 09:57 PM   #1 (permalink)
Senior Member
 
Join Date: Feb 2004
Location: MN
Posts: 346
My Photos: (0)
Feedback Score: 0 reviews
Turn signal problem

Hey guys, on the 2000 in my sig. I'm having an intermittant problem with the turn signals working perfect one minute and the next time I use them it might work and blink once or twice or not at all. It's got me frustrated. When it was blinking I checked the fuses under the hood and had power on both sides of the fuse and when it's not working there isn't any power to either side of the fuses (the 7.5 amp fuses for trailer turn/stop). I checked them because I have have had problems with those fuses blowing randomly (about twice a year for my trailer lights). When the turn signals are not working the hazards will work. Sorry for being so lengthy and hope this makes sense.
Thanks, Eric
__________________
2008 Chev 2500HD CC SB LTZ 4X4 Duramax/Allison, dual alternators, B&W Turnover ball w/ Companion, 8'2" Boss V-plow, Timbrens



SOLD----2002 F350 CC SB, 4x4, Lariat, leveling kit, 285 BFG's, AIS w/ fender sleeve, AIC, A-pillar Pyro, Boost, Trans, SCMT, 4" Magnaflow turbo-back, AIH delete, Weatherguard toolbox, 8'2" Boss V-plow, Hide-a-way strobes, B & W Turnover Ball and Fifth Wheel Companion, Fumoto, 203* Stat, Bilsteins, XM, C-Betrs, 136,000 miles,Hella 500's up front, Hella flush mount back-up lights, Speed Bleeders, Air Lift rear bags w/ inside controller

Pulling this:

2005 Alumascape 35 FLQ by Holiday Rambler w/ 5 slides

2007 F550 4x4 XLT, 11' contractor dump box, dual alternators, Tow Command, Upfitters, C-Betrs, #19000 GVW, Fumoto, 9'2" Boss V-Plow, 8' V-box salt/sander, LED flashers
prograde is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 12-10-2005, 12:22 AM   #2 (permalink)
Lifetime Supporting Member
 
klhansen's Avatar
 
Join Date: Jan 2003
Location: Eagle River, Alaska
Posts: 20,479
My Photos: (175)
Feedback Score: 0 reviews
Re: Turn signal problem

Your multifunction (turn signal, headlight, etc.) switch may be bad. The fuses you're checking are downstream of the multifunction switch.

I think there was also an issue with the wiring harness connector coming loose from the switch, which might cause your problem also.

Hope that helps.
__________________
First truck -- 1929 Model A Ford pickup, restored from ground up. Wish I still had it!
99.5 F250 PSD Supercab LB 4x4, ZF-6 w/SB Con OFE, 3.73LS, Boost & pyro gauges, Swamps S175/146 injectors, DP 80 HP Econo PCM (classic version), AIS, coolant filter w/"hokum" bracket, regulated return, heated mirror mod, lighted cupholder, Marinco heater plug-in.

Hard or no-start? Check Here
klhansen is offline   Reply With Quote Quick reply to this message
Old 12-10-2005, 12:28 AM   #3 (permalink)
Senior Member
 
Join Date: Apr 2004
Posts: 1,433
My Photos: (0)
Feedback Score: 0 reviews
Re: Turn signal problem

I've been seeing a lot of the multifuntction switches going bad lately. I just did one on my Excursion but also a lot on the cabs in the company I own. They are all Crown vics. It's an easy repair, takes 5-10 minutes to swap out.
__________________
2000 Black Excursion,PFC 2 piece rotors,Tipton tuned,BDP stage 2 singles, BDP H2E, AFE stage 2, Spearco 7.3, ITP Reg. return fuel system, Evans, BTS, 186,000 miles....And still goin' strong! Thanks Beansdieselperformance.com and Puredieselpower.com for all your help
BBBxcursion is offline   Reply With Quote Quick reply to this message
Old 12-10-2005, 08:16 AM   #4 (permalink)
Senior Member
 
Join Date: Feb 2004
Location: MN
Posts: 346
My Photos: (0)
Feedback Score: 0 reviews
Re: Turn signal problem

Thanks guys, so I should check the connection to the multi-function switch and if thats good then it's prob. the switch?
Eric
__________________
2008 Chev 2500HD CC SB LTZ 4X4 Duramax/Allison, dual alternators, B&W Turnover ball w/ Companion, 8'2" Boss V-plow, Timbrens



SOLD----2002 F350 CC SB, 4x4, Lariat, leveling kit, 285 BFG's, AIS w/ fender sleeve, AIC, A-pillar Pyro, Boost, Trans, SCMT, 4" Magnaflow turbo-back, AIH delete, Weatherguard toolbox, 8'2" Boss V-plow, Hide-a-way strobes, B & W Turnover Ball and Fifth Wheel Companion, Fumoto, 203* Stat, Bilsteins, XM, C-Betrs, 136,000 miles,Hella 500's up front, Hella flush mount back-up lights, Speed Bleeders, Air Lift rear bags w/ inside controller

Pulling this:

2005 Alumascape 35 FLQ by Holiday Rambler w/ 5 slides

2007 F550 4x4 XLT, 11' contractor dump box, dual alternators, Tow Command, Upfitters, C-Betrs, #19000 GVW, Fumoto, 9'2" Boss V-Plow, 8' V-box salt/sander, LED flashers
prograde is offline   Reply With Quote Quick reply to this message
Old 12-10-2005, 06:01 PM   #5 (permalink)
Senior Member
 
Join Date: Feb 2004
Location: MN
Posts: 346
My Photos: (0)
Feedback Score: 0 reviews
Re: Turn signal problem

bump
__________________
2008 Chev 2500HD CC SB LTZ 4X4 Duramax/Allison, dual alternators, B&W Turnover ball w/ Companion, 8'2" Boss V-plow, Timbrens



SOLD----2002 F350 CC SB, 4x4, Lariat, leveling kit, 285 BFG's, AIS w/ fender sleeve, AIC, A-pillar Pyro, Boost, Trans, SCMT, 4" Magnaflow turbo-back, AIH delete, Weatherguard toolbox, 8'2" Boss V-plow, Hide-a-way strobes, B & W Turnover Ball and Fifth Wheel Companion, Fumoto, 203* Stat, Bilsteins, XM, C-Betrs, 136,000 miles,Hella 500's up front, Hella flush mount back-up lights, Speed Bleeders, Air Lift rear bags w/ inside controller

Pulling this:

2005 Alumascape 35 FLQ by Holiday Rambler w/ 5 slides

2007 F550 4x4 XLT, 11' contractor dump box, dual alternators, Tow Command, Upfitters, C-Betrs, #19000 GVW, Fumoto, 9'2" Boss V-Plow, 8' V-box salt/sander, LED flashers
prograde is offline   Reply With Quote Quick reply to this message
Old 12-10-2005, 06:07 PM   #6 (permalink)
Lifetime Supporting Member
 
klhansen's Avatar
 
Join Date: Jan 2003
Location: Eagle River, Alaska
Posts: 20,479
My Photos: (175)
Feedback Score: 0 reviews
Re: Turn signal problem

[ QUOTE ]
Thanks guys, so I should check the connection to the multi-function switch and if thats good then it's prob. the switch?
Eric

[/ QUOTE ]

That'd be my guess. There's a troubleshooting guide for the switch, where you check continuity across the connector pins in various switch positions. If you need that let me know.
__________________
First truck -- 1929 Model A Ford pickup, restored from ground up. Wish I still had it!
99.5 F250 PSD Supercab LB 4x4, ZF-6 w/SB Con OFE, 3.73LS, Boost & pyro gauges, Swamps S175/146 injectors, DP 80 HP Econo PCM (classic version), AIS, coolant filter w/"hokum" bracket, regulated return, heated mirror mod, lighted cupholder, Marinco heater plug-in.

Hard or no-start? Check Here
klhansen is offline   Reply With Quote Quick reply to this message
Old 12-10-2005, 07:49 PM   #7 (permalink)
Senior Member
 
Join Date: Feb 2004
Location: MN
Posts: 346
My Photos: (0)
Feedback Score: 0 reviews
Re: Turn signal problem

Thanks klhansen. I'll probably pick-up a switch.
__________________
2008 Chev 2500HD CC SB LTZ 4X4 Duramax/Allison, dual alternators, B&W Turnover ball w/ Companion, 8'2" Boss V-plow, Timbrens



SOLD----2002 F350 CC SB, 4x4, Lariat, leveling kit, 285 BFG's, AIS w/ fender sleeve, AIC, A-pillar Pyro, Boost, Trans, SCMT, 4" Magnaflow turbo-back, AIH delete, Weatherguard toolbox, 8'2" Boss V-plow, Hide-a-way strobes, B & W Turnover Ball and Fifth Wheel Companion, Fumoto, 203* Stat, Bilsteins, XM, C-Betrs, 136,000 miles,Hella 500's up front, Hella flush mount back-up lights, Speed Bleeders, Air Lift rear bags w/ inside controller

Pulling this:

2005 Alumascape 35 FLQ by Holiday Rambler w/ 5 slides

2007 F550 4x4 XLT, 11' contractor dump box, dual alternators, Tow Command, Upfitters, C-Betrs, #19000 GVW, Fumoto, 9'2" Boss V-Plow, 8' V-box salt/sander, LED flashers
prograde is offline   Reply With Quote Quick reply to this message
Old 12-11-2005, 11:18 AM   #8 (permalink)
Member
 
Join Date: Oct 2005
Location: Detriot, MI
Posts: 33
My Photos: (0)
Feedback Score: 0 reviews
Re: Turn signal problem

I put a combo switch in mine as well for simular problems. I got codes as well from the GEM module.
__________________
2000 Ford F-350 4x4 PSD ZF6 Trans
Banks 4"exhaust, chip, wastegate
Chad73 is offline   Reply With Quote Quick reply to this message
Old 12-12-2005, 01:09 AM   #9 (permalink)
Senior Member
 
Join Date: Nov 2001
Location: Alaska
Posts: 525
My Photos: (0)
Feedback Score: 0 reviews
Re: Turn signal problem

Same as Chad73 a month ago.
__________________
Scott
Early 99, 4WD
Skydiver is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Diesel Forum - TheDieselStop.com > 1999-2007 Ford Super Duties > 99 & up 7.3L Power Stroke Engine and Drivetrain

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Diesel Forum - TheDieselStop.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



Wheel & Tire Center

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 06:44 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.