2000 F350 7.3 powerstroke no electrical - Diesel Forum - TheDieselStop.com
Ford Diesel Forum / Powerstroke Forum
Ford Diesel Forum / Powerstroke Forum
Go Back   Diesel Forum - TheDieselStop.com > 1999-2007 Ford Super Duties > 1999-2007 General Questions

1999-2007 General Questions General questions related to 1999-2007 Super Duty trucks. If it doesn't fit the other categories, post it here. Gas engine discussion that pertains to all models is allowed. Specific gas engine questions should use the Gas Engines forum.

TheDieselstop.com is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 09-21-2012, 09:33 PM   #1 (permalink)
Junior Member
 
Join Date: Sep 2012
Posts: 1
My Photos: (0)
Feedback Score: 0 reviews
2000 F350 7.3 powerstroke no electrical

ok, was using truck shut it off ran into a place came back out and I have no electrical power what so ever, both batteries are testing 12.5 but I have no electrical any where, head lights dont even turn on any ideas, and please specify a location of any fuseable links or relays I need to check.
phill99337 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 09-21-2012, 10:24 PM   #2 (permalink)
Lifetime Supporting Member
 
klhansen's Avatar
 
Join Date: Jan 2003
Location: Eagle River, Alaska
Posts: 20,796
My Photos: (178)
Feedback Score: 0 reviews
Welcome to TheDieselStop

Look at the starter relay on the passenger side fender just behind the battery. That's the main connection point for power. There are two wires there each with two fusible links there that supply power to 2 places, the GPR, IAHR and Alternator, and toward the rear over to the main Power Junction box on the driver's side. You should also check the main connection there on the front of the box. There's a cover there that slides up to uncover the terminal.
__________________
First truck -- 1929 Model A Ford pickup, restored from ground up. Wish I still had it!
99.5 F250 PSD Supercab LB 4x4, ZF-6 w/SB Con OFE, 3.73LS, Boost & pyro gauges, Swamps S175/146 injectors, DP 80 HP Econo PCM (classic version), AIS, coolant filter w/"hokum" bracket, regulated return, heated mirror mod, lighted cupholder, Marinco heater plug-in.

Hard or no-start? Check Here

Last edited by klhansen; 09-21-2012 at 11:14 PM.
klhansen is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Diesel Forum - TheDieselStop.com > 1999-2007 Ford Super Duties > 1999-2007 General Questions

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Diesel Forum - TheDieselStop.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



Wheel & Tire Center

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 07:38 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.