1993 7.3 problems (injector pump?) - Diesel Forum - TheDieselStop.com
Ford Diesel Forum / Powerstroke Forum
Ford Diesel Forum / Powerstroke Forum
Go Back   Diesel Forum - TheDieselStop.com > Ford Diesels > 7.3L IDI Diesels (Not Power Strokes)

7.3L IDI Diesels (Not Power Strokes) Technical discussion of topics related to vehicles powered by the 7.3 Liter In-Direct Injection Navistar engines.

TheDieselstop.com is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 02-04-2007, 12:19 PM   #1 (permalink)
Member
 
Join Date: Oct 2006
Location: Winston-Salem, NC
Posts: 60
My Photos: (0)
Feedback Score: 0 reviews
1993 7.3 problems (injector pump?)

A friend has a 93 with the Banks turbo, not really modified other than that. It has about 115K miles on it. Just recently, it will cut off when the clutch is pushed in. He says it idles fine, but anytime the clutch is pushed in it will cut off.

Another friend said it is the injector pump? Any info on best place to get one, how hard is it to install one, etc?

Thanks
Tacoma747 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 02-04-2007, 02:08 PM   #2 (permalink)
Senior Member
 
Join Date: Aug 2002
Location: near Cleveland, Ohio
Posts: 5,224
My Photos: (0)
Feedback Score: 0 reviews
Re: 1993 7.3 problems (injector pump?)

No need to replace the pump, the governor ring is just sticking. He needs to run some lubricating diesel additive through it. A little turn up of the idle screw will help until it gets cleared up.
__________________
1997 Ford F350 SRW 7.3L PSD
1985 Ford Ranger 2.3L 5 speed
1966 Mustang 200 I6, auto, 4 wheel disk, power brake retrofit, Corvette master.

Former vehicles, 1994 E350 7.3L IDI, 1985 International 1654 rollback, 6.9L IDI, (2) 1994 Ford E350 7.3L IDI, 1985 Ford F350 DRW 6.9L IDI, 1985 Ford F350 wrecker 6.9L IDI.

*dual ASE Master Certified, Automotive, Medium & Heavy trucks*

Owner / operator, Patriot Automotive, N Ridgeville OH
Mr_Roboto is offline   Reply With Quote Quick reply to this message
Old 02-04-2007, 05:21 PM   #3 (permalink)
Senior Member
 
Join Date: Oct 2004
Location: NC
Posts: 755
My Photos: (0)
Feedback Score: 0 reviews
Re: 1993 7.3 problems (injector pump?)

[ QUOTE ]
No need to replace the pump, the governor ring is just sticking. He needs to run some lubricating diesel additive through it. A little turn up of the idle screw will help until it gets cleared up.

[/ QUOTE ]

mrroboto, I am just curious how the clutch relates to this? Do you know?
thanks
__________________
1993 Ford IDI 7.3L
F-250
ZF-5 speed 4 wheel drive
Class 5 hitch
D load tires <img src="/ubbthreads/images/graemlins/frown.gif" alt="" />
super cab
18x,xxx miles.
Purchased 9-22-06
luckys420 is offline   Reply With Quote Quick reply to this message
Old 02-04-2007, 05:40 PM   #4 (permalink)
Senior Member
 
Join Date: Aug 2002
Location: near Cleveland, Ohio
Posts: 5,224
My Photos: (0)
Feedback Score: 0 reviews
Re: 1993 7.3 problems (injector pump?)

When the clutch is engaged, the trucks' inertia keeps the engine RPM up, even when you are off the throttle. Once you push the clutch in, the IP governor has to give more fuel to keep RPM up. When the governor gets gummed up, it can't react quite fast enough and you get stalling.

My truck does the same thing after I run it low on fuel (even after refilling), it must be sucking crap up from the bottom of the tank.
__________________
1997 Ford F350 SRW 7.3L PSD
1985 Ford Ranger 2.3L 5 speed
1966 Mustang 200 I6, auto, 4 wheel disk, power brake retrofit, Corvette master.

Former vehicles, 1994 E350 7.3L IDI, 1985 International 1654 rollback, 6.9L IDI, (2) 1994 Ford E350 7.3L IDI, 1985 Ford F350 DRW 6.9L IDI, 1985 Ford F350 wrecker 6.9L IDI.

*dual ASE Master Certified, Automotive, Medium & Heavy trucks*

Owner / operator, Patriot Automotive, N Ridgeville OH
Mr_Roboto is offline   Reply With Quote Quick reply to this message
Old 02-04-2007, 10:15 PM   #5 (permalink)
Senior Member
 
Join Date: Oct 2004
Location: NC
Posts: 755
My Photos: (0)
Feedback Score: 0 reviews
Re: 1993 7.3 problems (injector pump?)

ok. great. thanks alot.
__________________
1993 Ford IDI 7.3L
F-250
ZF-5 speed 4 wheel drive
Class 5 hitch
D load tires <img src="/ubbthreads/images/graemlins/frown.gif" alt="" />
super cab
18x,xxx miles.
Purchased 9-22-06
luckys420 is offline   Reply With Quote Quick reply to this message
Old 02-04-2007, 10:39 PM   #6 (permalink)
Member
 
Join Date: Oct 2006
Location: Winston-Salem, NC
Posts: 60
My Photos: (0)
Feedback Score: 0 reviews
Re: 1993 7.3 problems (injector pump?)

Diesel additive you put in the fuel, or somewhere else? Seems it would take awhile if it is the fuel kind since he can't really drive it (guess he could let it sit idle for a long time).

I know nothing about the IDI 7.3's, and to keep me from having too look too much, where exactly is the idle screw at?

Thanks, I am sure he will be very happy if it is not the injector pump.
Tacoma747 is offline   Reply With Quote Quick reply to this message
Old 02-05-2007, 02:58 AM   #7 (permalink)
Senior Member
 
cdnsarguy's Avatar
 
Join Date: Jan 2003
Location: Neepawa, Manitoba Canada
Posts: 20,672
My Photos: (109)
Feedback Score: 0 reviews
Re: 1993 7.3 problems (injector pump?)

Visit my gallery for pics of the IP.....
__________________
93 F250 7.3 IDI S/C XLT 4X4 E40D 3.55LS, Captains chairs, Tutone Mocha, Leer 48" Hiboy cap, FR & RR hitches, full DeeZee running boards. Factory ordered/delivered Jan 93

Toys: 2006 37' Triple E Embassy coach (powered by Cummins), 18' Sylvan Pro Fish with Mariner motors.

Proud Canadian BOOB man too!!

Please PRIVATE MESSAGE only!! ...
Please DO NOT.....visitor message me...
cdnsarguy is offline   Reply With Quote Quick reply to this message
Old 02-05-2007, 01:02 PM   #8 (permalink)
Member
 
GenLightening's Avatar
 
Join Date: Sep 2006
Location: Minden,NV
Posts: 61
My Photos: (0)
Feedback Score: 0 reviews
Re: 1993 7.3 problems (injector pump?)

Pull the fuel filter and fill it, or a new one, with the additive. Hope it clears it up.
__________________
1988 Chevy CC DRW w/a 7.3L IDI w/Banks Turbo
E4OD w/Baumann Transcommand
Racer-X triple disc TC
US Gear Exhaust Brake
4.10 Chevy Diff
GenLightening is offline   Reply With Quote Quick reply to this message
Old 02-05-2007, 07:09 PM   #9 (permalink)
Member
 
Join Date: Oct 2006
Location: Winston-Salem, NC
Posts: 60
My Photos: (0)
Feedback Score: 0 reviews
Re: 1993 7.3 problems (injector pump?)

Filled the fuel filter with additive (power source brand), truck sputtered for a little bit, but it runs fine now [img]/ubbthreads/images/graemlins/smile.gif[/img]

I am getting a free dinner out of this deal, saved him $1000 or more on an injector pump, at least for the night that is... I will be sure to update if it fails to KEEP working. I also put the additive in both his fuel tanks, and I bet he keeps using it [img]/ubbthreads/images/graemlins/smile.gif[/img]

Thanks for the help.
Tacoma747 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Diesel Forum - TheDieselStop.com > Ford Diesels > 7.3L IDI Diesels (Not Power Strokes)

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Diesel Forum - TheDieselStop.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



Wheel & Tire Center

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 05:19 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.