Blue smoke at idle, slight "miss"a - Diesel Forum -
7.3L IDI Diesels (Not Power Strokes) Technical discussion of topics related to vehicles powered by the 7.3 Liter In-Direct Injection Navistar engines.

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 04-26-2012, 05:12 PM Thread Starter
Junior Member
Join Date: Apr 2008
Posts: 6
Feedback Score: 0 reviews
Blue smoke at idle, slight "miss"a

I'm not a diesel mechanic and am a little scared to break this thing.
93 F250 7.3 IDI non turbo 4x4 139k

So...she smokes blue right from startup, and as long as it idles. It does not smoke while driving...unless..i am running 2k RPMs and I let off then she puffs blue for a few seconds.
I pulled off the CDR valve and cleaned it seems to be ok i can feel rubber gasket and rear hole is clear, if i blow in the small hole air goes past the gasket but only with a good amount of pressure applied. It had engine oil in it but not a ton.

Now to the starts right at startup and increases with RPM. It has been getting steadily worse and it seems to not have as much power (although it me be my imagination).
Also...I have NEVER seen black smoke on this truck no matter what im doing.
I loosened each injector line and every one of them made it run rough immediately. I have never had it timed

Am I looking at injector pump issue or what?

Last edited by laidback22; 04-26-2012 at 05:48 PM.
laidback22 is offline  
Sponsored Links

  Diesel Forum - > Ford Diesels > 7.3L IDI Diesels (Not Power Strokes)
Gear in this thread - Powered by O'Reilly Auto Parts

Quick Reply

Register Now

In order to be able to post messages on the Diesel Forum - forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome