HELP!!! GLOW PLUG RELAY WIRING - Diesel Forum - TheDieselStop.com
Ford Diesel Forum / Powerstroke Forum
Ford Diesel Forum / Powerstroke Forum
Go Back   Diesel Forum - TheDieselStop.com > Ford Diesels > 7.3L IDI Diesels (Not Power Strokes)

7.3L IDI Diesels (Not Power Strokes) Technical discussion of topics related to vehicles powered by the 7.3 Liter In-Direct Injection Navistar engines.

TheDieselstop.com is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 02-13-2011, 01:58 PM   #1 (permalink)
Junior Member
 
Join Date: Feb 2011
Posts: 9
My Photos: (0)
Feedback Score: 0 reviews
Exclamation HELP!!! GLOW PLUG RELAY WIRING

hey guys im new to the "online thread" group stuff.. but im gunna learn and i wanna become one into this brotherhood.. but i have an issue

i will be as exact as possible:

1992 F250 IDI 7.3 Ext cab 8Ft bed truck.

the guy i bought the truck from hooked up (which what i learned recently) was a bypass kit? for the glow plug timer.. so theres this switch he installed and told me when i need to start the truck i put the key in the ignition hit the switch on.. start the truck.. turn the switch off.. OK! easy enough..

the very next day.. the truck wont start (keep in mind i bought the truck from the orginal owner and he is a friend of mine not jerk)

so it was my fault i left the switch on.. DOHH! so bought new glow plugs for $10 a piece at autzone.. replaced them and boom she fired right up almost to good to be true.. next day.. same damn problem!.. so i said screw it.. im replacing the GLOW PLUG RELAY.

he added a switch to it and all that crap and i decided i wanted to take that out and let it be OEM and call it day.. right? wronggg.. after replacing the GPR (i got discouraged with the extra wires) i left it the way it was but with a new GPR.. but i think i messed up a wire or a ground or something because it still wont crank...

S0000 long story short.. every morning i have to pop the hood and fire up the struck off the starter solenoid and by shooting some starting fluid into the intake..

IM IN JERSEY (unfortunatley) and it FRIGGEN COLD.. its getting annoying.. can ANYONE FOR THE LOVE OF GOD- HELP ME.. pictures would be awesome if possible..

BETTER YET! anyone on this forum live in JERSEY? im in milltown (near east brunswick/north brunswick/new brunswick/ edison area)


THANKS TO EVERYONE IN ADVANCE FOR THE ONES WHO CAN HELP!!
im just a army soldier trying to get to ft dix everyday.. which i do, but with the PITA starup procedures i have to do every morning..


appreciate it guys/girls. thank you
Attached Thumbnails
HELP!!! GLOW PLUG RELAY WIRING-img00142-20110213-1734.jpg   HELP!!! GLOW PLUG RELAY WIRING-img00141-20110213-1734.jpg  

Last edited by Twiztedpiff; 02-13-2011 at 05:41 PM.
Twiztedpiff is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 02-13-2011, 02:10 PM   #2 (permalink)
Senior Member
 
cdnsarguy's Avatar
 
Join Date: Jan 2003
Location: Neepawa, Manitoba Canada
Posts: 20,671
My Photos: (109)
Feedback Score: 0 reviews
Hard to say what he really did.........

NEVER USE AN ON/OFF SWITCH........PUSH BUTTON ONLY should you want to control the best solid state system made....

What brand of GPs did you buy???? they are probably again burnt out if wrong ones.

If you hook up the controller as OEM was, it will automatically do all you need for a start.
I will PM you the start sequence of events.........

Check my photo's under my name for the GP wiring schematic.......
__________________
93 F250 7.3 IDI S/C XLT 4X4 E40D 3.55LS, Captains chairs, Tutone Mocha, Leer 48" Hiboy cap, FR & RR hitches, full DeeZee running boards. Factory ordered/delivered Jan 93

Toys: 2006 37' Triple E Embassy coach (powered by Cummins), 18' Sylvan Pro Fish with Mariner motors.

Proud Canadian BOOB man too!!

Please PRIVATE MESSAGE only!! ...
Please DO NOT.....visitor message me...

Last edited by cdnsarguy; 02-13-2011 at 02:13 PM.
cdnsarguy is offline   Reply With Quote Quick reply to this message
Old 02-13-2011, 03:02 PM   #3 (permalink)
Junior Member
 
Join Date: Feb 2011
Posts: 9
My Photos: (0)
Feedback Score: 0 reviews
pictures were somewhat helpful but i need a better picture of the controller and wires..


thanks for the post im glad someone saw it and took the time to read it and try and help..

anyone have pictures.?!?!?!?!


Twiztedpiff is offline   Reply With Quote Quick reply to this message
Old 02-13-2011, 03:17 PM   #4 (permalink)
Junior Member
 
Join Date: Feb 2011
Posts: 9
My Photos: (0)
Feedback Score: 0 reviews
anyone/?
Twiztedpiff is offline   Reply With Quote Quick reply to this message
Old 02-13-2011, 03:34 PM   #5 (permalink)
Senior Member
 
chuckster57's Avatar
 
Join Date: Apr 2008
Location: Central Valley, Ca.
Posts: 15,414
My Photos: (7)
Feedback Score: 1 reviews
Quote:
Originally Posted by Twiztedpiff View Post
anyone/?
Are you looking for a pic of the controller? If so I can post when I get home from work.
__________________
1994 F-350 7.3 IDI Turbo, crew cab, E4OD,4:10 L/S, LB, Dually Photos
ATS Turbo upgrades: 3" DP with 3" exhaust Magnaflow XL muffler: Pictures Here
2012 Copper Canyon 273 FWRET w/2 slides, Air Lift 5000 bags
Pillar pod: Autometer C2 Series gauges: pyro,trans, boost, water, oil pressure
Hypermax Cowl induction, K&N air filter, flex-a-lite 26K trans cooler with fan,Tekonsha prodigy
Train Horns: Pictures here

PM please not visitor message
chuckster57 is offline   Reply With Quote Quick reply to this message
Old 02-13-2011, 04:21 PM   #6 (permalink)
Junior Member
 
Join Date: Feb 2011
Posts: 9
My Photos: (0)
Feedback Score: 0 reviews
Quote:
Originally Posted by chuckster57 View Post
Are you looking for a pic of the controller? If so I can post when I get home from work.

im looking for a picture of the controller properly wired up.. for a IDI setup.. not a powerstoke. can u you be of some help?



Twiztedpiff is offline   Reply With Quote Quick reply to this message
Old 02-13-2011, 05:03 PM   #7 (permalink)
Senior Member
 
chuckster57's Avatar
 
Join Date: Apr 2008
Location: Central Valley, Ca.
Posts: 15,414
My Photos: (7)
Feedback Score: 1 reviews
Here you go!!

Quote:
Originally Posted by Twiztedpiff View Post
im looking for a picture of the controller properly wired up.. for a IDI setup.. not a powerstoke. can u you be of some help?
Since we are in the IDI FORUM:
Attached Thumbnails
HELP!!! GLOW PLUG RELAY WIRING-glow-plug-controller.jpg  
__________________
1994 F-350 7.3 IDI Turbo, crew cab, E4OD,4:10 L/S, LB, Dually Photos
ATS Turbo upgrades: 3" DP with 3" exhaust Magnaflow XL muffler: Pictures Here
2012 Copper Canyon 273 FWRET w/2 slides, Air Lift 5000 bags
Pillar pod: Autometer C2 Series gauges: pyro,trans, boost, water, oil pressure
Hypermax Cowl induction, K&N air filter, flex-a-lite 26K trans cooler with fan,Tekonsha prodigy
Train Horns: Pictures here

PM please not visitor message
chuckster57 is offline   Reply With Quote Quick reply to this message
Old 02-13-2011, 05:38 PM   #8 (permalink)
Junior Member
 
Join Date: Feb 2011
Posts: 9
My Photos: (0)
Feedback Score: 0 reviews
i need pictures of it installed on a vehicle actually if possible?

im having a really bad wiring issue with this friggen truck and they previous owner.. so im trying to compare to someone elses on there actual vehicle..

thx for the standard picture tho.. can u take one of the one on ur truck?
Twiztedpiff is offline   Reply With Quote Quick reply to this message
Old 02-13-2011, 05:40 PM   #9 (permalink)
Senior Member
 
Join Date: Nov 2010
Location: pacific northwest coast
Posts: 132
My Photos: (0)
Feedback Score: 0 reviews
Quote:
Originally Posted by Twiztedpiff View Post
S0000 long story short.. every morning i have to pop the hood and fire up the struck off the starter solenoid and by shooting some starting fluid into the intake..
If you are having to short the starter relay to get it to crank over then there is something wrong that is not related to the glow plugs ... Possibly a miswire from the ignition switch to the starter relay ...
__________________
1986 F250 4x4 Ranger XL ... 6.9 NA IDI ... C6 ... Stock (for now) ...
fordforever is offline   Reply With Quote Quick reply to this message
Old 02-13-2011, 05:40 PM   #10 (permalink)
Junior Member
 
Join Date: Feb 2011
Posts: 9
My Photos: (0)
Feedback Score: 0 reviews
picture of mine wired up incorrectly (i believe it is being it doesnt start on its own) has been added!

every day gotta use starting fliud.. is that bad to do to the truck?
Twiztedpiff is offline   Reply With Quote Quick reply to this message
Old 02-13-2011, 06:07 PM   #11 (permalink)
Junior Member
 
Join Date: Feb 2011
Posts: 9
My Photos: (0)
Feedback Score: 0 reviews
Quote:
Originally Posted by fordforever View Post
If you are having to short the starter relay to get it to crank over then there is something wrong that is not related to the glow plugs ... Possibly a miswire from the ignition switch to the starter relay ...
not true.. its liek 20 degrees outside... and i dont plug in the truck.. so when i spray the staring fluid in the engine i just fire it up off the solenoid being im standing right there.

i may have typed it wrong in the original thread.. i can spray the motor and go back into the truck and start it from the key as well....

ANYONE HAVE PICS OF THE CONTROLLER ON THERE TRUCK??
Twiztedpiff is offline   Reply With Quote Quick reply to this message
Old 02-13-2011, 06:16 PM   #12 (permalink)
Senior Member
 
chuckster57's Avatar
 
Join Date: Apr 2008
Location: Central Valley, Ca.
Posts: 15,414
My Photos: (7)
Feedback Score: 1 reviews
Quote:
Originally Posted by Twiztedpiff View Post
i need pictures of it installed on a vehicle actually if possible?

im having a really bad wiring issue with this friggen truck and they previous owner.. so im trying to compare to someone elses on there actual vehicle..

thx for the standard picture tho.. can u take one of the one on ur truck?
Here you go: If you need me to trace wires it might be a few days as the weather is getting bad and it's supposed to rain...

__________________
1994 F-350 7.3 IDI Turbo, crew cab, E4OD,4:10 L/S, LB, Dually Photos
ATS Turbo upgrades: 3" DP with 3" exhaust Magnaflow XL muffler: Pictures Here
2012 Copper Canyon 273 FWRET w/2 slides, Air Lift 5000 bags
Pillar pod: Autometer C2 Series gauges: pyro,trans, boost, water, oil pressure
Hypermax Cowl induction, K&N air filter, flex-a-lite 26K trans cooler with fan,Tekonsha prodigy
Train Horns: Pictures here

PM please not visitor message
chuckster57 is offline   Reply With Quote Quick reply to this message
Old 02-13-2011, 06:20 PM   #13 (permalink)
Junior Member
 
Join Date: Feb 2011
Posts: 9
My Photos: (0)
Feedback Score: 0 reviews
yeah see that doesnt look nearly close to what i have.. your glow plug wires are red???


did you see the pictures of mine?
Twiztedpiff is offline   Reply With Quote Quick reply to this message
Old 02-13-2011, 06:51 PM   #14 (permalink)
Senior Member
 
chuckster57's Avatar
 
Join Date: Apr 2008
Location: Central Valley, Ca.
Posts: 15,414
My Photos: (7)
Feedback Score: 1 reviews
Quote:
Originally Posted by Twiztedpiff View Post
yeah see that doesnt look nearly close to what i have.. your glow plug wires are red???
did you see the pictures of mine?
yeah I saw your pictures. The best way is to trace the wires. Mine is factory original as far as I know.
__________________
1994 F-350 7.3 IDI Turbo, crew cab, E4OD,4:10 L/S, LB, Dually Photos
ATS Turbo upgrades: 3" DP with 3" exhaust Magnaflow XL muffler: Pictures Here
2012 Copper Canyon 273 FWRET w/2 slides, Air Lift 5000 bags
Pillar pod: Autometer C2 Series gauges: pyro,trans, boost, water, oil pressure
Hypermax Cowl induction, K&N air filter, flex-a-lite 26K trans cooler with fan,Tekonsha prodigy
Train Horns: Pictures here

PM please not visitor message
chuckster57 is offline   Reply With Quote Quick reply to this message
Old 02-13-2011, 07:27 PM   #15 (permalink)
Junior Member
 
Join Date: Feb 2011
Posts: 9
My Photos: (0)
Feedback Score: 0 reviews
yea well whenever you have time to trace them (if you have time) would greatly be appreciated..


this is giving me a huge headache!! haha
Twiztedpiff is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Diesel Forum - TheDieselStop.com > Ford Diesels > 7.3L IDI Diesels (Not Power Strokes)

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Diesel Forum - TheDieselStop.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



Wheel & Tire Center

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 09:45 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.