misfire - Diesel Forum - TheDieselStop.com
7.3L IDI Diesels (Not Power Strokes) Technical discussion of topics related to vehicles powered by the 7.3 Liter In-Direct Injection Navistar engines.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 11-20-2012, 04:12 PM Thread Starter
Junior Member
 
Join Date: Nov 2012
Posts: 3
My Photos: (0)
Feedback Score: 0 reviews
misfire

I have an engine misfire on an international t444e 7.3l. It happens after the engine has warmed up and been ran for a while. I doesn't happen at any specific speed or under load, it just starts to misfire and gradually gets worse as time goes on. Sometimes the motor will even stall. We have changed the fuel filters so those are good and also changed the fuel pump. Oil level is good also. Any suggestions?
ryandude1 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 11-20-2012, 05:32 PM
Senior Member
 
chuckster57's Avatar
 
Join Date: Apr 2008
Location: Central Valley, Ca.
Posts: 17,101
My Photos: (7)
Feedback Score: 1 reviews
Welcome to the Diesel Stop!!
You have posted in the IDI forum. Your engine is pretty much the same thing as a Powerstroke.

I would "report" this thread and ask a moderator to move it, that way you'll get more exposure in the proper forum.

1994 F-350 7.3 IDI Turbo, crew cab, E4OD,4:10 L/S, LB, Dually
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

ATS Turbo upgrades: 3" DP with 3" exhaust Magnaflow XL muffler:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2012 Copper Canyon 273 FWRET w/2 slides, Air Lift 5000 bags
Pillar pod: Autometer C2 Series gauges: pyro,trans, boost, water, oil pressure
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Hypermax Cowl induction, K&N air filter, flex-a-lite 26K trans cooler with fan,Tekonsha prodigy
Train Horns:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


PM please not visitor message
chuckster57 is offline  
Sponsored Links
Advertisement
 
Reply

  Diesel Forum - TheDieselStop.com > Ford Diesels > 7.3L IDI Diesels (Not Power Strokes)

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Forum - TheDieselStop.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome