sinking brake pedal 92 f350 - Diesel Forum - TheDieselStop.com
Ford Diesel Forum / Powerstroke Forum
Ford Diesel Forum / Powerstroke Forum
Go Back   Diesel Forum - TheDieselStop.com > Ford Diesels > 7.3L IDI Diesels (Not Power Strokes)

7.3L IDI Diesels (Not Power Strokes) Technical discussion of topics related to vehicles powered by the 7.3 Liter In-Direct Injection Navistar engines.

TheDieselstop.com is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 11-24-2009, 09:46 PM   #1 (permalink)
Junior Member
 
Join Date: Nov 2009
Location: tampa fl
Posts: 3
My Photos: (0)
Feedback Score: 0 reviews
sinking brake pedal 92 f350

got a real ballbuster here fellows. hello, new to forum. longtime ford lover 33yrs ase master. usually solving others probs at my shop but not to proud to ask for help. 92 f350 dually 2wd 7.3 idi w rabs. got this truck with pedal on the floor cheap to use as hauller. replaced worn out drums, shoes, hardware, adj cable springs, everything at rear, new m/c old leaks, new booster, leaked vac on hard stop. new front lines rotten, new front calipers, boots shot pins also hard, sticking.cant get good brajke pedal. weird problem. engine off pedal feels ok on second application but first time sinks 4-5 inches.second stroke pedal feels good. leave pedal up for 20 seconds and back to low pedal. running have 3/4 travel mushy worse than ford usual. all napa new parts no rebuilds. tried 3 m/c cause feels like m/c problem. not m/c tried differnet parts store to rule out bad lot of mc. triple checked rear adjustment ok. the new rabs valve out of desperation. have seen them clog, go one way check valve, new rabs no help. didnt try remove spring trick ifound searching! GOOD oNE!!! old dog got him a new trick. truck will stop good reAR ABS WORKS CAN ALMOST LOCK FRONT BUT PEDAL SUCKS AND IS SCARY. NO LEAKS. COMPLETE NEW SYSTEM EXCEPT FOR HARDLINE, THEY LOOK GOOD, NOT RESTRICTED NO LEAKS. NOR PAD KNOCK BACK PROBLEM CAUSE TRUCK DOESNT HAVE NO MOVE TO HAVE THIS HAPPPEN. NO RED OR ABS LIGHT. DOUBTED VAC PROBLEM BUT CHECKED ANYWAY MORMAL PER FORD TEST. HAVE GOOD FLUID SHOT AT ALL 4 WHEELS BLEED 3 GALLONS FLUID POWER VACUUM BLEED, MANUEL 2 MAN ENG ON AND OFF. SERIOUS BENCH BLLED M/C EVERY TIME AND HAVNT MADE A DENT IN THIS ISSUE. SPENT ALOT OF TIME AND MONEY, TRUCK NOT SO CHEAP ANY MORE BUT DONT CARE, NOW ITS GETTING PERSONAL. ANY SUGGESTONS. NO LONGER AHVE ORG WHEEL CYLINDERS BUT THERE WAS ACHOICE WONDER MAYBE FUBARED AND USED WRONG SIZE. WOULD THEY FIT. USUALLY COMPARE OLD TO NEW BUT MAYBE MADE A MISTAKE. ANY SUGGESTIONS WELCOME. ILL BE BACK OFTEN AND AM SURE TO TRY TO HELP YOU GUYS OUT. HAVE ALLDATA AND SCANNER SO ACCESS TO TSB , WIRING SCHEMATICS NOT A PROBLEM. I HAVE BEEN REPAIRING FORD TRUCKS SINCE THE 70'S IN FLEET AND INDEPENDANT SETTINGS AND HAVE NEVER HAD A TRUCK GIVE ME FITS LIKE THIS. ONE FINAL THING DO NOTICE THAT BLEEDING PEDAL DROP IS TWICE AS FAR BLEEDING FRONT CIRCUIT REAR DROPS LESS?
gatoraid is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 11-24-2009, 11:13 PM   #2 (permalink)
Senior Member
 
Cjhstang's Avatar
 
Join Date: Feb 2007
Location: PA
Posts: 1,112
My Photos: (0)
Feedback Score: 0 reviews
i read on a post a while back about a spring that is in the abs. apparently this spring is soft and gets softer as time goes. This could be your culprit. lotsa ppl replaced it with a slightly stiffer spring and works great.
Wish i could remember who posted it... was prolly three or four months back. try the forum search engine on it.
__________________
F-350 4x4 1990
-'94 overhauled 5.9 Cummins P7100 Injection Pump w/ 4kgsk, 60lb valve springs, Hamilton performance cam, HX40 turbo, ARP head studs, New marine pistons and injectors, FASS system lift pump
-Homemade oem & engine harness with Dual electric fans
-'92 interior; '86 front clip; '04 Hydroboosted front and rear disc brake system; Slew of autometer gauges; dual 4.25" Stacks
-Rebuilt and upgraded my E4OD - billet input shaft and T.C. Remote mount Derale dual layer trans cooler; Baumann Trans Controller and Harness
-3" Body Lift, Cut-Out Bushwacker Fender Flares with 16x10 Eagle Alloy 186 on 33's

All done in the driveway and basement...
Cjhstang is offline   Reply With Quote Quick reply to this message
Old 11-24-2009, 11:17 PM   #3 (permalink)
Senior Member
 
Cjhstang's Avatar
 
Join Date: Feb 2007
Location: PA
Posts: 1,112
My Photos: (0)
Feedback Score: 0 reviews
Here is the thread. hope it helps

soft brake pedal!
__________________
F-350 4x4 1990
-'94 overhauled 5.9 Cummins P7100 Injection Pump w/ 4kgsk, 60lb valve springs, Hamilton performance cam, HX40 turbo, ARP head studs, New marine pistons and injectors, FASS system lift pump
-Homemade oem & engine harness with Dual electric fans
-'92 interior; '86 front clip; '04 Hydroboosted front and rear disc brake system; Slew of autometer gauges; dual 4.25" Stacks
-Rebuilt and upgraded my E4OD - billet input shaft and T.C. Remote mount Derale dual layer trans cooler; Baumann Trans Controller and Harness
-3" Body Lift, Cut-Out Bushwacker Fender Flares with 16x10 Eagle Alloy 186 on 33's

All done in the driveway and basement...
Cjhstang is offline   Reply With Quote Quick reply to this message
Old 11-25-2009, 09:03 AM   #4 (permalink)
Senior Member
 
cdnsarguy's Avatar
 
Join Date: Jan 2003
Location: Neepawa, Manitoba Canada
Posts: 20,672
My Photos: (109)
Feedback Score: 0 reviews
Have you checked the reaction disc in the booster is still in place......... check my photo link... if it drops out of place long pedal travel and through the windshild stops are produced. Have you done the vacuum test on my link.........
__________________
93 F250 7.3 IDI S/C XLT 4X4 E40D 3.55LS, Captains chairs, Tutone Mocha, Leer 48" Hiboy cap, FR & RR hitches, full DeeZee running boards. Factory ordered/delivered Jan 93

Toys: 2006 37' Triple E Embassy coach (powered by Cummins), 18' Sylvan Pro Fish with Mariner motors.

Proud Canadian BOOB man too!!

Please PRIVATE MESSAGE only!! ...
Please DO NOT.....visitor message me...
cdnsarguy is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Diesel Forum - TheDieselStop.com > Ford Diesels > 7.3L IDI Diesels (Not Power Strokes)

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Diesel Forum - TheDieselStop.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



Wheel & Tire Center

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 04:15 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.