Loosing power - Diesel Forum - TheDieselStop.com
General Diesel Discussion about diesels in general. All brands are welcome, please refrain from brand wars. Discussions about types of diesel fuel also go here.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 03-19-2017, 07:35 PM Thread Starter
Junior Member
 
Join Date: Mar 2017
Posts: 1
My Photos: (0)
Feedback Score: 0 reviews
Loosing power

I have 2002 Freightliner Columbia*with Detroit 60 Series. For last 2-3 weeks its loosing power. when I going up gear like 6th to seven then its very hard to keep up*speed. Most of the times I shift down and try again. My mechanic checked twice with the *computer but did not find any code but its very hard to work within the city with this truck. Today I am bobtail but my truck did not reach even*at 100 km. I checked with couple of mechanics but everybody had different view.
cks_sandhu is offline  
Sponsored Links
Advertisement
 
Reply

  Diesel Forum - TheDieselStop.com > Other Topics > General Diesel

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Forum - TheDieselStop.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome