Diesel Forum - TheDieselStop.com - View Single Post - IDM or valve issue
View Single Post
post #2 of (permalink) Old 10-15-2018, 10:52 PM
klhansen
Lifetime Supporting Member
 
klhansen's Avatar
 
Join Date: Jan 2003
Location: Eagle River, Alaska
Posts: 24,755
My Photos: (180)
I would suspect a defective replacement injector before a base engine issue, such as valve train.

The IDM failure code is probably a fluke. I've had that come up a few times, but have never had an IDM problem.

You could swap the #2 injector to another cylinder and see if the contribution fault follows it. If you put rebuilt injectors in, I would definitely suspect them.

Your injector provider is incorrect. Unless the '99 went in for the "cackle fix" and someone changed the #8 injector, it would have 8 AD injectors. The change to the AE in #8 required a PCM flash as well, and if not done would affect how it runs.

First truck -- 1929 Model A Ford pickup, restored from ground up. Wish I still had it!
'99.5 F250 PSD Supercab LB 4x4, ZF-6 w/SB Con OFE, 3.73LS, Boost & pyro gauges, Swamps S175/146 injectors, DP 80 HP Econo PCM (classic version
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
), AIS,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
regulated return,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
klhansen is offline  
 
 
For the best viewing experience please update your browser to Google Chrome