Diesel Forum - TheDieselStop.com - View Single Post - Suspected dirty injectors
View Single Post
post #3 of (permalink) Old 12-31-2018, 12:15 AM Thread Starter
bluenavigator
Senior Member
 
bluenavigator's Avatar
 
Join Date: Sep 2002
Location: Hutto, Texas
Posts: 723
My Photos: (5)
Yea, seen some of them at Tractor Supply Company. Must be good stuff.

The reason why I am thinking of the injectors being dirty, the engine does idle just fine, sitting in the driveway. When I drive the truck around the streets or down the highway, I can feel the engine kinda of stumble or not at the full power. I mean that there is noticeable loss of the power. It only happen during high RPM, not low RPM, which makes me think of injectors being dirty somehow.

I had replaced the o-rings on all 8 injectors with "updated" o-rings for new ultra low sulfur fuel, maybe 14 years ago. I got them at International dealer. $20 bucks per set for each injector.

Wonder if there is another possible cause of this... IPR? That one was never replaced. I do not know if it goes bad or not. How does one determine that IPR was bad or not?

I had the fuel pump replaced about 14 years ago because it leaked at the weep hole. I checked it while it was out, I am able to push the tappet (not sure what it was called) and it pump the fuel out as expected.

Bluenavigator

'95 F-350 XLT PSD, CC, 2WD, Garrett Turbo AR 1.1, 5spd ZF tranny, LUK, 4.10 Limited Slip, just added Dual Arm Tenisoner. Just added my ol' vacuum gauge to monitor my vacuum pump.
bluenavigator is offline  
 
 
For the best viewing experience please update your browser to Google Chrome