Diesel Forum - TheDieselStop.com - View Single Post - Non-Start Issue
Thread: Non-Start Issue
View Single Post
post #55 of (permalink) Old 04-19-2019, 05:55 PM Thread Starter
bgiebels
Lifetime Supporting Member
Lifetime Supporting Member
 
Join Date: Nov 2011
Location: Iowa
Posts: 270
My Photos: (0)
Send a message via AIM to bgiebels Send a message via MSN to bgiebels Send a message via Skype™ to bgiebels
Quote:
Originally Posted by bismic View Post
Yup, I was saying re-re, lol. It is easy to nick one of those o-rings. The oil rail needs to be lowered on as straight and as evenly as possible. Oil up the injector tops!! Not quite getting a good seal on the ball tube seal is a possibility also. Good idea to check. A lot of techs actually don't recommend messing with those unless they are pretty loose.
I have the parts to "re-re" seal the injector, it certainly isn't going to hurt anything. I'll do a better job of lubing the ball tubes up when installing the rail. I did notice that the rail wasn't exactly seating evenly so I also want to check to ensure there is nothing in the way, like an injector wire as well.

We'll give that a try and see what happens... That passenger side is a little harder to get the torque wrench into the back lower bolts but that shouldn't have the affect of a leaking #3 injector... but who knows...

Thanks Bismic,

2005 F350 SRW 4x4
  • Sinister Diesel EGR Delete
  • SCT Tuner
  • ARP Studs
  • Sinister Diesel Coolant Filter Kit
  • Updated Oil Cooler
  • Garrett Powermax Turbo
  • BD Diesel Up-Pipes
bgiebels is offline  
 
 
For the best viewing experience please update your browser to Google Chrome