Diesel Forum - TheDieselStop.com - View Single Post - 500 miles post injector job madness
View Single Post
post #6 of (permalink) Old 10-16-2019, 01:14 PM
DENNY
Senior Member
 
Join Date: Apr 1999
Location: Chugiak Alaska
Posts: 4,611
My Photos: (8)
You need to put some information on you truck in you sig block so we are not trying to guess what you have!!
Did you get the injectors rebuilt as stock injectors or some kind of upgrade (single shot,ect) if so did you get a chip programed for the injectors? Did the truck come with a chip/programer?

Do a search on the Hutch mod/Poon mod you will usually find both are done at the same time. The stock fuel bowl is a very good system however a regulated fuel return is good to have also (FRx is what I have run simple and low price). Once again do a search.
You could have a injector bad o-ring or two, bad injector, chip/programer causing the problem.
Don't just throw parts at it!!! You need to pull the codes and go from there. Also do a LOT OF READING before you do any changes. You have a 20 year old engine that most any O-ring/seal/system can start to fail so take your time when it comes to making changes. I am not a fan of rebuilt injectors but other things could be your problem fuel bowl is most likely not one of them.
DENNY

Early 1999 F350 AUTO 4x4 CC LB DRW 4.10 6.0 trans cooler, Front hitch, 2,000 hubs/ brakes, Bilstein shocks/steering stabilizer, Diesel site coolant filter 203 thermostat, EBV delete, new O-rings, new Oil cooler, RIFF RAFF FRX, Glow plug led, Pillar gauges, Lighted cupholder, Painless wiring fuze block, Harpoon/hutch mods, Removed axle blocks. Air bags, 5 wheel hitch, In bed 7 pin plug. Spare tire key delete. KLHANSEN on speed dial. 75,000 as of May 2019
DENNY is offline  
 
 
For the best viewing experience please update your browser to Google Chrome