Diesel Forum - TheDieselStop.com

Diesel Forum - TheDieselStop.com (https://www.thedieselstop.com/forums/)
-   Wheels, Tires, Brakes, and Suspension (https://www.thedieselstop.com/forums/f122/)
-   -   Brake issues: at my wits end!!!!!! (https://www.thedieselstop.com/forums/f122/brake-issues-my-wits-end-468178/)

fordmedic 10-04-2014 12:07 PM

Brake issues: at my wits end!!!!!!
 
I have been trying to figure out why my brake pedal goes almost all the way down to the floor. I have replaced the pads, drums, shoes, calipers, vacuum pump, wheel cylinders, Master cylinder X's 2, Brake booster. Bleed the brakes many times Any suggestions????? Thanks in advance.

FMTRVT 10-04-2014 03:08 PM

Pedal drop has only a few causes on your vehicle: hydraulic leak, master cylinder bypass, or internal bypass of the RABS valve.

People who have had the similar problem and list of repairs on your era truck usually find in the end it was the RABS valve, something you had not listed in the repair attempts.

Without knowing more of what you have done I would change out the valve. The problem here is finding a replacement! Some have just bypassed the valve with tubing to rid themselves of the problem. That works OK if the vehicle also has a rear brake PROPORTIONING valve. If it does not, then adding in an aftermarket unit then dialing in the proper setting to prevent excessive and dangerous rear wheel skids is the best action.

madpogue 10-04-2014 03:39 PM

Did you bleed the RABS valve? Did you adjust the rear shoes? Did you bench bleed the master cylinder before installing it?

fordmedic 10-04-2014 05:02 PM

I did not bleed the RABS. I did bench bleed the master cylinder. Thank you for the replies!!!!!!

fordmedic 10-04-2014 10:05 PM

Replaced and bled the RABS. The connector didn't match so I cut the one off the old RABS and matched up the wires. There is a spot/ connection on the rear axle and closest to the drivers side that pairs up the right and left to a square with a hole in it. It looks like its suppose to be connected. I don't know the official name of it.

gibrokich 11-01-2018 10:36 AM

Having very similar issues. I just bypassed the ABS valve after replacing all that you mentioned and brake pedal still slowly goes to the floor. Was wondering what your final solution was?

klhansen 11-01-2018 11:30 AM

Fordmedic hasn't been on the site in over 2 years, so may not be likely to reply.

I'll move your post to Wheels, Tires, Brakes and Suspension.

Jack (FMTRVT) may be more likely to see it there. He's the resident brake guru. :yesnod:

gibrokich 11-01-2018 07:26 PM

Thanks

oilcan1001 11-02-2018 10:38 AM

Quote:

Originally Posted by gibrokich (Post 4644168)
Having very similar issues. I just bypassed the ABS valve after replacing all that you mentioned and brake pedal still slowly goes to the floor. Was wondering what your final solution was?

I'm not sure what you mean by "bypassed ABS valve",

But I had a similar issue and here is my post on another forum with a link for a way to test ABS HCU.

I've had the same problem for a few years on my wifey's F150.
Had a dealer change master , all fluid, pads everything - no help.
Then after a while it started getting worse.

After some research I came across this thread and post #20 outlines how to check an ABS hydraulic control unit.
https://www.ford-trucks.com/forums/9...edal-fade.html

I changed the ABS hcu and all is back to normal

I dont think it's quite the same on our super duties, but it's a good place to start looking after the obvious has been checked, ( ie, leaks, air in lines, etc.)


All times are GMT -5. The time now is 02:57 AM.

Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.

vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

 
For the best viewing experience please update your browser to Google Chrome