Running rough - Diesel Forum - TheDieselStop.com
Power Stroke Excursions Technical discussion of the Ford Excursion SUV with the Power Stroke diesel.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 10-01-2018, 03:03 PM Thread Starter
Junior Member
 
Join Date: Aug 2016
Posts: 7
My Photos: (0)
Feedback Score: 0 reviews
Running rough

2002 7.3 running rough when it is hot. stalls out
the only DTC that comes up is P0603
anyone have any ideas
andrew034 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 10-01-2018, 03:39 PM
RT
Lifetime Supporting Member
Lifetime Supporting Member
 
RT's Avatar
 
Join Date: Dec 2009
Location: Texas
Posts: 14,296
My Photos: (0)
Feedback Score: 0 reviews
KAM codes are rarely relevant to diagnostics. Dying when hot is frequently related to a failing IPR valve solenoid. If it restarts after cooling off, that helps the diagnosis. You can pour cold water on the solenoid and see if it restarts right away.


Sent from my iPhone using Tapatalk

2003 F-250 XLT Crew Cab 7.3L, Chrome BigTex Grille Guard, Quad pillar - 3 ISSPRO gauges (trans, pyro, boost) and DP-Tuner F6; Roush fuel pressure / temperature / oil pressure gauges, Ford Severe Duty AIS, 31 row 6.0 transmission cooler, ScanGauge II, Marinco mod, Walker BTM, Full Force Stage 1 injectors

IF MY BODY IS EVER FOUND ON A JOGGING TRAIL JUST KNOW THAT I WAS MURDERED SOMEWHERE ELSE AND DUMPED THERE
RT is offline  
post #3 of 4 (permalink) Old 10-03-2018, 02:52 PM Thread Starter
Junior Member
 
Join Date: Aug 2016
Posts: 7
My Photos: (0)
Feedback Score: 0 reviews
Once cool ran great for about 20 minutes. then started to sputter and stalled.
let it cool down for an hour started rt up and the cycle started again. stalled out, pored cold water o n it and it did start up for a few seconds before stalling again.
as long as it is cold it is good. also looks like their is a lot of oil on the intake. not sure if they are related.

should I just replace the IPR valve and hope for the best or is their another possibility
andrew034 is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 10-03-2018, 03:10 PM Thread Starter
Junior Member
 
Join Date: Aug 2016
Posts: 7
My Photos: (0)
Feedback Score: 0 reviews
Quote:
Originally Posted by andrew034 View Post
Once cool ran great for about 20 minutes. then started to sputter and stalled.
let it cool down for an hour started rt up and the cycle started again. stalled out, pored cold water o n it and it did start up for a few seconds before stalling again.
as long as it is cold it is good. also looks like their is a lot of oil on the intake. not sure if they are related.

should I just replace the IPR valve and hope for the best or is their another possibility
Could this be a bad ICP sensor?
andrew034 is offline  
Sponsored Links
Advertisement
 
Reply

  Diesel Forum - TheDieselStop.com > Ford Diesels > Power Stroke Excursions

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Forum - TheDieselStop.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome