Diesel Forum - TheDieselStop.com

Diesel Forum - TheDieselStop.com (https://www.thedieselstop.com/forums/)
-   6.7L Upgrades and Aftermarket - Engine (https://www.thedieselstop.com/forums/f150/)
-   -   2011 F350 deleted w/ Mini-Max - Getting P0181 Code (https://www.thedieselstop.com/forums/f150/2011-f350-deleted-w-mini-max-getting-p0181-code-654132/)

swickstrom 01-27-2019 06:07 PM

2011 F350 deleted w/ Mini-Max - Getting P0181 Code
 
Hey Diesel Stop crew,

I just had my engine light come on and I could sure use some insight.

I have a 2011 F350 with a full delete and a Mini-Max tuner. Delete and tuner have been on the truck for well over a year now w/o any issues.

I used the Mini-Max to read the engine code, it's showing P0181 "Fuel Temperature Sensor". I Googled the code and saw some references to trucks with deletes & tuners and some comments on having a block heater plugged in but nothing that was really clear or helpful....I figured TDS forum would be a good place to get some better insight.

It was down in the 20's (F) last night, I did have the truck plugged in over night. I started it this a.m. to run a quick errand......initially there was no engine light but after going to the store and starting the truck again the engine light came on the first time. I made one more stop and when I started the truck that next time the light came on again.

Any insight and/or recommendations would be greatly appreciated. I don't want to clear the code if this is something I should be concerned about or get fixed immediately.

Thank you in advance for the help!

jimmy 01-28-2019 09:01 AM

https://www.ebay.com/i/163142057544?chn=ps

Googled "ford 6.7 fuel temp sensor" and that showed up. My truck with that engine is not here but I think it's on a fuel line near to the engine fuel filter. Unplug the connector and see if there is corrosion and if not replace the sensor. The other alternative is to pay diag charges for someone to tell you the same or they find something wrong with wiring chafed or something of that sort. The $22 part installed first is pretty good gamble as I know these have failed enough that they have been posted about on some other site I view.

swickstrom 01-28-2019 09:38 PM

Quote:

Originally Posted by jimmy (Post 4652728)
https://www.ebay.com/i/163142057544?chn=ps

Googled "ford 6.7 fuel temp sensor" and that showed up. My truck with that engine is not here but I think it on a fuel line near to the engine fuel filter. Un plug the connector and see if there is corrosion and if not replace the sensor. The other alternative is to pay diag charges for someoen to tell you the same or they fins something wrong with wiring chafed or something of that sort. The $22 part installed first is pretty good gamble as I know these have failed enough that they have been posted about on some site I view.

Jimmy - Thanks for the advise, I agree completely for ~$25-$30 I'll replace it and just see what happens.
Have a good one Sir!


All times are GMT -5. The time now is 04:42 AM.

Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.

vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

 
For the best viewing experience please update your browser to Google Chrome