Diesel Forum - TheDieselStop.com

Diesel Forum - TheDieselStop.com (https://www.thedieselstop.com/forums/)
-   '11-16 Upgrades and Aftermarket (https://www.thedieselstop.com/forums/f151/)
-   -   Trailer wiring extension into bed acting funny! (https://www.thedieselstop.com/forums/f151/trailer-wiring-extension-into-bed-acting-funny-621850/)

Jesus_man 07-17-2017 03:12 PM

Trailer wiring extension into bed acting funny!
 
I apologize now as this is second hand information on my BIL's truck, a 2016 6.7l.

He has just installed a trailer wiring extension into the bed of his truck. From what I understand, he's pulled the connector off behind the bumper, put in this new extension, and plugged it back into the factory bumper connector. Then ran the new wiring to the bed to use with his gooseneck.

So, from what I gather, if you plug the trailer directly into the new wiring location, nothing works and there are faults on the instrument cluster. However, if you plug it into the bumper location, the faults go away and everything works. If you again, move the plug to the bed location everything STILL works for a while.

I am not sure what causes the bed plug to stop working (turn truck off or unplug trailer??) and I can get that information, but it sounds like it happens often enough that he can't just keep moving the plug to get it all to work.

He's tested all the wiring with a meter to make sure all the wires or connected properly between the factory and the new extension. Seems like a computer issue of some sort not wanting to recognize the new location?? Any ideas? Thanks!

jimmy 07-17-2017 06:30 PM

He needs to very carefully inspect for any of the wires having touched inside taped or covered harness with the top side plug not connected. Then try again once that plug is in place. The issue may be in the top side plug. The computer knows only continuity to a trailer or a short in the wires. There is no recognition of wiring to be done or detected. I have installed several of those Curt harnesses and had no issues. I have had the end plug where trailer plug inserts have bent pins. He needs to look in the back of that new plug to see if there is anything wrong there. If he used a plug up top where he cut and stripped and then set screw secured wires into a plug the same thing goes as far as the end plug having issues that can make the lighting and electric brake circuit monitoring go nuts.

HeavyAssault 07-19-2017 07:43 AM

Isn't there any aftermarket harness that uses the OEM connections found on the underside of the receiver hitch?

Jesus_man 07-19-2017 08:14 AM

Yeah, I think that is what he used, as it was a plug-n-play operation. However, that is an assumption on my part as I don't actually know that. But from the conversation I had, it T's off that connection.

gearhead1011 07-19-2017 09:02 AM

Quote:

Originally Posted by HeavyAssault (Post 4448250)
Isn't there any aftermarket harness that uses the OEM connections found on the underside of the receiver hitch?

There is a factory harness that uses a connector that breaks out of the harness somewhere under the bed. For some reason not all of the superdutys have that connector so you have to use the aftermarket harness that tee's off of the back of the connector by the hitch. My truck is one that does not have the factory connector for the in-bed receptacle so I used the aftermarket one and have never had a problem with it.

larrgh 07-19-2017 08:44 PM

Quote:

Originally Posted by gearhead1011 (Post 4448314)
There is a factory harness that uses a connector that breaks out of the harness somewhere under the bed. For some reason not all of the superdutys have that connector so you have to use the aftermarket harness that tee's off of the back of the connector by the hitch. My truck is one that does not have the factory connector for the in-bed receptacle so I used the aftermarket one and have never had a problem with it.

All wide frame trucks came with the two connectors by the driver's side rear wheel/tire. The in-bed 7 pin connector was installed if one ordered the goose neck prep kit from the factory. The wide frame trucks came with the connectors even if bed delete was optioned.

Bed 7 pin harness - BC3Z-13A576-A

The narrow frame (no bed fleet/commercial/ambulance/etc) trucks did not have the two connectors by the driver's side rear wheel/tire.

gearhead1011 07-20-2017 11:39 PM

Quote:

Originally Posted by larrgh (Post 4448730)
All wide frame trucks came with the two connectors by the driver's side rear wheel/tire. The in-bed 7 pin connector was installed if one ordered the goose neck prep kit from the factory. The wide frame trucks came with the connectors even if bed delete was optioned.

Nope, not all of them. I went over mine several times before I bought the tee harness. There were a couple of other posts on here from others that did not have it also. http://www.thedieselstop.com/forums/...86/index2.html http://www.thedieselstop.com/forums/...gtails-287811/

big_blue 10-16-2017 10:45 PM

mine has given me trouble a couple of times. it's aftermarket. first time it wouldn't work and i realized it had come unplugged so reached up and plugged it in, then everything was screwy for a while and realized that the pigtail was clocked wrong at that same in-bed plug at the rear. you would think that you couldn't plug it in except for correctly, but i found a different way! every since then all has been well.

cjohnsonseed 02-01-2018 08:07 PM

Quick question, does anyone have the factory gooseneck plug in location in the bed. I am adding the in bed plug and have an idea where I want it but would like to use OEM location. I have googled for pics but couldn't find any. Thanks

larrgh 02-01-2018 10:10 PM

Here are some photos of the 7-pin plug in the bed. There are factory installed with goose neck prep kit

http://lh3.ggpht.com/_xwec34prd2E/S4...ease%20044.JPG

http://www.thedieselstop.com/forums/...6/#post2240483

cjohnsonseed 02-02-2018 04:45 AM

Thanks again

gearhead1011 02-02-2018 12:16 PM

Some pics and details of mine when I installed it.
http://www.thedieselstop.com/forums/...l-plug-309286/

A post with dimensions of the location that I used for locating mine.
http://www.thedieselstop.com/forums/...trucks-260895/


All times are GMT -5. The time now is 07:13 PM.

Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.

vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

 
For the best viewing experience please update your browser to Google Chrome