Strange blinker problem - Diesel Forum - TheDieselStop.com
'11-16 General Questions General questions related to 2011-Up Super Duty trucks. If it doesn't fit the other categories, post it here. Gas engine discussion that pertains to all models is allowed. Specific gas engine questions should use the Gas Engines forum.

 3Likes
  • 1 Post By diesel2121
  • 1 Post By ford_doctor
  • 1 Post By big_blue
 
LinkBack Thread Tools Display Modes
post #1 of 13 (permalink) Old 12-24-2017, 04:08 PM Thread Starter
Senior Member
 
big_blue's Avatar
 
Join Date: Apr 2003
Location: Dripping Springs, Texas
Posts: 375
My Photos: (0)
Feedback Score: 0 reviews
Strange blinker problem

So my right front blinker isn't working. blinks fast when selected but rear works (and headache rack too). stock bulbs, not LED. so i thought it would be an easy bulb replacement. it's not the bulb. i put 2 in the harness before i checked with a test light. my park lamp works on the bulb but no power to blinker. can't be a fuse since the rear is working. so my guess is turn signal switch? can i check to see if hot coming out of turn signal switch for the right front blinker? anyone know what color wire to check at the multifunction switch? or am i missing something else?

thanks everyone.

'99 F250 PSD 4wd CC LWB, 400+K Hard Miles!!! Sold
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Never been in the shop in it's life!!!
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


this truck was the WINNER of the 2013 Tough Truck Challenge by Ford Commercial Vehicles Division! that's how we got the '14!

'14 F350 LWB SRW Crew Cab Lariat

'00 Excursion 7.3 2wd
big_blue is offline  
Sponsored Links
Advertisement
 
post #2 of 13 (permalink) Old 12-24-2017, 07:39 PM
Junior Member
 
Join Date: Sep 2016
Posts: 22
My Photos: (0)
Feedback Score: 0 reviews
Quote:
Originally Posted by big_blue View Post
So my right front blinker isn't working. blinks fast when selected but rear works (and headache rack too). stock bulbs, not LED. so i thought it would be an easy bulb replacement. it's not the bulb. i put 2 in the harness before i checked with a test light. my park lamp works on the bulb but no power to blinker. can't be a fuse since the rear is working. so my guess is turn signal switch? can i check to see if hot coming out of turn signal switch for the right front blinker? anyone know what color wire to check at the multifunction switch? or am i missing something else?

thanks everyone.
Did you check the fluid?

Sent from my SAMSUNG-SM-G890A using Tapatalk
badbart likes this.
diesel2121 is offline  
post #3 of 13 (permalink) Old 12-25-2017, 02:28 PM Thread Starter
Senior Member
 
big_blue's Avatar
 
Join Date: Apr 2003
Location: Dripping Springs, Texas
Posts: 375
My Photos: (0)
Feedback Score: 0 reviews
ha ha, yeah...just changed it!

'99 F250 PSD 4wd CC LWB, 400+K Hard Miles!!! Sold
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Never been in the shop in it's life!!!
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


this truck was the WINNER of the 2013 Tough Truck Challenge by Ford Commercial Vehicles Division! that's how we got the '14!

'14 F350 LWB SRW Crew Cab Lariat

'00 Excursion 7.3 2wd
big_blue is offline  
Sponsored Links
Advertisement
 
post #4 of 13 (permalink) Old 12-25-2017, 07:45 PM
Senior Member
 
edjunior's Avatar
 
Join Date: Mar 2010
Posts: 757
My Photos: (0)
Feedback Score: 0 reviews
Did this just start happening, or has it been a while, and you're just getting around to addressing it? It sounds more like a short, or a loose or corroded wire somewhere.

Ed...KF5INW
2019 6.7L PSD XLT - Hatin' the payments, but lovin' the truck!
2010 Wildcat 28RKBS 5er
edjunior is offline  
post #5 of 13 (permalink) Old 12-26-2017, 05:33 AM
Lifetime Supporting Member
Lifetime Supporting Member
 
HeavyAssault's Avatar
 
Join Date: Oct 2000
Location: VA
Posts: 4,037
My Photos: (6)
Feedback Score: 0 reviews
I think the connectors and the pins inside can be a tad off making this happen.

2015 F-350 CCLB PSD 4X4 3.55 ELD

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Some stock stuff, some modded stuff, some deleted stuff.....
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
HeavyAssault is offline  
post #6 of 13 (permalink) Old 12-26-2017, 11:41 AM
Senior Member
 
ford_doctor's Avatar
 
Join Date: Jul 2004
Location: NJ Native
Posts: 4,478
My Photos: (1)
Garage
Feedback Score: 0 reviews
The front turn signal lamp circuits are FET circuits and the body control module will turn them off if excessive current is detected. The circuit overload or short circuit needs to be corrected then the module must pass a self test to clear any codes set before the lamp will function if this is the reason your turn signal is out. I have also been handed faulty bulbs in the past, try another bulb.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.




2019 Ford Fusion ENERGI Titanium Plug-in Hybrid
Ford Senior Master Diesel Technician
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Diesel Technician Society
Diesel Mentor Directory

ford_doctor is offline  
post #7 of 13 (permalink) Old 12-26-2017, 08:10 PM Thread Starter
Senior Member
 
big_blue's Avatar
 
Join Date: Apr 2003
Location: Dripping Springs, Texas
Posts: 375
My Photos: (0)
Feedback Score: 0 reviews
Thanks for the responses. Seems like this site isn't as active as it used to be. Guess we're all getting newer trucks?


Ford_doctor: I have a turn/park light on my front aftermarket bumper. I'm going to unplug that pigtail where i tapped into the blinker harness and see what happens. How often do the modules "self test?" This would make some sense of my situation since rear turn signal works and I have no power to my front turn signal.

HeavyAssault: I have no power to the bulb. But I'll check to make sure the connectors are lined up with bulb connectors. Now that I've read about this "body control module" seems like anything goes. If anyone can overcomplicate things now days I think they will.

edjunior: took me about 3 days to address the fast blinking right side. had to wait for weather to get a little nicer. I have an aftermarket park/turn lamp in my front bumper and although the park lamp still works, I need to look closely at it to make sure it doesn't have any issues.

'99 F250 PSD 4wd CC LWB, 400+K Hard Miles!!! Sold
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Never been in the shop in it's life!!!
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


this truck was the WINNER of the 2013 Tough Truck Challenge by Ford Commercial Vehicles Division! that's how we got the '14!

'14 F350 LWB SRW Crew Cab Lariat

'00 Excursion 7.3 2wd
big_blue is offline  
post #8 of 13 (permalink) Old 12-27-2017, 07:02 AM
Senior Member
 
ford_doctor's Avatar
 
Join Date: Jul 2004
Location: NJ Native
Posts: 4,478
My Photos: (1)
Garage
Feedback Score: 0 reviews
Quote:
Originally Posted by big_blue View Post
Ford_doctor: I have a turn/park light on my front aftermarket bumper. I'm going to unplug that pigtail where i tapped into the blinker harness and see what happens. How often do the modules "self test?" This would make some sense of my situation since rear turn signal works and I have no power to my front turn signal..
All four turn and stop lamp circuits are separate output circuits coming from the body control module. The module may or may not retry the circuit but from my experience a fault must be corrected before the circuit is re-enabled. Unless the root cause is an intermittent fault you will need a scan tool to run a self test and clear any relevant codes. Add on lighting is a common cause of lighting problems in these trucks - more so on trucks with upfitted bodies that have lights with wiring that was poorly done or the module was not configured to properly sense the load in the circuits. In those instances the rear lighting is affected and I rarely see issues with front lighting. Typically if there is an issue there there is snow plow wiring involved. The module is what makes your turn indicator flash fast to indicate a bulb out like the old flasher type systems and the rear light may flash normally. Do try disconnecting the add on lighting as that is a good place to start.
larrgh likes this.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.




2019 Ford Fusion ENERGI Titanium Plug-in Hybrid
Ford Senior Master Diesel Technician
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Diesel Technician Society
Diesel Mentor Directory


Last edited by ford_doctor; 12-27-2017 at 04:49 PM.
ford_doctor is offline  
post #9 of 13 (permalink) Old 12-27-2017, 04:59 PM Thread Starter
Senior Member
 
big_blue's Avatar
 
Join Date: Apr 2003
Location: Dripping Springs, Texas
Posts: 375
My Photos: (0)
Feedback Score: 0 reviews
Thank you sir I'll let you know what I find.

'99 F250 PSD 4wd CC LWB, 400+K Hard Miles!!! Sold
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Never been in the shop in it's life!!!
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


this truck was the WINNER of the 2013 Tough Truck Challenge by Ford Commercial Vehicles Division! that's how we got the '14!

'14 F350 LWB SRW Crew Cab Lariat

'00 Excursion 7.3 2wd
big_blue is offline  
post #10 of 13 (permalink) Old 12-29-2017, 09:57 AM
Junior Member
 
Join Date: Dec 2017
Posts: 1
My Photos: (0)
Feedback Score: 0 reviews
Quote:
Originally Posted by big_blue View Post
Thank you sir I'll let you know what I find.
I have been trying to diagnose an electrical problem on my 2017 F350. The front passenger turn signal (just the front),sometimes drops out. This only happens when my snowplow is hooked up to the truck. The side and back work fine. No snowplow;everything works OK.

I did find a TSB-- ( Q-269R1 ) that references ( Erratic operation of electrical features with snowplow and other high electrical load devices.
It references built before April 08.2017.
Also solution references TSB-17-0043 for service.

I haven't checked with dealer on my problem as yet, May help with yours.
Edit/Delete Message
f450buyer is offline  
post #11 of 13 (permalink) Old 12-29-2017, 10:22 AM
Senior Member
 
ford_doctor's Avatar
 
Join Date: Jul 2004
Location: NJ Native
Posts: 4,478
My Photos: (1)
Garage
Feedback Score: 0 reviews
Quote:
Originally Posted by f450buyer View Post
I have been trying to diagnose an electrical problem on my 2017 F350. The front passenger turn signal (just the front),sometimes drops out. This only happens when my snowplow is hooked up to the truck. The side and back work fine. No snowplow;everything works OK.

I did find a TSB-- ( Q-269R1 ) that references ( Erratic operation of electrical features with snowplow and other high electrical load devices.
It references built before April 08.2017.
Also solution references TSB-17-0043 for service.

I haven't checked with dealer on my problem as yet, May help with yours.
Edit/Delete Message
The bulletins Q-269, 17-0043 and 17-0052 are not related to this concern. Those bulletins address an issue with system voltage drops that cause certain modules like the HVAC, Radio and Dash to cut out and cause charging system indicator to illuminate. I want to point this out to prevent us from going off track here.

With YOUR truck the plow wiring or the isolation module is highly suspect. I have seen a couple of these recently. One was an open in the plow lighting jumper harness and the other was the plow lighting module. Both non OEM parts and problem. Hope this helps.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.




2019 Ford Fusion ENERGI Titanium Plug-in Hybrid
Ford Senior Master Diesel Technician
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Diesel Technician Society
Diesel Mentor Directory

ford_doctor is offline  
post #12 of 13 (permalink) Old 01-04-2018, 05:50 PM Thread Starter
Senior Member
 
big_blue's Avatar
 
Join Date: Apr 2003
Location: Dripping Springs, Texas
Posts: 375
My Photos: (0)
Feedback Score: 0 reviews
Well I unhooked both front aftermarket bumper lights from the harness and unhooked my headache rack lights (for good measure) from the trailer harness. Then I unhooked the batteries and turned the headlight switch on overnight to drain all remaining juice. Right blinker still flashes fast. My backup camera has also stopped working since the "reset." I'm sure it will come back soon whenever something updates, this happened about a month ago where it quit all of a sudden and started working again after a few days.

Might be time for a trip to the dealer...

By the way I can light both filaments up "manually" but there is no power in the socket harness.

'99 F250 PSD 4wd CC LWB, 400+K Hard Miles!!! Sold
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Never been in the shop in it's life!!!
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


this truck was the WINNER of the 2013 Tough Truck Challenge by Ford Commercial Vehicles Division! that's how we got the '14!

'14 F350 LWB SRW Crew Cab Lariat

'00 Excursion 7.3 2wd

Last edited by big_blue; 01-04-2018 at 05:54 PM. Reason: little more info
big_blue is offline  
post #13 of 13 (permalink) Old 01-30-2018, 10:16 PM Thread Starter
Senior Member
 
big_blue's Avatar
 
Join Date: Apr 2003
Location: Dripping Springs, Texas
Posts: 375
My Photos: (0)
Feedback Score: 0 reviews
Dealer replaced body control module.
ford_doctor likes this.

'99 F250 PSD 4wd CC LWB, 400+K Hard Miles!!! Sold
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Never been in the shop in it's life!!!
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


this truck was the WINNER of the 2013 Tough Truck Challenge by Ford Commercial Vehicles Division! that's how we got the '14!

'14 F350 LWB SRW Crew Cab Lariat

'00 Excursion 7.3 2wd
big_blue is offline  
Sponsored Links
Advertisement
 
Reply

  Diesel Forum - TheDieselStop.com > 2011 - 2016 Ford Super Duties > '11-16 General Questions

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Forum - TheDieselStop.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome