Lost power when I added Attitude ??? - Diesel Forum - TheDieselStop.com
Upgrades and Aftermarket - 6.0L Engine Upgrading or adding OEM or aftermarket equipment to your 2003-Up Super Duty or Excursion with 6.0L Power Stroke diesel engine. Please confine discussion of topics in this forum to those items that are specific to the 6.0L Power Stroke engine.

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 03-07-2004, 07:12 PM Thread Starter
Member
 
trs900's Avatar
 
Join Date: Feb 2003
Location: Jupiter, Fl
Posts: 78
My Photos: (4)
Feedback Score: 0 reviews
Lost power when I added Attitude ???

Sent my edge back for update, got it back truck would not start...called Edge they sent me a new one with a return label for bad one with out any ??? they sure do have good customer service ... Well I decided to add Attitude so when I got it I noticed it was Manufactured 2-14-2004 and it says on screen it is version 1.6.. I drilled my exhaust and mounted attitude... now the part I dont understand is when I set Attitude on 5/5 I dont have near the power or throttle response that I had with just Edge Juice.. it reads temperature ok.. etc...

To verify this I disconnected Attitude and with edge juice only all my power was back.. Is Attitude defective or did I not do the proper procedure when I started up attitude... I will call Edge tomorrow.. has any one else had this happen..


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


2003 350 Lariat CC DRW 4x4 6.0 5 speed auto 2002 build date magnaflow #15956 turbo back
trs900 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 03-07-2004, 10:35 PM
Senior Member
 
Strictly Diesel's Avatar
 
Join Date: Sep 2000
Location: Phoenix, AZ
Posts: 4,119
My Photos: (0)
Feedback Score: 3 reviews
Re: Lost power when I added Attitude ???

Did you connect the MAP sensor wire too? The Juice/Attitude combo will run like "doo doo" if the MAP wire is not connected as the Attitude won't fuel the motor without seeing boost.

Double check the MAP wire connection and if it still doesn't work right, check for continuity on the wires in the Edge MAP harness. I have had to swap that harness for a customer and it fixed all of his "low power" problems.

Dennis Schroeder - Co-Owner of Strictly Diesel

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
/
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
/
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Race Truck :: 6050# / 11.31 @ 120mph / Best 60' of 1.56 ... with "Built" Race Engine (Fuel Only!)
Race Truck :: 5980# / 10.965 @ 124mph / Best 60' of 1.54 ... with "Built" Race Engine (Nitrous)
Strictly Diesel is offline  
post #3 of 7 (permalink) Old 03-07-2004, 11:05 PM Thread Starter
Member
 
trs900's Avatar
 
Join Date: Feb 2003
Location: Jupiter, Fl
Posts: 78
My Photos: (4)
Feedback Score: 0 reviews
Re: Lost power when I added Attitude ???

No... that explanes it... I did not connect map sensor as wire did not come with Attitude they are sending it now...

Thanks I will wait till I get map sensor hooked up, then we will see..


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


2003 350 Lariat CC DRW 4x4 6.0 5 speed auto 2002 build date magnaflow #15956 turbo back
trs900 is offline  
Sponsored Links
Advertisement
 
post #4 of 7 (permalink) Old 03-08-2004, 07:07 AM
Senior Member
 
Join Date: Apr 1999
Location: Michigan
Posts: 1,017
My Photos: (2)
Feedback Score: 0 reviews
Re: Lost power when I added Attitude ???

You will know when you get it hooked up right. There will be no questions in your mind about it.

2011 Ford F250 Lariat, CC 6.7, 20's, ARE Topper, bedrug, EDGE CTS.

<a href="
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
target="_blank"><img src="http://mefi.us/images/fuelly/smallsig-us/89813.png" width="115" height="40" alt="Fuelly" title="Share and compare MPG at Fuelly" border="0" style="border:solid #ccc 1px;padding:4px;background:#fff;"/></a>
Dick is offline  
post #5 of 7 (permalink) Old 03-17-2004, 09:29 PM
Lifetime Supporting Member
 
teamroper60's Avatar
 
Join Date: Feb 2003
Location: Troy, MO
Posts: 7,228
My Photos: (0)
Feedback Score: 0 reviews
Re: Lost power when I added Attitude ???

I'm waiting on my Juice to arrive (any day now). I downloaded the instructions and have read through them. I'm wondering, will I need to plug in the MAP sensor cable if I'm not running the attitude??

Thanks.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
2003 Toreador Red/Arizona Beige CC, DRW, Lariat, FX4, 6.0 PSD, Torqshift, born early Feb. 03; AIC; Silverline turbo-back dual exhaust; 155cc injectors from Full Force Diesel (Casserly); SCT with tuning by Tony Wildman (Total Diesel Performance) & Innovative Diesel; ARP studs; Dfuser regulated return; AFE PG7; Fumoto valve; B&W hitch, Di-Pricol gauges; DIESELSITE Coolant filter; Timbrens; Rancho RSXs; Michelin XPS Traction's; a whole bunch of "bling"; Connex 4300hp; Pioneer DEH6100BT; JL Audio 275w amp driving a 12" sub; JL Audio 50wx4 amp driving the Alpine door and rear seat speakers. 380.3hp/786.7ft-lbs (on my tow tune!)
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


#43


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
President and Webmaster
teamroper60 is offline  
post #6 of 7 (permalink) Old 03-17-2004, 10:17 PM Thread Starter
Member
 
trs900's Avatar
 
Join Date: Feb 2003
Location: Jupiter, Fl
Posts: 78
My Photos: (4)
Feedback Score: 0 reviews
Re: Lost power when I added Attitude ???

No, if just using juice you are ok.. attitude plugged into juice then you have to hook it up..


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


2003 350 Lariat CC DRW 4x4 6.0 5 speed auto 2002 build date magnaflow #15956 turbo back
trs900 is offline  
post #7 of 7 (permalink) Old 03-17-2004, 10:37 PM
Lifetime Supporting Member
 
teamroper60's Avatar
 
Join Date: Feb 2003
Location: Troy, MO
Posts: 7,228
My Photos: (0)
Feedback Score: 0 reviews
Re: Lost power when I added Attitude ???

Thanks for the info!! That's what makes this site great. No matter what the question, someone will probably know the answer! [img]/ubbthreads/images/graemlins/biggrin.gif[/img]


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
2003 Toreador Red/Arizona Beige CC, DRW, Lariat, FX4, 6.0 PSD, Torqshift, born early Feb. 03; AIC; Silverline turbo-back dual exhaust; 155cc injectors from Full Force Diesel (Casserly); SCT with tuning by Tony Wildman (Total Diesel Performance) & Innovative Diesel; ARP studs; Dfuser regulated return; AFE PG7; Fumoto valve; B&W hitch, Di-Pricol gauges; DIESELSITE Coolant filter; Timbrens; Rancho RSXs; Michelin XPS Traction's; a whole bunch of "bling"; Connex 4300hp; Pioneer DEH6100BT; JL Audio 275w amp driving a 12" sub; JL Audio 50wx4 amp driving the Alpine door and rear seat speakers. 380.3hp/786.7ft-lbs (on my tow tune!)
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


#43


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
President and Webmaster
teamroper60 is offline  
Sponsored Links
Advertisement
 
Reply

  Diesel Forum - TheDieselStop.com > 1999-2007 Ford Super Duties > Upgrades and Aftermarket - 6.0L Engine

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Forum - TheDieselStop.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome