Extremely low power, P2290 - Diesel Forum - TheDieselStop.com
6.0L Power Stroke Engine and Drivetrain Discussion of the 6.0L Power Stroke diesel engine and drivetrain in the 2003-Up Super Duties and Excursions. No gas engine discussion allowed except on transmissions and drivetrain that pertain to all models. Please confine discussion of topics in this forum to those items that are specific to the 6.0L Power Stroke engine.

 
LinkBack Thread Tools Display Modes
post #1 of 11 (permalink) Old 01-23-2019, 11:51 PM Thread Starter
Member
 
HarleyFreeman's Avatar
 
Join Date: Feb 2008
Location: Central Texas
Posts: 45
My Photos: (0)
Feedback Score: 0 reviews
Extremely low power, P2290

Hey guys, I've read several threads concerning the P2290 DTC and I'm starting to form some ideas about what the issue is with the truck in my signature, but just wanted to run it by you more experienced folks before I tear into it in the coming days...


On the highway this morning doing around 75mph I started to notice that I was having to press the pedal more than usual and was slowly losing speed. Luckily I wasn't too far out of town and pulled off to head back home. Before too long I was barely maintaining the 30mph speed limit in town and had cars stacked up behind me. It was getting progressively worse and after about a mile was crawling along at 10-15 mph. At this point I pulled off into a parking lot and turned it off while I waited for my wife to arrive. After she arrived about 10 minutes later I went to start it and it sputtered and died. Another crank and it sputtered a little but then idled fine. But still no power, absolutely crawling at maybe 5mph.



While I was crawling along I started up Torque Pro on my phone to take a look at things. With the pedal to the floor the IPR duty cycle was around 85% but my HPOP pressure was only showing around 500psi. FICM main power read 49V, exhaust looked normal and no rough idle, so I'm thinking it's probably not the FICM. Given the way it sputtered and had a hard time starting after 10 minutes shut down - but then idled smoothly once started - I was thinking that the HPO system had lost pressure in that 10 minutes, so maybe this points to a leak in the HPO system like maybe a broken o-ring? As opposed to a faulty sensor or electrical problems?


Anyway, I appreciate any input any of you may have. Thanks in advance

2004 F350 6.0 PSD, Long Box SRW Crew Cab FX4
Completely stock, minus the EGR
320,000 miles so far
HarleyFreeman is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 01-24-2019, 03:10 PM
Senior Member
 
Join Date: Oct 2005
Location: Eastern VA
Posts: 1,366
My Photos: (0)
Feedback Score: 0 reviews
P2290=Injector pressure too low.

While deferring to some of the more experienced techs on here, it sounds like a HPOP or high pressure oil system leak. What does the IPR and ICP say when cranking the engine? Check it cold and then hot. Does it cold start OK?

2006 F250 Lariat Supercrew, ESOF 4x4, 18" tires, FX 4, HD Alt., block heater, Integrated Trailer Brake Controller, Upfitters, power rear window, cab lights - delivered 10/25/05

Ford Remote Start; High idle mod; Timbren load levelers, Scangauge II, Blue Spring upgrade, Quick Start 200 amp large frame alternator, 2 batteries January 2010; GPCM replace October 2011; 2 EGR valves; EGR Cooler replaced 12/30/11; Performance Machine & Mfg. coolant filter added 1/2/12; Rotella T6 5W40 oil; turned rotors, replaced brake pads for 1st time 1/7/12 101K miles; GPCM, both subharnesses and all 8 glowplugs replaced 1/5/13 at 118,000 miles; 2 Ford batteries replaced under battery warranty twice, the latest 9/18/2015; FICM power supply board replaced with Dorman board 11/20/13. Coolant flushed and replaced with Prestone ELC 9/27/14. STC fitting 10/19/14; Dummy Plugs 11/8/14; Turbo rebuilt 11/29/14; cold side CAC tube and boots replaced with metal tube 1/24/15; replaced hot side boots 1/30/16.

Last edited by Ford06; 01-24-2019 at 03:14 PM.
Ford06 is offline  
post #3 of 11 (permalink) Old 01-25-2019, 11:06 AM Thread Starter
Member
 
HarleyFreeman's Avatar
 
Join Date: Feb 2008
Location: Central Texas
Posts: 45
My Photos: (0)
Feedback Score: 0 reviews
Quote:
Originally Posted by Ford06 View Post
P2290=Injector pressure too low.

While deferring to some of the more experienced techs on here, it sounds like a HPOP or high pressure oil system leak. What does the IPR and ICP say when cranking the engine? Check it cold and then hot. Does it cold start OK?
Thanks for the reply. Yeah, the code is definitely injector pressure too low, I was just trying to gain a little more confidence that it's an actual leak as opposed to some faulty sensor or wiring so I have a better idea what to look for. I think you're right, though, I'm leaning toward it being an actual leak. I'm not going to be able to touch the truck until maybe Sunday now, but I'll definitely get those readings while cranking and get back to you. What should I be looking for with those readings?

When I warm-started it Wednesday morning after only being off for ~10 minutes it had some trouble getting started - sputtered and died, then sputtered again before running smoothly. So right now I'm thinking it will probably be similar probably a little harder to get going but will then probably run smoothly. But I'll let you know about that as well.

My thinking is that this hard start after 10 min points to an actual leak because the HPO system would have lost pressure while it was off and would have to build it up again while cranking before it could operate the injectors. Hopefully my logic in this case is not too flawed, but somebody please correct me if it is!

Anyway, thanks again for the reply.

2004 F350 6.0 PSD, Long Box SRW Crew Cab FX4
Completely stock, minus the EGR
320,000 miles so far
HarleyFreeman is offline  
Sponsored Links
Advertisement
 
post #4 of 11 (permalink) Old 01-25-2019, 01:12 PM
Senior Member
 
Join Date: Oct 2005
Location: Eastern VA
Posts: 1,366
My Photos: (0)
Feedback Score: 0 reviews
I see you have a 2004. Which engine? Early or late? Is the ICP on the passenger side valve cover? If so it is a late model engine which will have the standpipe/dummy plug and STC leakage issues. See the sticky note at the top of the forum and read abpot the air test for leakage.

Also, have you done the blue spring upgrade to the fuel pressure regulator?

2006 F250 Lariat Supercrew, ESOF 4x4, 18" tires, FX 4, HD Alt., block heater, Integrated Trailer Brake Controller, Upfitters, power rear window, cab lights - delivered 10/25/05

Ford Remote Start; High idle mod; Timbren load levelers, Scangauge II, Blue Spring upgrade, Quick Start 200 amp large frame alternator, 2 batteries January 2010; GPCM replace October 2011; 2 EGR valves; EGR Cooler replaced 12/30/11; Performance Machine & Mfg. coolant filter added 1/2/12; Rotella T6 5W40 oil; turned rotors, replaced brake pads for 1st time 1/7/12 101K miles; GPCM, both subharnesses and all 8 glowplugs replaced 1/5/13 at 118,000 miles; 2 Ford batteries replaced under battery warranty twice, the latest 9/18/2015; FICM power supply board replaced with Dorman board 11/20/13. Coolant flushed and replaced with Prestone ELC 9/27/14. STC fitting 10/19/14; Dummy Plugs 11/8/14; Turbo rebuilt 11/29/14; cold side CAC tube and boots replaced with metal tube 1/24/15; replaced hot side boots 1/30/16.
Ford06 is offline  
post #5 of 11 (permalink) Old 01-26-2019, 04:04 PM Thread Starter
Member
 
HarleyFreeman's Avatar
 
Join Date: Feb 2008
Location: Central Texas
Posts: 45
My Photos: (0)
Feedback Score: 0 reviews
Ford06, to your question... Just went out and started it. It cranked a long time, maybe 20-30 seconds but then idled smoothly. During crank, IPR duty cycle was ~85% and the ICP climbed up past 500 and then after it started showed between 800-1000, so I thought I'd better drive it up the street. While I'm trying to accelerate the pressure drops to right around 500, but when I let it idle it goes back up to 800-1000 - even got as high as 1200 at one point. It is a newer 04, so I will keep the leaky plug and STC issues in mind. It has over 300,000 miles on it so any of those things could be worn out.

The other thing that comes to mind is that if I accelerate while in neutral/park, the RPMs go up pretty much like they should. My guess is that when it's not under load it still doesn't need that much fuel to rev up, so the injectors aren't sucking up a lot of the oil pressure. And when I'm accelerating under load, the injectors consume what high pressure the HPOP can maintain with the leak Does that sound right?

So right now I'm assuming that it is a leak and planning to start pulling it apart, first getting into the valve covers to check the oil rails and stand pipes and the connections to the injectors, then get down to the HPOP and see what I see there.

Thanks again for the replies, Ford06. Anybody else, please don't hesitate to chime in if there's something I may not be considering or anything like that

2004 F350 6.0 PSD, Long Box SRW Crew Cab FX4
Completely stock, minus the EGR
320,000 miles so far
HarleyFreeman is offline  
post #6 of 11 (permalink) Old 01-26-2019, 04:31 PM
Senior Member
 
Join Date: Sep 2005
Posts: 4,589
My Photos: (0)
Feedback Score: 0 reviews
An 04 doesn't have the failure prone "STC" fitting. Only 05 and up.

With over 300k miles, I am surprised that the HPOP is still good (assuming it is still original).

Air test it.

Mark
06 F250 CC SB FX4 Lariat;ARP studs;OEM gaskets;Banks exhaust;DynaTrac Ball joints;Coolant filter;High-Idle mod;RACCCV6000;JimmiJammers;Ravelco;SynchroMax xfer case;Fumoto valve;Harpooned;CPOhighwayProducts toolbox;tracrac;Fox Weatherboots;Wet Okole Seat Covers;BriteBox;Re-flashed;Quadzilla Recon XZT Fuel Press;Blue FPR spring;DashDAQ;PHP FICM;RiffRaff boots;DCPower270A XP;PowerInverter;Rancho7000's;BPD EGR cooler;One-piece HPOP fitting;D-plugs&standpipes;BPD Billet WaterPump;SCT w/ Matts SRL+;ELC Ultra;DuraTracs

Last edited by bismic; 01-26-2019 at 04:34 PM.
bismic is offline  
post #7 of 11 (permalink) Old 02-11-2019, 10:24 AM Thread Starter
Member
 
HarleyFreeman's Avatar
 
Join Date: Feb 2008
Location: Central Texas
Posts: 45
My Photos: (0)
Feedback Score: 0 reviews
Quote:
Originally Posted by bismic View Post
An 04 doesn't have the failure prone "STC" fitting. Only 05 and up.

With over 300k miles, I am surprised that the HPOP is still good (assuming it is still original).

Air test it.
Thanks Bismic, it is the original pump. After a few weeks of not being able to work on it from just having waaay too much other stuff going on, I finally got into it again yesterday. My brother-in-law and I pulled the HPOP and used my air compressor to test it as you suggested - like in this video:

The pump in the video appears to be a newer style pump, but I think the idea is the same. Anyway, so I think the HPOP has gone bad. It wasn't as obvious as the one in the video, but when we put air on the output port and a finger over the inlet port, and turned the wheel, we'd feel air kind of popping out the inlet port. Though not freely flowing, air was definitely moving the wrong direction through the pump. On a good HPOP there should be zero back-flow through the pump regardless of if the wheel is turning or not, right?

Thanks again everybody!

2004 F350 6.0 PSD, Long Box SRW Crew Cab FX4
Completely stock, minus the EGR
320,000 miles so far
HarleyFreeman is offline  
post #8 of 11 (permalink) Old 02-11-2019, 10:28 AM
Senior Member
 
Join Date: Sep 2005
Posts: 4,589
My Photos: (0)
Feedback Score: 0 reviews
Sounds like a bad HPOP to me. The original served you well!

IMO you should air test once the high pressure oil system has been re-assembled.

Mark
06 F250 CC SB FX4 Lariat;ARP studs;OEM gaskets;Banks exhaust;DynaTrac Ball joints;Coolant filter;High-Idle mod;RACCCV6000;JimmiJammers;Ravelco;SynchroMax xfer case;Fumoto valve;Harpooned;CPOhighwayProducts toolbox;tracrac;Fox Weatherboots;Wet Okole Seat Covers;BriteBox;Re-flashed;Quadzilla Recon XZT Fuel Press;Blue FPR spring;DashDAQ;PHP FICM;RiffRaff boots;DCPower270A XP;PowerInverter;Rancho7000's;BPD EGR cooler;One-piece HPOP fitting;D-plugs&standpipes;BPD Billet WaterPump;SCT w/ Matts SRL+;ELC Ultra;DuraTracs
bismic is offline  
post #9 of 11 (permalink) Old 02-11-2019, 02:18 PM Thread Starter
Member
 
HarleyFreeman's Avatar
 
Join Date: Feb 2008
Location: Central Texas
Posts: 45
My Photos: (0)
Feedback Score: 0 reviews
Thank you for the reply Bismic.

Do you mean where you take the ICP sensor out and put compressed air into the oil rail with a special fitting? I don't currently have a fitting to do that but I'll do some Google-fu and see if I can't figure out how to make one. It does seem like a good idea to do that test too.

Thanks again, you have been very helpful

2004 F350 6.0 PSD, Long Box SRW Crew Cab FX4
Completely stock, minus the EGR
320,000 miles so far
HarleyFreeman is offline  
post #10 of 11 (permalink) Old Yesterday, 11:46 AM Thread Starter
Member
 
HarleyFreeman's Avatar
 
Join Date: Feb 2008
Location: Central Texas
Posts: 45
My Photos: (0)
Feedback Score: 0 reviews
So I went to pick up a new pump yesterday and one of their head diesel techs just happened to be there at the parts desk, and we started talking about why I was getting a new pump. Long story short, he indicated that a little bit of air moving the wrong direction through the pump doesn't necessarily mean the pump is bad. He said that if it's able to make >500 psi, which it is (like I said before, it'll start and idle smoothly, just has no power when you press the gas pedal), then the pump is probably fine and he'd look elsewhere for a leak...

So what do you all think about this? I've talked to him before and he seems to know what he's talking about, but nobody knows everything. It seems to me that the pump must have some kind of check-valve in it because air flows freely inlet -> outlet, and for the most part doesn't flow at all outlet -> inlet (except for pops of air as you turn the wheel), so it seems to me like air probably should not flow backwards. I've ordered the air compressor ICP fitting so I can do a proper air test of the system, but what's the truth about these pumps? Should air be able to move the wrong direction through the pump at all, even a little bit?

2004 F350 6.0 PSD, Long Box SRW Crew Cab FX4
Completely stock, minus the EGR
320,000 miles so far
HarleyFreeman is offline  
post #11 of 11 (permalink) Old Yesterday, 12:36 PM
Senior Member
 
Join Date: Sep 2005
Posts: 4,589
My Photos: (0)
Feedback Score: 0 reviews
My experience is that you can leak a little air at the shaft seal, but not any in reverse flow. I am sure that some SMALL amount may be acceptable (not ideal though), but there is no way to quantify that.

The thing about the HPOP's is that the OEM, and many of the aftermarket pumps, are marginal in quality/longevity.

To get an HPOP that will last, it will cost you (unless you get lucky like you did w/ your OEM pump). The Dieselsite Adrenaline pump is the best one available. It is costly at $900. CNCFab has a good pump also, but they have been out of stock for a while. Both these pumps have been modified to fix some inherent design issues w/ the 03 and 04 pumps.

I agree that doing the air test of the high pressure oil system is the best idea. To do that, you put air in the ICP fitting and close the IPR valve, or buy the test fitting for the IPR valve port and test it there (then you don't have to mess with closing the IPR valve). That said, since you have 200k miles on the original and the system is open, it can save you a lot of trouble in the future by replacing it with an upgraded pump.

The 100% positive way to condemn an HPOP is when you hear air gurgling form the oil filter housing (pull the oil filter to listen). The gurgling sound means unacceptable air back flow through the pump.

https://www.dieselsite.com/2003-2004...lpumphpop.aspx
(unless you are going for HIGH horsepower, the stock rated HPOP is what you need)

Looks like the CNCFab pump is still out of stock.
https://cncfab.us/i-30498072-cnc-fab...hpop-stg1.html

Mark
06 F250 CC SB FX4 Lariat;ARP studs;OEM gaskets;Banks exhaust;DynaTrac Ball joints;Coolant filter;High-Idle mod;RACCCV6000;JimmiJammers;Ravelco;SynchroMax xfer case;Fumoto valve;Harpooned;CPOhighwayProducts toolbox;tracrac;Fox Weatherboots;Wet Okole Seat Covers;BriteBox;Re-flashed;Quadzilla Recon XZT Fuel Press;Blue FPR spring;DashDAQ;PHP FICM;RiffRaff boots;DCPower270A XP;PowerInverter;Rancho7000's;BPD EGR cooler;One-piece HPOP fitting;D-plugs&standpipes;BPD Billet WaterPump;SCT w/ Matts SRL+;ELC Ultra;DuraTracs

Last edited by bismic; Yesterday at 12:50 PM.
bismic is offline  
post #12 of 11 (permalink) Old Yesterday, 12:47 PM
Senior Member
 
Join Date: Sep 2005
Posts: 4,589
My Photos: (0)
Feedback Score: 0 reviews
Since you have the late 04, the dummy plugs and standpipes o the oil rails are common leak points, so you definitely need to check them with an air test. IMO the best way to do the air test is with the IPR test fitting and put air through it. Also, the injectors may be leaking, so having the valve covers off so you can hear leaks (if any) at each injector is almost a requirement.

Best to do the air test with hot oil. You need to give the air time to push the oil out of the system, which happens faster with hot oil.

Mark
06 F250 CC SB FX4 Lariat;ARP studs;OEM gaskets;Banks exhaust;DynaTrac Ball joints;Coolant filter;High-Idle mod;RACCCV6000;JimmiJammers;Ravelco;SynchroMax xfer case;Fumoto valve;Harpooned;CPOhighwayProducts toolbox;tracrac;Fox Weatherboots;Wet Okole Seat Covers;BriteBox;Re-flashed;Quadzilla Recon XZT Fuel Press;Blue FPR spring;DashDAQ;PHP FICM;RiffRaff boots;DCPower270A XP;PowerInverter;Rancho7000's;BPD EGR cooler;One-piece HPOP fitting;D-plugs&standpipes;BPD Billet WaterPump;SCT w/ Matts SRL+;ELC Ultra;DuraTracs
bismic is offline  
Sponsored Links
Advertisement
 
Reply

  Diesel Forum - TheDieselStop.com > 1999-2007 Ford Super Duties > 6.0L Power Stroke Engine and Drivetrain

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Forum - TheDieselStop.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome