Simple AE question regarding CMP/CKP Sync flipflopping... - Diesel Forum - TheDieselStop.com
6.0L Power Stroke Engine and Drivetrain Discussion of the 6.0L Power Stroke diesel engine and drivetrain in the 2003-Up Super Duties and Excursions. No gas engine discussion allowed except on transmissions and drivetrain that pertain to all models. Please confine discussion of topics in this forum to those items that are specific to the 6.0L Power Stroke engine.

 1Likes
  • 1 Post By stevedunham-2
 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 08-29-2018, 01:46 PM Thread Starter
Member
 
Join Date: Jul 2016
Posts: 98
My Photos: (0)
Feedback Score: 0 reviews
Simple AE question regarding CMP/CKP Sync flipflopping...

Troubleshooting an ongoing intermittent "No Start" problem that keeps leaving me stranded on my '04 6.0. The truck left me stranded Sunday, but eventually fired and ran OK getting home. I replaced another CMP Sensor Sunday, but that did NOT fix the "no start". Today, when monitoring using AE's Live Data, "CMP/CKP sync" keeps flip flopping back and forth between 0 and 1 about every second or so. I'm assuming this is NOT normal for the signal to be flip flopping that often, and so the signal is being interrupted between the CMP, CKP and FICM. The FICM is an upgraded Swamp's Diesel 58 Volt FICM going on 7 or 8 years old now, but it always test OK on the Power Side, and does today. I know the Logic Side can also go south, so that may be the issue, but no way to confirm or test it that I'm aware of before sending it in for repair. I'm leaning towards replacing the engine harness and the CKP sensor while I'm behind the AC Compressor to swap out the electrical connector even though supposedly CKP sensors rarely fail, and it's not the original sensor (replaced years ago due to leaking/failed o-ring). Comments...?

'04 F250 KR - '14 F350 Lariat -
stevedunham-2 is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 08-29-2018, 02:13 PM Thread Starter
Member
 
Join Date: Jul 2016
Posts: 98
My Photos: (0)
Feedback Score: 0 reviews
Found a bunch of threads here and there regarding this exact same flip flopping cmp/ckp sync output in AE and some say it is normal... Ugh...

'04 F250 KR - '14 F350 Lariat -
stevedunham-2 is offline  
post #3 of 10 (permalink) Old 08-29-2018, 07:20 PM
Senior Member
 
Phil G.'s Avatar
 
Join Date: May 1999
Location: Ontario, Canada
Posts: 2,445
My Photos: (2)
Feedback Score: 0 reviews
Ya, the 0-1-0-1 thing made me wonder too regarding sync.

Just a hunch but I think your on the right track changing out the harness at least that's what I would do at this stage. You could load test each wire but that's a ton of work. Regarding the FICM, do you know someone with one they could lone you for a day or two? Or, if they are worried about your truck somehow harming their FICM, could you get them to run yours for a couple days and keep theirs with them just in case?

2007 F350 SRW 6.0L Auto, 3.73LS, 172"WB 4x4. Viper Alarm/RS, WD pillar Guages,AutoEnginuity, 100gal polished alum fuel tank.
All Sold: 99.5, early03 , 2004 - all were 172" wb 4x4 lariat's.

My Worklog - *Updated 8/18 with Edge CTS2 install click here =>*:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Phil G. is offline  
Sponsored Links
Advertisement
 
post #4 of 10 (permalink) Old 08-30-2018, 10:13 AM Thread Starter
Member
 
Join Date: Jul 2016
Posts: 98
My Photos: (0)
Feedback Score: 0 reviews
After talking to the guys at Swamps Diesel regarding the possibility of the Logic Side of their 58 Volt FICM going bad, they said "it's not likely"... They would test it for me for a fee if required if I send it in. At this point, I ordered a harness and new crank sensor and will do that job first. Then we'll see if the "no start" comes back . If so, then I'll send in the FICM again and get it tested/repaired. After this hunting season is over, the truck is outa here even though I'm gonna' take a huge financial loss on it... I should have sold it 10 years ago to be honest...
Phil G. likes this.

'04 F250 KR - '14 F350 Lariat -
stevedunham-2 is offline  
post #5 of 10 (permalink) Old 08-30-2018, 12:55 PM
Senior Member
 
Phil G.'s Avatar
 
Join Date: May 1999
Location: Ontario, Canada
Posts: 2,445
My Photos: (2)
Feedback Score: 0 reviews
Everything you just stated makes sense to me. Hopefully the harness will cure it, then you can sell it straight up running properly to someone and move on. Let us know if the harness cures it.

2007 F350 SRW 6.0L Auto, 3.73LS, 172"WB 4x4. Viper Alarm/RS, WD pillar Guages,AutoEnginuity, 100gal polished alum fuel tank.
All Sold: 99.5, early03 , 2004 - all were 172" wb 4x4 lariat's.

My Worklog - *Updated 8/18 with Edge CTS2 install click here =>*:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Phil G. is offline  
post #6 of 10 (permalink) Old 08-30-2018, 07:53 PM
Senior Member
 
79jasper's Avatar
 
Join Date: Dec 2012
Posts: 1,616
My Photos: (0)
Feedback Score: 0 reviews
It's likely going to get deleted, but I'm posting because it has a ton of relevant info.
https://www.ford-trucks.com/forums/1...v-check-5.html

Sent from my SAMSUNG-SM-G930A using Tapatalk

1994 F350 7.3 PSD 4X4 ZF5 DUALLY
PHP HYDRA, 6637, 3-4 DP TO STRAIGHT 4 BEHIND THE TIRE, 1.0 EXHAUST HOUSING, DIY D66 TURBO, FUGA E-FUEL, EBPV DELETE. Cooper discoverer AT/3'S.

2010 VW JETTA TDI DSG Kerma tune. Hankook ventus v2 concept 2.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
79jasper is offline  
post #7 of 10 (permalink) Old 08-30-2018, 11:04 PM
Senior Member
 
Join Date: Sep 2005
Posts: 4,716
My Photos: (0)
Feedback Score: 0 reviews
Quote:
Originally Posted by stevedunham-2 View Post
After talking to the guys at Swamps Diesel regarding the possibility of the Logic Side of their 58 Volt FICM going bad, they said "it's not likely"... They would test it for me for a fee if required if I send it in. At this point, I ordered a harness and new crank sensor and will do that job first. Then we'll see if the "no start" comes back . If so, then I'll send in the FICM again and get it tested/repaired. After this hunting season is over, the truck is outa here even though I'm gonna' take a huge financial loss on it... I should have sold it 10 years ago to be honest...
Ed from FICMReopair.com says he sees almost as many logic board failures as power board failures.

I wonder what Swamps does to the logic board (if anything) for improved reliability.

Mark
06 F250 CC SB FX4 Lariat;ARP studs;OEM gaskets;Banks exhaust;DynaTrac Ball joints;Coolant filter;High-Idle mod;RACCCV6000;JimmiJammers;Ravelco;SynchroMax xfer case;Fumoto valve;Harpooned;CPOhighwayProducts toolbox;tracrac;Fox Weatherboots;Wet Okole Seat Covers;BriteBox;Re-flashed;Quadzilla Recon XZT Fuel Press;Blue FPR spring;DashDAQ;PHP FICM;RiffRaff boots;DCPower270A XP;PowerInverter;Rancho7000's;BPD EGR cooler;One-piece HPOP fitting;D-plugs&standpipes;BPD Billet WaterPump;SCT w/ Matts SRL+;ELC Ultra;DuraTracs
bismic is offline  
post #8 of 10 (permalink) Old 09-02-2018, 10:36 AM Thread Starter
Member
 
Join Date: Jul 2016
Posts: 98
My Photos: (0)
Feedback Score: 0 reviews
Quote:
Originally Posted by bismic View Post
Ed from FICMReopair.com says he sees almost as many logic board failures as power board failures.

I wonder what Swamps does to the logic board (if anything) for improved reliability.

I wondered too so asked them in an email and they really didn't respond specifically other than to say "in general, the logic sides don't fail"... Not a real confidence booster to be honest. Seems more of a canned response than anything else... I ordered a harness and will swap it out as time permits... The only spot on the wiring that has me concerned is where it winds around the oil filter base and the fuel filter... The looms there seems to have been pushed on pretty hard there... We'll see...

'04 F250 KR - '14 F350 Lariat -
stevedunham-2 is offline  
post #9 of 10 (permalink) Old 10-18-2018, 08:21 AM Thread Starter
Member
 
Join Date: Jul 2016
Posts: 98
My Photos: (0)
Feedback Score: 0 reviews
The issue(s) seems to have been resolved by replacing the engine harness as it hasn't left me stranded since that weekend and the engine is running better than it has in years. It has not failed to start since the harness swap. Upon inspecting the old harness for signs of wear, there was a repair done by somebody without my knowledge (Ford...?) that looks suspect but other than that, no obvious signs of chafing, wear through, etc. The job was a PITA as I have the IPR Remote Oil Cooler, IPR remote Coolant Filter, etc. and all that stuff is in the way of the harness and connectors... I particularly love how Ford decided to hide 1 of the bolts for the AC Compressor (has to be moved to get access to the CKP sensor) underneath the compressor between it and the frame, with only a tiny hole for access to it... That was fun...

'04 F250 KR - '14 F350 Lariat -
stevedunham-2 is offline  
post #10 of 10 (permalink) Old 10-18-2018, 08:39 AM
Senior Member
 
Join Date: Sep 2005
Posts: 4,716
My Photos: (0)
Feedback Score: 0 reviews
Thanks for the update.

btw - International built the engine.

Mark
06 F250 CC SB FX4 Lariat;ARP studs;OEM gaskets;Banks exhaust;DynaTrac Ball joints;Coolant filter;High-Idle mod;RACCCV6000;JimmiJammers;Ravelco;SynchroMax xfer case;Fumoto valve;Harpooned;CPOhighwayProducts toolbox;tracrac;Fox Weatherboots;Wet Okole Seat Covers;BriteBox;Re-flashed;Quadzilla Recon XZT Fuel Press;Blue FPR spring;DashDAQ;PHP FICM;RiffRaff boots;DCPower270A XP;PowerInverter;Rancho7000's;BPD EGR cooler;One-piece HPOP fitting;D-plugs&standpipes;BPD Billet WaterPump;SCT w/ Matts SRL+;ELC Ultra;DuraTracs
bismic is offline  
Sponsored Links
Advertisement
 
Reply

  Diesel Forum - TheDieselStop.com > 1999-2007 Ford Super Duties > 6.0L Power Stroke Engine and Drivetrain

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Forum - TheDieselStop.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome