Slow turbo spool & p0299 - Diesel Forum - TheDieselStop.com
6.0L Power Stroke Engine and Drivetrain Discussion of the 6.0L Power Stroke diesel engine and drivetrain in the 2003-Up Super Duties and Excursions. No gas engine discussion allowed except on transmissions and drivetrain that pertain to all models. Please confine discussion of topics in this forum to those items that are specific to the 6.0L Power Stroke engine.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 02-21-2019, 06:37 PM Thread Starter
Senior Member
 
Join Date: Feb 2010
Posts: 162
My Photos: (0)
Feedback Score: 0 reviews
Slow turbo spool & p0299

Hi All -

So I've been slowly treating a slow turbo boost on my work truck -- it has had a few other issues along the way, which through the help of this forum I have been tackling, so I will try to summarize quickly here:

Truck has is a dog off the line. its a manual tranny and a lot of times I need to start in granny low just to get enough boost to get going. Once I get past first gear, the turbo builds plenty of pressure - up in the lows 20s and the truck feels like it has great power. Only code is p0299.

What I've done:

- Removed and cleaned turbo -- it was nasty, stuck, and the unison ring was worn so I replaced all of that
- Removed EBP sensor and tube - cleaned and replaced.
- Found several leaks in CAC and pipes - installed new CAC & all piping/boots from turbo to intake. This made a big difference in my overall boost numbers, but didn't seem to help the low end

I'm thinking maybe a leak at the y-pipe but I don't see any soot or hear any leaking.

My Map & Baro readings all seem normal.

EBP at idle is 0psi and VGT is 85% which I know is obviously not good as the computer isn't seeing enough boost from the turbo. While driving, EBP goes upend VGT is between 30-65%. As a note, On my other (well functioning) 6.0, EBP at idle is 3psi.


I have a new EBP I was going to try and swap out - but other than that, and searching for a y-pipe leak, any other thoughts are much appreciated!

2006 F350 Dually King Ranch
dieselnoob1 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 02-22-2019, 12:22 PM
Senior Member
 
Join Date: Oct 2005
Location: Eastern VA
Posts: 1,380
My Photos: (0)
Feedback Score: 0 reviews
Try taping a shop vac set on blow to the tail pipe. You will hear any cracks or leaks.

2006 F250 Lariat Supercrew, ESOF 4x4, 18" tires, FX 4, HD Alt., block heater, Integrated Trailer Brake Controller, Upfitters, power rear window, cab lights - delivered 10/25/05

Ford Remote Start; High idle mod; Timbren load levelers, Scangauge II, Blue Spring upgrade, Quick Start 200 amp large frame alternator, 2 batteries January 2010; GPCM replace October 2011; 2 EGR valves; EGR Cooler replaced 12/30/11; Performance Machine & Mfg. coolant filter added 1/2/12; Rotella T6 5W40 oil; turned rotors, replaced brake pads for 1st time 1/7/12 101K miles; GPCM, both subharnesses and all 8 glowplugs replaced 1/5/13 at 118,000 miles; 2 Ford batteries replaced under battery warranty twice, the latest 9/18/2015; FICM power supply board replaced with Dorman board 11/20/13. Coolant flushed and replaced with Prestone ELC 9/27/14. STC fitting 10/19/14; Dummy Plugs 11/8/14; Turbo rebuilt 11/29/14; cold side CAC tube and boots replaced with metal tube 1/24/15; replaced hot side boots 1/30/16.
Ford06 is offline  
Sponsored Links
Advertisement
 
Reply

  Diesel Forum - TheDieselStop.com > 1999-2007 Ford Super Duties > 6.0L Power Stroke Engine and Drivetrain

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Forum - TheDieselStop.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
non working turbo issue ibefishing20 6.0L Power Stroke Engine and Drivetrain 15 04-04-2011 04:26 PM
Turbo won't spool till engine warm?? Coolhand Power Strokes 1994-1997 General 3 03-07-2007 04:01 PM
Turbo Pedestal O-Ring R&R gregrob '99 & up 7.3L Power Stroke Engine and Drivetrain 10 05-17-2006 05:01 PM
Engine Oil and Differential temperatures??? RobsE350 E-Series Vans 8 03-16-2006 09:23 PM
ATS Ported Housing with stock wheel vs. stock housing with WW DarthSurplus '99 & up Upgrades and Aftermarket - 7.3L Engine 225 03-17-2005 02:43 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome