Hot Re-start problem - Diesel Forum - TheDieselStop.com
'99 & up 7.3L Power Stroke Engine and Drivetrain Discussion of the '99 & up 7.3L Power Stroke diesel engine and drivetrain in the 1999-Up Super Duty trucks and Excursions. No gas engine discussion allowed except on transmissions and drivetrain that pertain to all models. Please confine discussion of topics in this forum to those items that are specific to the 7.3L Power Stroke engine.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 05-07-2019, 01:57 PM Thread Starter
Member
 
sganz's Avatar
 
Join Date: Jun 2003
Location: Los Angeles
Posts: 64
My Photos: (0)
Feedback Score: 0 reviews
Hot Re-start problem

Having the dreaded hot restart issue that I have been seeing a bit here. Trying to narrow some things down before buying parts or having to take it in.


2003 Excursion with some mods, but was working ok for a while then Hot restart issue started hapenning.



Starts fine cold or after sitting for an hour or so.
When hot will crank but won't start.
Looked at ICP while cranking and bounces around well under 500psi (will have to check actual next time around).
Open the hood and let it cool for 15-20 minutes and seems to start up right up, sometimes clean running sometimes a bit rough.
It drives fine, no issues until it's shut off.
Have a T500 HPOP that see a good amount of pressure (3000+ while on it), but when hot and idle hangs around the 500 psi range.



In reading some of the threads seems to a few things show up but trying to find some way to hone in on what might be the issue. Here is what typically I found, but not sure of how accurate it might be for my case -


ICP bad, gets hot doesn't work (But works fine while driving???)
IPR Stuck open

Injector O-Rings leaking (They have about 10k miles on them, but have been in and out at least once due to issues when rebuilding the engine a while back)
Cam Sensor


ICP and IPR are both Ford and were replaced about 10k with the rebuild job (I bought them both from RiffRaff Diesel).



Have not seen any check engine lights ever come on, batteries and starter crank fast, truck hauls a$$ otherwise.



What should I start checking to see what the problem is. I have Torque on my phone so can see a bunch of data if that helps.


Sandy

2003 Excursion Limited 4x4 7.3L PSD "The Jolly Green Giant", Injector Cup Replacement, Diesel Site Billet T-Stat housing and T-Stat, CAT EC-1 Coolant, Hellwig Swaybar, GT38R, Banks Intercooler, AFE and Riff Raff Intake, 238/80 Injectors, Comp Springs w/ reground Roller.

Rest of the cars at
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Injector Cup and Super Duty Power Steering Fix and other fun stuff. Electronics at
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
sganz is offline  
Sponsored Links
Advertisement
 
Reply

  Diesel Forum - TheDieselStop.com > 1999-2007 Ford Super Duties > '99 & up 7.3L Power Stroke Engine and Drivetrain

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Forum - TheDieselStop.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Another No Start Problem Tockit Power Strokes 1994-1997 General 12 01-17-2017 09:34 AM
Heater problem Hot -Cold- Hot on its own Maddog 308 1999-2007 Upgrades and Aftermarket - General 1 01-12-2016 10:51 AM
No start when hot jviii 6.9L IDI Diesels (Not Power Strokes) 7 10-07-2011 09:34 AM
Hot Start Problem - Any Help?? DuckAddict Upgrades and Aftermarket - 6.0L Engine 3 07-29-2008 01:45 PM
Cold start problem JakeDog 6.0L Power Stroke Engine and Drivetrain 0 05-17-2005 07:23 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome