Loses all boost and pops - Diesel Forum - TheDieselStop.com
'99 & up 7.3L Power Stroke Engine and Drivetrain Discussion of the '99 & up 7.3L Power Stroke diesel engine and drivetrain in the 1999-Up Super Duty trucks and Excursions. No gas engine discussion allowed except on transmissions and drivetrain that pertain to all models. Please confine discussion of topics in this forum to those items that are specific to the 7.3L Power Stroke engine.

 
LinkBack Thread Tools
Old 06-17-2019, 09:14 PM Thread Starter
Senior Member
 
Join Date: Feb 2004
Location: Seaside, California
Posts: 157
My Photos: (0)
Feedback Score: 0 reviews
Loses all boost and pops

2003 7.3l 150k miles all stock except 4” exhaust and open air intake. Truck one day suddenly makes a pop and loses all boost and power. Let off the pedal and wait a few seconds then it will build boost once again. It can see 18-19 psi before it (releases) boost. Have replaced all of the silicone intercooler boots. It now does this consistently. If I press the accelerator lightly it will get more boost. If I stomp on it, it will go bang and lose boost and power. I have checked fuel pressure. Never goes below 55 psi under load. ICP goes up to 2800 or so if I remember correctly. The IPR percentage was low. I have replaced the wastegate actuator with a banks aftermarket unit. Problem still persists. I cannot tow a trailer now and not sure what to do. No codes when scanned. Truck idles perfectly and ran great until this started. A few mechanics have looked at it and didn’t know what to do. The truck runs great until boost reaches about 19 psi or even at 13-14 psi if heavy on the pedal then boost drops and power loss for a couple of seconds then it comes back alive. No CEL or codes. Any help would be appreciated. Thank you

1999.5 F350 CCLB 7.3L auto 4x4 189,000 miles, Hutch mod, HPX, FRX, 4" exhaust. All stock otherwise.
04 GMC 3500 4x4 dually LB7 duramax- Sold
04/04 F250 12/20/03 build date, XLT Supercab longbed 6.0l, 4X4, 3.73lsd, FX4 pkg, torqueshift, ESOF, silver/med. flint, 6cd, back up sensors, rear slider, camper pkg, big mirrors w/ heated/pwr glass, 120k Sold
04/04 F350 Crew Cab long bed 6.0L lariat FX4 46K Sold
1998.5 Dodge 3500 4x4 dually 24valve cummins 160K (sold)
2005 Lance 835 Cabover Camper
1999 Sanger DXII ski boat
1975 Dodge RamCharger (sold)
1990 Sanger DX ski boat
1991 Dodge W350 Cummins SRW 215K(sold)
pwrstrokn2004 is offline  
Sponsored Links
Advertisement
 
Old 06-19-2019, 09:21 PM
Lifetime Supporting Member
 
klhansen's Avatar
 
Join Date: Jan 2003
Location: Eagle River, Alaska
Posts: 24,610
My Photos: (180)
Feedback Score: 0 reviews
I would look at the intercooler boots again. You may have one that's deteriorated (maybe internally split causing part of it to block the passage?). Take them all off and inspect closely. Squish them by hand and look for splits.
Can't see how it would be related to the wastegate. You could try wiring that closed and see if it still acts up.

First truck -- 1929 Model A Ford pickup, restored from ground up. Wish I still had it!
'99.5 F250 PSD Supercab LB 4x4, ZF-6 w/SB Con OFE, 3.73LS, Boost & pyro gauges, Swamps S175/146 injectors, DP 80 HP Econo PCM (classic version
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
), AIS,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
regulated return,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
klhansen is offline  
Old 06-23-2019, 08:53 AM
Senior Member
 
Absolute's Avatar
 
Join Date: Jul 2009
Location: Vancouver, BC, Canada
Posts: 990
My Photos: (0)
Feedback Score: 0 reviews
Have you checked you EBPV to make sure its not disconnected and slamming shut, or broken and flopping around blocking the exhaust. If you lose boost it should belch black smoke big time. If not , its plugged. Also, if the waste gate you bought exceeds the max boost of your programming your Map sensor will take a dump. If you go over its rating it signals the cpu to dump power and your boost drops to about 10psi max. If you stop at a light it resets until it over boosts again. THen it dumps again. You could try with no harm the boost fooler trick, and ground the high boost wire. The cpu doesn't get the shut down code then and it wont de rate your power. I doubt its the waste gate itself but its possible, but not without smoke when it does. Mine fails because its gotten weak and the gate opens it on its own at max boost. IT farts then instantly gets back on it. So different results than yours. It also belches a mass of smoke when it does it, so if yours aint smoken, its not the turbo itself, its whats controlling the turbo. Since you have no smoke, I would say your map sensor is pooched.

2002 F350 Super Duty, Crew Cab,Long box,4x4, 7.3 PSD, Complete rebuild .010 over by myself except balancing, 2000hp billet connecting rods, ARP main and head studs, ceramic coated pistons, Smith Bros Chrome Molly push rods, Comp Cams springs, shims and seals. Competion complete valve set and head grinding and vacuum tested, Adrenaline HPOP, DP Tuner Infinity DX programmer and full load of tunes modified for my new Stage 3 250 shot injectors, ceramic coated exhaust manifolds and up pipes and collector, BD Diesel triple clutch furnace brazed billet torque converter and BD pro engine brake and compressor set up, MBRP 4" stainless turbo back, Driven Diesel regulated fuel return system, AFE pro stage 2 cool air intake, riffraff billet Whicked Wheel 2 compressor wheel in a GTP38R turbo, riffraff blue cooler boot kit and coil clamps, International Double Ceramic Coated Bellowed Up Pipes
1999 Mustang GT Convertible Anniversary, rare stock electric green
2009 40' Raptor Velocity Toy Hauler
Absolute is offline  
Sponsored Links
Advertisement
 
 

  Diesel Forum - TheDieselStop.com > 1999-2007 Ford Super Duties > '99 & up 7.3L Power Stroke Engine and Drivetrain

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Forum - TheDieselStop.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Thread Tools



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome