Diesel Forum - TheDieselStop.com

Diesel Forum - TheDieselStop.com (https://www.thedieselstop.com/forums/)
-   '99 & up 7.3L Power Stroke Engine and Drivetrain (https://www.thedieselstop.com/forums/f24/)
-   -   Poor fuel economy??? (https://www.thedieselstop.com/forums/f24/poor-fuel-economy-656304/)

jobaa 08-02-2019 01:51 PM

Poor fuel economy???
 
I installed a K&N filter along with a 4" exhaust with straight through muffler, new bellowed up pipes and deleted the back pressure valve. Didn't change anything else. My fuel economy dropped by about 2 MPG. Anybody have any ideas? Did I do something I shouldn't have? It seems that these mods should improve economy and performance but neither is better. The only thing I've noticed is a different exhaust tone and I can hear the turbo whistling a bit more.

jleedog 08-02-2019 03:50 PM

What kind of K&N did you use? Most of us agree that they are not the greatest filters to use on our trucks. Is it the K&N direct stock replacement filter?Did you oil it? You may have restricted flow if you did, which would explain the drop in MPG. I recommend the ford AIS air filter setup if you really want a good filter. Take out the K&N and put the old filter back in and recheck your MPG. A new exhaust would not typically cause a drop in MPG but a exhaust or turbo/up pipe leak might. Check for leaks on the new up pipes. Did you loose any boost after the new work?

bugman 08-02-2019 04:12 PM

If mods improved mileage as much as they claim to they would put the oil refineries out of business.

So, how are you checking the mileage? Using math or the lie-o-meter? How many tanks of fuel have you ran through since doing these mods? Did you change your driving style?

Sent from my SM-J737V using Tapatalk

RT 08-02-2019 05:45 PM

Check for boost leaks. That would be a sure source of decreased fuel economy. You can buy or build a leak tester.

Absolute 08-03-2019 07:53 AM

I used to have problems with my back pressure sensor. It would malfunction and shut the truck down. Unplugged I could get going again. That said. The only difference I noticed with it unplugged was crappy fuel economy. Plug back in and all good again, once I replaced the sensor. So, Im guess its your missing back pressure sensor.

Rickie 08-10-2019 12:29 PM

Quote:

Originally Posted by jobaa (Post 4665168)
I installed a K&N filter along with a 4" exhaust with straight through muffler, new bellowed up pipes and deleted the back pressure valve. Didn't change anything else. My fuel economy dropped by about 2 MPG. Anybody have any ideas? Did I do something I shouldn't have? It seems that these mods should improve economy and performance but neither is better. The only thing I've noticed is a different exhaust tone and I can hear the turbo whistling a bit more.

The exhaust should sound different, youíve removed the original set up.:surprise:.

Since youíve changed a few items, any single one may be the culprit. As mentioned above, I hope itís just data from only one fill up. You need a few fill ups/tanks of fuel before you want to compare data sets.

Absolute 08-17-2019 11:52 AM

Once again. Removing the back pressure sensor will directly effect your fuel economy. In fact, on a diesel that's all it helps the CPU with. It helps the CPU determine fuel mixture along with other sensors of course. So you removed one of its equations and it runs on default now. Which will be rich, which will drop your fuel economy. 2 mpg would be about right over a tank a bit rich. Put it back, and your CPU will then be able to calculate fuel economy with your new add ons, and fuel economy will be better than before most likely. If not the same. The CPU already recognizes your add ons, but has lost part of its information network without back pressure, and cant take advantage of your add ons because it must run rich on default information. Default will never run lean. Lean doesn't keep your truck running in a sensor loss situation. So all vehicles will either run rich on default, or de rate hp and run rich like a semi truck does with sensor loss.

RT 08-17-2019 12:13 PM

I missed where he said he removed the sensor. He did say he removed the exhaust back pressure valve, but that is a common delete and has no affect on the sensor.


All times are GMT -5. The time now is 11:39 AM.

Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.

vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

 
For the best viewing experience please update your browser to Google Chrome