Had Pac Brake installed , not working - Diesel Forum - TheDieselStop.com
'99 & up Upgrades and Aftermarket - 7.3L Engine Upgrading or adding OEM or aftermarket equipment to your 1999-Up Super Duty or Excursion with 7.3L Power Stroke diesel engine. Please confine discussion of topics in this forum to those items that are specific to the 7.3L Power Stroke engine.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 06-14-2019, 11:38 PM Thread Starter
Junior Member
 
Join Date: May 2018
Posts: 3
My Photos: (0)
Feedback Score: 0 reviews
Had Pac Brake installed , not working

I had a pac brake installed on my 03 7.3 auto transmission, installers cannot get brake to engage when driving, compressor runs, with key on switch turned on and lights up, you can here valve go through its check sequence, but when you drive nothing happens, have a red light on switch never turns orange and no sound or evidence the valve closed. Its Friday night and we are headed out supposedly Sunday, any thoughts ideas would be appreciated, thanks
Firedad207 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 06-15-2019, 08:35 AM
Member
 
Join Date: Jul 2018
Posts: 81
My Photos: (0)
Feedback Score: 0 reviews
From my experience with these exhaust brakes, it’s probably the switch at the throttle not engaging
Buffalohead1 is offline  
post #3 of 5 (permalink) Old 06-15-2019, 10:08 AM Thread Starter
Junior Member
 
Join Date: May 2018
Posts: 3
My Photos: (0)
Feedback Score: 0 reviews
Thanks , how do I check the throttle switch ?
Firedad207 is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 06-15-2019, 08:49 PM
Member
 
Join Date: Jul 2018
Posts: 81
My Photos: (0)
Feedback Score: 0 reviews
It’s a micro switch bolted to the side of the accelerator pedal that activates when completely off the throttle. Disconnect the wires and test for continuity when the switch should be closed. I sometimes skip my foot off the pedal to slap the switch into activation.
Buffalohead1 is offline  
post #5 of 5 (permalink) Old 06-17-2019, 02:39 PM
Member
 
Join Date: Jul 2018
Posts: 81
My Photos: (0)
Feedback Score: 0 reviews
If the compressor is running check to see if the cylinder cycles on the pac brake. Check for any airleaks too.
Buffalohead1 is offline  
Sponsored Links
Advertisement
 
Reply

  Diesel Forum - TheDieselStop.com > 1999-2007 Ford Super Duties > '99 & up Upgrades and Aftermarket - 7.3L Engine

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Forum - TheDieselStop.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome