Cruise not working. Here are my codes - Diesel Forum - TheDieselStop.com
1999-2007 General Questions General questions related to 1999-2007 Super Duty trucks. If it doesn't fit the other categories, post it here. Gas engine discussion that pertains to all models is allowed. Specific gas engine questions should use the Gas Engines forum.

 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 09-29-2017, 05:20 PM Thread Starter
Senior Member
 
itorchedparis's Avatar
 
Join Date: Aug 2009
Location: Western NY
Posts: 301
My Photos: (0)
Feedback Score: 0 reviews
Cruise not working. Here are my codes

Cruise stopped working about 6 months ago. Finally itching to have it back. I did the KOER switch test and came back with this. What are your thoughts on what is wrong? Thanks.
Attached Thumbnails
Click image for larger version

Name:	4D3F3EDE-5CBB-4E5E-801A-1800C3DF6D3A_1506723578386.jpg
Views:	90
Size:	746.9 KB
ID:	116017  


2000
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
F250 7.3L Lariat, Crew Cab/Short bed 4x4. AFE stage II intake. Magnaflow 3.5DP/4" SS exhaust. Isspro gauges (EGT, Boost, Trans Temp, Fuel Pressure) AIH Delete with riffraff boost fitting adapter, Foil delete, Muffler Delete, CCV Mod, Rebuilt HD Tranny with BTS valve body. 6.0 tranny cooler, ported compressor housing, turbomaster wastegate controller, garret high flow outlet, Non EBPV pedestal, dieselsite boot kit, Marinco mod, HPX mod, Sinister Diesel regulated return system, DP F6 tuner (60 tow, 80 econo, 120 race, High idle 1200, Drive Thru) Warn Hubs, 08 tailights, 05-07 front end conversion, 08-11 rear end conversion, Line-xed rocker panels/wheel wells/bumpers.
itorchedparis is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 09-30-2017, 01:12 AM
Lifetime Supporting Member
 
klhansen's Avatar
 
Join Date: Jan 2003
Location: Eagle River, Alaska
Posts: 24,648
My Photos: (180)
Feedback Score: 0 reviews
Did you cycle all the switches during the test? It looks like every switch checked by that test failed. That would happen if you just ran the test and didn't cycle any of the switches.

If you pushed all the cruise buttons during the test, then I'd say your clock spring is shot.

First truck -- 1929 Model A Ford pickup, restored from ground up. Wish I still had it!
'99.5 F250 PSD Supercab LB 4x4, ZF-6 w/SB Con OFE, 3.73LS, Boost & pyro gauges, Swamps S175/146 injectors, DP 80 HP Econo PCM (classic version
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
), AIS,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
regulated return,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
klhansen is offline  
post #3 of 9 (permalink) Old 09-30-2017, 09:34 AM Thread Starter
Senior Member
 
itorchedparis's Avatar
 
Join Date: Aug 2009
Location: Western NY
Posts: 301
My Photos: (0)
Feedback Score: 0 reviews
OOOOOH! Didn't know I was supposed to do that. I will redo the test and post my results then. Thanks!

2000
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
F250 7.3L Lariat, Crew Cab/Short bed 4x4. AFE stage II intake. Magnaflow 3.5DP/4" SS exhaust. Isspro gauges (EGT, Boost, Trans Temp, Fuel Pressure) AIH Delete with riffraff boost fitting adapter, Foil delete, Muffler Delete, CCV Mod, Rebuilt HD Tranny with BTS valve body. 6.0 tranny cooler, ported compressor housing, turbomaster wastegate controller, garret high flow outlet, Non EBPV pedestal, dieselsite boot kit, Marinco mod, HPX mod, Sinister Diesel regulated return system, DP F6 tuner (60 tow, 80 econo, 120 race, High idle 1200, Drive Thru) Warn Hubs, 08 tailights, 05-07 front end conversion, 08-11 rear end conversion, Line-xed rocker panels/wheel wells/bumpers.
itorchedparis is offline  
Sponsored Links
Advertisement
 
post #4 of 9 (permalink) Old 09-30-2017, 07:54 PM
Lifetime Supporting Member
Lifetime Supporting Member
 
Andrew G's Avatar
 
Join Date: Apr 2011
Location: St. Augustine, Florida
Posts: 186
My Photos: (0)
Feedback Score: 0 reviews
While the KOER test is running, press the OD switch on and off, press all the buttons on the steering wheel one at a time, turn the wheel half a turn and back, step on the brake pedal, and cycle the 4WD switch. If it's a manual press the clutch pedal to the floor and release, as well. The test doesn't automatically activate all those inputs, so if you don't do it manually it thinks they failed the test.

99.5 F250 7.3 PSD Supercab Shortbed 4x4 on 315 75 16s
Front leveling springs, Hutch and Harpoon mods, A pillar 3 gauge pod with DiPricol Trans, Boost and EGT, Scangauge II, CNC Fab HPOP and HPX lines, Riffraff FRX, 2004 Heated and Lighted mirrors
Andrew G is offline  
post #5 of 9 (permalink) Old 11-13-2017, 10:26 AM Thread Starter
Senior Member
 
itorchedparis's Avatar
 
Join Date: Aug 2009
Location: Western NY
Posts: 301
My Photos: (0)
Feedback Score: 0 reviews
Extremely delayed response here as life is crazy, but I finally went back and did the KOER switch test and this time I actually pushed all the switches haha.

I did this test a couple dozen times just to compare the results and they were hardly consistent. Relating to the cruise control, the CRUISE ON failed and the Brake Position Switch Failed....however, not every time. The Brake position switch failed more often that the Cruise on. Am I doing something wrong that gives me these inconsistencies?

I don't know if this is related but now that's it's getting colder, my truck went into high idle the other day and when I depressed the brake it went back down to normal idle like it should. Does that mean the brake position switch is working properly or is that totally different from cruise?

2000
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
F250 7.3L Lariat, Crew Cab/Short bed 4x4. AFE stage II intake. Magnaflow 3.5DP/4" SS exhaust. Isspro gauges (EGT, Boost, Trans Temp, Fuel Pressure) AIH Delete with riffraff boost fitting adapter, Foil delete, Muffler Delete, CCV Mod, Rebuilt HD Tranny with BTS valve body. 6.0 tranny cooler, ported compressor housing, turbomaster wastegate controller, garret high flow outlet, Non EBPV pedestal, dieselsite boot kit, Marinco mod, HPX mod, Sinister Diesel regulated return system, DP F6 tuner (60 tow, 80 econo, 120 race, High idle 1200, Drive Thru) Warn Hubs, 08 tailights, 05-07 front end conversion, 08-11 rear end conversion, Line-xed rocker panels/wheel wells/bumpers.
itorchedparis is offline  
post #6 of 9 (permalink) Old 11-13-2017, 11:00 AM
Senior Member
 
Join Date: Nov 2016
Location: Greenville,Virginia
Posts: 141
My Photos: (0)
Feedback Score: 0 reviews
check brake switch on end of master cylinder under hood also harness and fuse if it has it my switch went bad replaced switch cruise started working on my early 99
stumpman is offline  
post #7 of 9 (permalink) Old 05-18-2018, 08:02 PM Thread Starter
Senior Member
 
itorchedparis's Avatar
 
Join Date: Aug 2009
Location: Western NY
Posts: 301
My Photos: (0)
Feedback Score: 0 reviews
I can NOT solve my cruise control issue. I have swapped out every possible sensor that I read about including...

Master cylinder brake switch
Master cylinder pressure switch
Brake pedal switch
Clock spring
The cruise buttons themselves
Transmission Range sensor

Nothing has made my cruise work again. The only sensor that I swapped out and then swapped back after it didn't fix the problem is the brake pedal switch so I guess I can try a new one again since I've done the clock spring and buttons since that. I suppose there could be more than one faulty sensor but ****! Is there ANYTHING that I'm missing here? This has me so frustrated

2000
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
F250 7.3L Lariat, Crew Cab/Short bed 4x4. AFE stage II intake. Magnaflow 3.5DP/4" SS exhaust. Isspro gauges (EGT, Boost, Trans Temp, Fuel Pressure) AIH Delete with riffraff boost fitting adapter, Foil delete, Muffler Delete, CCV Mod, Rebuilt HD Tranny with BTS valve body. 6.0 tranny cooler, ported compressor housing, turbomaster wastegate controller, garret high flow outlet, Non EBPV pedestal, dieselsite boot kit, Marinco mod, HPX mod, Sinister Diesel regulated return system, DP F6 tuner (60 tow, 80 econo, 120 race, High idle 1200, Drive Thru) Warn Hubs, 08 tailights, 05-07 front end conversion, 08-11 rear end conversion, Line-xed rocker panels/wheel wells/bumpers.

Last edited by itorchedparis; 05-18-2018 at 08:04 PM.
itorchedparis is offline  
post #8 of 9 (permalink) Old 05-18-2018, 09:32 PM
Lifetime Supporting Member
 
klhansen's Avatar
 
Join Date: Jan 2003
Location: Eagle River, Alaska
Posts: 24,648
My Photos: (180)
Feedback Score: 0 reviews
The one thing that kind of hides in the woodwork as far as cruise control working is the parking brake switch. It's not documented well in the service manual. If yours is hung up and the brake indicator light is burnt out that would explain why the cruise doesn't work. I believe the KOER switch test will also check the parking brake switch, but if not, you can bring up that PID with AutoEnginuity and cycle the switch to see if the PCM can see it change state from on to off (1 or zero on the screen).

First truck -- 1929 Model A Ford pickup, restored from ground up. Wish I still had it!
'99.5 F250 PSD Supercab LB 4x4, ZF-6 w/SB Con OFE, 3.73LS, Boost & pyro gauges, Swamps S175/146 injectors, DP 80 HP Econo PCM (classic version
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
), AIS,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
regulated return,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
klhansen is offline  
post #9 of 9 (permalink) Old 05-18-2018, 10:07 PM
Senior Member
 
79jasper's Avatar
 
Join Date: Dec 2012
Posts: 1,616
My Photos: (0)
Feedback Score: 0 reviews
Can't you run a diagnostic with AE?
Well, at least see if the button are working through the pcm.
Tunes?
Running any LEDs? High mount brake light working?

Sent from my SM-G892A using Tapatalk

1994 F350 7.3 PSD 4X4 ZF5 DUALLY
PHP HYDRA, 6637, 3-4 DP TO STRAIGHT 4 BEHIND THE TIRE, 1.0 EXHAUST HOUSING, DIY D66 TURBO, FUGA E-FUEL, EBPV DELETE. Cooper discoverer AT/3'S.

2010 VW JETTA TDI DSG Kerma tune. Hankook ventus v2 concept 2.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
79jasper is offline  
Sponsored Links
Advertisement
 
Reply

  Diesel Forum - TheDieselStop.com > 1999-2007 Ford Super Duties > 1999-2007 General Questions

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Forum - TheDieselStop.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome