Intermittent Gauge Cluster issue¯.ideas? - Diesel Forum - TheDieselStop.com
1999-2007 General Questions General questions related to 1999-2007 Super Duty trucks. If it doesn't fit the other categories, post it here. Gas engine discussion that pertains to all models is allowed. Specific gas engine questions should use the Gas Engines forum.

 1Likes
  • 1 Post By iqraceworks
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 06-11-2018, 12:06 PM Thread Starter
Senior Member
 
iqraceworks's Avatar
 
Join Date: Jan 2018
Posts: 199
My Photos: (0)
Feedback Score: 0 reviews
Question Intermittent Gauge Cluster issue….ideas?

A few weeks ago I had a strange issue with my gauge cluster in my 05’ F250. I fired up the truck, and put it in 4-low …as soon as I shifted the transfer case into 4x4, the display on the gauge cluster popped up a TBC error fault, the check engine and wrench light came on, the odometer read “- - - - - - - - - - - -“, and the speedo and tach went dead….but the truck still idled and ran just fine. I shut it off, restarted the truck……..and everything worked fine. I scanned the truck for any fault codes, nope…nothing, no faults of any kind. I tried shifting the transfer case into 4L and back into 2H again…worked fine, no issues. I figured it was just a fluke…..


Fast forward a week….and I’m at the campground with my family last weekend with our camper. I fire up the truck in the morning, the dash display instantly does the same thing….TBC fault display, no odometer, tach, speedo, and check engine light. Crap! Well, I let the truck idle for a few minutes…..all of a sudden, the TBC fault clears, and everything starts working again. Never had a problem the rest of the day.


I’ve checked the plugs going into the gauge cluster…nothing appeared to be lose. I might try calling circuit board medics and see what they think….but I’m sure they will want to just rebuild the gauge cluster….because that’s what they get paid to do.


So does this sound like the common gauge cluster problem…..or something else? The thing about it doing it as soon as I shifted the transfer case into 4low doesn’t make any sense to me…..along with getting a TBC fault, that’s odd also.


Thoughts?
mike029 likes this.
iqraceworks is offline  
Sponsored Links
Advertisement
 
Reply

  Diesel Forum - TheDieselStop.com > 1999-2007 Ford Super Duties > 1999-2007 General Questions

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Forum - TheDieselStop.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome