96 7.3 PSD no CC or 4th/OD - Diesel Forum - TheDieselStop.com
Power Strokes 1994-1997 General Technical discussion of topics related to vehicles powered by the Power Stroke engine in 1994 through 1997 models.

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 08-15-2019, 12:45 PM Thread Starter
Junior Member
 
Join Date: Aug 2019
Location: San Antonio TX.
Posts: 4
My Photos: (0)
Feedback Score: 0 reviews
Question 96 7.3 PSD no CC or 4th/OD

I am trying to troubleshoot an issue I have recently discovered with a 1996 F250 7.3L SRW. The vehicle had been sitting for a couple months without being ran, and last week in preparation for me to come and pick it up ( I am Active Duty Army stationed in TX and truck is located in Oregon ) my father got the truck running and took it for a quick ride just to check everything out. He noticed that cruise control no longer works as it did previously as well as not wanting to shift into 4th / OD unless under heavy acceleration but will then come back out into 3rd with TC Lock up, so at 65 Mph its running about 2500 Rpm's. there is no CEL and the OD Light does not flash, he also stated that all brake lights work correctly and the fuses all looked good. I am headed out there this weekend to get the truck and drive back to Texas with it but want to rectify this issue(s) as I'm not sure where to look at this point and don't want to encounter issues during the trip. The Truck has 181k on the ODO and had a transmission rebuild roughly 3 years / 70k miles ago which it has had 0 issues since the rebuild until recently when it had sat and not ran for a couple months.

1996 Super Cab F250 7.3L PSD RWD, all stock with 4.10 Gears
DocRenegade is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 08-15-2019, 02:42 PM
Lifetime Supporting Member
Lifetime Supporting Member
 
bugman's Avatar
 
Join Date: May 2002
Location: Gypsum, Co
Posts: 8,406
My Photos: (12)
Feedback Score: 1 reviews
Make sure that that third brake light on the cab is working.

If it had the cruse recall done check the fuses just off of the master brake cylinder.

Is the speedometer working? It could also be the VSS on the top of the rear end housing.

96 F250 PS XLT 4X4 long box, 5sp,4.10, manual hubs,pyro+boost guages, Dark Toumaline, add a leaf, Dale's TYMAR, and HX hose, downpipe, coolant filter, Luk clutch
bugman is offline  
post #3 of 8 (permalink) Old 08-15-2019, 02:55 PM Thread Starter
Junior Member
 
Join Date: Aug 2019
Location: San Antonio TX.
Posts: 4
My Photos: (0)
Feedback Score: 0 reviews
Bugman,

he said the 3rd brake light was good, speedo and tach work fine, no bouncing or irregularities in performance. I'm not sure if the recall had been done, once I get there this weekend ill give those a look over, any way to test the VSS ?

1996 Super Cab F250 7.3L PSD RWD, all stock with 4.10 Gears
DocRenegade is offline  
Sponsored Links
Advertisement
 
post #4 of 8 (permalink) Old 08-15-2019, 04:34 PM
Lifetime Supporting Member
Lifetime Supporting Member
 
bugman's Avatar
 
Join Date: May 2002
Location: Gypsum, Co
Posts: 8,406
My Photos: (12)
Feedback Score: 1 reviews
If the speedometer and odometer is working then the VSS should be fine.

I am not a automatic fan so that is about all I know of that you can check if things are not working properly. On the cruse recall if you look at the master cylinder you can tell if it has been done or not. I'll add a picture of what it looks like, but I am not sure if you can see the fuses or not, but there is a big blue tag on the new part.
Attached Thumbnails
Click image for larger version

Name:	Recalled Harness I.JPG
Views:	10
Size:	1.18 MB
ID:	127666  


96 F250 PS XLT 4X4 long box, 5sp,4.10, manual hubs,pyro+boost guages, Dark Toumaline, add a leaf, Dale's TYMAR, and HX hose, downpipe, coolant filter, Luk clutch
bugman is offline  
post #5 of 8 (permalink) Old 08-15-2019, 08:22 PM
Lifetime Supporting Member
 
Mark Kovalsky's Avatar
 
Join Date: May 1999
Location: SE Florida, USA
Posts: 11,582
My Photos: (6)
Feedback Score: 0 reviews
I can't think of anything in common that would prevent it from shifting into fourth AND keep the cruise from working. I can easily think of how no cruise and no torque converter lock could happen.

Are you certain that the converter is locking and that it isn't shifting to fourth gear with the converter unlocked? It's really easy to mix up the lockup and the 3-4 shift.

No lockup can be caused by a bad brake on/off switch on the brake pedal, a bad pressure switch on the master cylinder, or a bad brake light.

Mark
Former
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Automatic Transmission Engineer 1988-2007


“The good thing about science is that it's true whether or not you believe in it.” ― Neil deGrasse Tyson
Mark Kovalsky is offline  
post #6 of 8 (permalink) Old 08-16-2019, 10:58 AM
Senior Member
 
Join Date: Nov 2010
Location: Flagstaff,Az.
Posts: 481
My Photos: (0)
Feedback Score: 0 reviews
Just checking don't forget about the 3rd brake light that is where I had an issue once upon a time.

I have a 95 F350 PS/DRW/LB which I bought in 05' with 102,000mi from original owner as of 6/29/12 it has 920,798 mi.on the original engine.It runs great and pulls even better.It pulls commercially anything and everything that pays me money Ha,Ha.Upgrades done are an all steel cowl induction hood to help get the heat out of the engine bay,Banks inter-cooler hardware kit using a cooler from a 99 PS,TRUCOOL tranny cooler,Magtech alum.finned tranny and rear diff.covers,DP tunes 40T,60T,60E.S&W guages BST/Trans.Temp/EGT,K&N cold air intake,BD 4"exhaust,HPturbochargers did my upgrades on turbo with banks impeller(a little diff.pitch and height than the stock garrett splitter wheel) and 1.0 exh.for faster spool-up WOW!I'm hoping to hit 1 million miles or more before having to put my drop-in crate engine in.I can only hope that it will be just as good.Hopefully! I can be of assistance to any one needing help with thier PS with problems that I may or may not have encountered.GOOD LUCK!
themule67 is offline  
post #7 of 8 (permalink) Old 08-16-2019, 11:42 AM
Junior Member
 
Jbloodworth80@gmail.com's Avatar
 
Join Date: Jul 2019
Posts: 12
My Photos: (0)
Feedback Score: 0 reviews
I just dealt with the same issue mine was a combo bad third brake light and a 7 pin trailer connector in the bed had rubbed through and shorted. Mine was shifting into 4th but torque converter not locking. Bet possible a mouse got ur wiring while it was sitting. Let us know what u find.
post #8 of 8 (permalink) Old 09-04-2019, 01:18 PM Thread Starter
Junior Member
 
Join Date: Aug 2019
Location: San Antonio TX.
Posts: 4
My Photos: (0)
Feedback Score: 0 reviews
I was able to resolve the issue, turns out something ate a wire in the wiring harness in the engine bay. spliced and soldered a new wire in and everything works as it should... minus the speedometer needle bouncing at speeds over 60 mph. I replaced the speed sensor in the rear differential with a motorcraft replacement, also had to replace the connecter as the retaining clips broke but that did not resolve the bounce. tachometer doesn't bounce and there are no SES light or ABS light.

1996 Super Cab F250 7.3L PSD RWD, all stock with 4.10 Gears
DocRenegade is offline  
Sponsored Links
Advertisement
 
Reply

  Diesel Forum - TheDieselStop.com > Ford Diesels > Power Strokes 1994-1997 General

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Forum - TheDieselStop.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome