Whats my problem?? - Diesel Forum - TheDieselStop.com
Power Strokes 1994-1997 General Technical discussion of topics related to vehicles powered by the Power Stroke engine in 1994 through 1997 models.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 03-03-2009, 03:29 PM Thread Starter
 
Join Date: Mar 2009
Posts: 1
My Photos: (0)
Feedback Score: 0 reviews
Whats my problem??

I just drove down from Kingman, AZ (Where I live - "close to retirement") to San Diego, CA (Where I am stationed), In my 96 F350 7.3L 210000miles....

At the ThousandPalms "Flying J" I checked the oil and it looked low and wierd - but I couldnt recognize the smell (seemed to be a combo of stuff).. It was NOT chocolate milk looking as if it was pure antifreeze.. but it did have some bubbles and was a runny... So I dumped in 3 bottles of LUCAS engine oil additive (to thicken up the mix) to get me the remaining 138miles to base so I could get underway yesterday morning (didnt wanna miss ships movement).. I didnt have the time Monday morning when I got in to check everything very thorough due to the time and it was dark out (0330). but it almost smelled like diesel and antifreeze.. like I said a wierd smell.. the exhaust had ZERO smoke of any kind.. but did smell of oil.
(Usually a 6hr trip - ended up being a 10hr trip, cause I wanted to take an easy).. ..

So I have came to the conclusion of (All base on Internet Searching):
- Possible blown head gasket
- I need to pressure test my coolant system
- Probably will have to replace the injector cups (will know forsure when I remove the injectors)
- should probably replace the injector O-rings (Speaking of this - Anyone have the numbhers for the injector O-Rings from VITON)
- Need to check the coolant overflow for oil slick.

Is there anything else I need to look at?? I did atleast mark the coolant overflow bottle so after this week of underway I can see if there is a difference.. and as far as fuel.. well all I could do is mark where the needle was at when I turned it off.

Thanks for any assistance and or insight..

Tim
g19amc is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 03-03-2009, 07:04 PM
Senior Member
 
Join Date: Apr 2001
Location: washington state (Go Mariners)
Posts: 813
My Photos: (0)
Feedback Score: 0 reviews
also check your fuel filter for oil contamination, if the filter is black... it usually means injector orings are shot.

97 f250 4x4 ext cab tymar filter e4od 410 ts chip dp and 4" exhaust system
julyer is offline  
post #3 of 3 (permalink) Old 03-04-2009, 10:12 PM
Member
 
BiodieselPlace's Avatar
 
Join Date: May 2008
Posts: 51
My Photos: (0)
Feedback Score: 0 reviews
Could be your engine oil cooler.
I just did mine. Different sympton though, I had an oil leak coming out of the oil cooler o-ring.
But oil AND coolant come together at the oil cooler.
Just a thought.

---------------------------------------------------
* 96 F250 PSD, CC, SB, 2wd, auto, 3:55s
* 280,000 miles
* Tymar Performance intake
* 10K mod
* FPR shim
* DIY Exhaust Brake
* 3" downpipe
* Rotella Synthetic Engine Oil
* B100 all the way!
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

---------------------------------------------------
BiodieselPlace is offline  
Sponsored Links
Advertisement
 
Reply

  Diesel Forum - TheDieselStop.com > Ford Diesels > Power Strokes 1994-1997 General

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Forum - TheDieselStop.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome