'1990 7.3L Turbo diesel E4OD flashing OD light - Diesel Forum - TheDieselStop.com
7.3L IDI Diesels (Not Power Strokes) Technical discussion of topics related to vehicles powered by the 7.3 Liter In-Direct Injection Navistar engines.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 12-05-2018, 04:25 PM Thread Starter
Junior Member
 
Join Date: Mar 2011
Posts: 1
My Photos: (0)
Feedback Score: 0 reviews
'1990 7.3L Turbo diesel E4OD flashing OD light

I have a 90 E350 with a 7.3 turbo diesel and an E4OD. I believe it has 167,000 miles, came from the state with records and appears to have had regular maintenance. No maintenance listed on transmission other then fluid level checks. The OD light flashes almost as soon as you start driving. The switch is mounted on the dash not on the end of the shifter. Transmission shifts smooth through all 4 gears so its NOT in limp mode. Fluid is full and not burnt. You can turn OD off and on and see the change in RPM. Having problems pulling a code, either no code or failure to read. So looking to see if anyone has ran into this issue.

Last edited by sarhuey212; 12-05-2018 at 04:32 PM.
sarhuey212 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 12-05-2018, 05:28 PM
Lifetime Supporting Member
 
Mark Kovalsky's Avatar
 
Join Date: May 1999
Location: SE Florida, USA
Posts: 11,473
My Photos: (6)
Feedback Score: 0 reviews
It never reports no code. There is ALWAYS a code, even if it is a code 11, which is no problems found. You're going to have to fix the problem that is keeping you from reading codes first, then we can find out what's wrong with the transmission.

Are you using this method? https://www.troublecodes.net/ford/

Mark
Former
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Automatic Transmission Engineer 1988-2007


“The good thing about science is that it's true whether or not you believe in it.” ― Neil deGrasse Tyson
Mark Kovalsky is offline  
Sponsored Links
Advertisement
 
Reply

  Diesel Forum - TheDieselStop.com > Ford Diesels > 7.3L IDI Diesels (Not Power Strokes)

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Forum - TheDieselStop.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome