7.3L IDI fuel trouble and glow plugs controller - Diesel Forum - TheDieselStop.com
7.3L IDI Diesels (Not Power Strokes) Technical discussion of topics related to vehicles powered by the 7.3 Liter In-Direct Injection Navistar engines.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 22 (permalink) Old 05-09-2018, 07:25 PM Thread Starter
Junior Member
 
CowboyMoyer's Avatar
 
Join Date: May 2018
Posts: 19
My Photos: (0)
Feedback Score: 0 reviews
7.3L IDI fuel trouble and glow plugs controller

well i have a 1993 7.3 crew cab dually with after market turbo on it, im not getting fuel to my injectors, i have put a new fuel pump and another injector pump and im fixing to change it again, help help me please, motor was just freshly rebuilt it has about 20 miles on motor, with alot of new parts.
Attached Thumbnails
Click image for larger version

Name:	20171219_144849_1525911454756.jpg
Views:	26
Size:	591.3 KB
ID:	123473  

Click image for larger version

Name:	20171219_144830_1525911786036.jpg
Views:	20
Size:	635.2 KB
ID:	123489  

CowboyMoyer is offline  
Sponsored Links
Advertisement
 
post #2 of 22 (permalink) Old 05-09-2018, 08:09 PM
Senior Member
 
Join Date: Apr 2002
Location: Pocono Mountains in beautiful eastern Pennsylvania
Posts: 360
My Photos: (0)
Feedback Score: 0 reviews
Help is on the way.

Don't want to sound like a smart alec, but do you have fuel in the tank?
You need at least 1/2 tank, both front and rear, reason is this, Foot valve in tank will eventually fail, leaving the last 3 inches or so of fuel out of reach. Also , selector valve may get stuck, so you might have air coming in from an empty tank.
After fuel level has been established, air must be manually bled from the fuel filter and the injection pump.
Then, open the injector lines a few turns,(till the nut is a bit loose),at the injector.
Crank engine to remove air from lines.
Tighten lines.
You may want a battery charger hooked up while you do this, as a long cranking session will drain batteries. These engines need a bit of speed while cranking,low batteries will compound any previous problems.
I don't check in here that often, but others are around, I'm sure enough talent and experience exist here to help you with this.
Enjoy, Ed.
supermechanic is offline  
post #3 of 22 (permalink) Old 05-09-2018, 09:39 PM
Junior Member
 
Join Date: May 2018
Location: OREGON
Posts: 19
My Photos: (0)
Feedback Score: 0 reviews
IS THE INJECTOR PUMP SOLENOID TURNING ON? THERES A SOLENOID THAT CAN GO BAD I BELIEVE ITS INSIDE THE PUMP BUT I DONT REMEMBER LOCATION FOR SURE.
C.MITCHELL is offline  
Sponsored Links
Advertisement
 
post #4 of 22 (permalink) Old 05-09-2018, 09:40 PM
Junior Member
 
Join Date: May 2018
Location: OREGON
Posts: 19
My Photos: (0)
Feedback Score: 0 reviews
LETS ACTUALLY START WITH ARE YOU GETTING FUEL TO THE INJECTOR PUMP?
C.MITCHELL is offline  
post #5 of 22 (permalink) Old 05-09-2018, 11:30 PM
Member
 
genscripter's Avatar
 
Join Date: Feb 2018
Location: Inglewood CA USA
Posts: 72
My Photos: (0)
Feedback Score: 0 reviews
First off, Are you getting fuel to the Schrader Valve on your Diesel Fuel Filter? What to do if no Diesel Fuel is coming out of the Schroeder Valve on a 6.9 / 7.3 IDI ? IDI Online


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
genscripter is offline  
post #6 of 22 (permalink) Old 05-09-2018, 11:42 PM
Junior Member
 
Join Date: May 2018
Location: OREGON
Posts: 19
My Photos: (0)
Feedback Score: 0 reviews
JUST SHOOTING IN THE DARK BUT IF IT RAN FOR 20 MILES AND QUIT, HAVE YOU CHECKED THE LIFT PUMP DRIVE? IM NOT A BIG IDI MECHANIC SO I DON'T RECALL HOW THEY OPERATE... JUST A THOUGHT
C.MITCHELL is offline  
post #7 of 22 (permalink) Old 05-09-2018, 11:44 PM Thread Starter
Junior Member
 
CowboyMoyer's Avatar
 
Join Date: May 2018
Posts: 19
My Photos: (0)
Feedback Score: 0 reviews
im getting fuel to the injector pump fine, but nothing coming out of pump, some time it starts and sometimes it just turns over, i got another injector pump ill be in stalling tomorrow
CowboyMoyer is offline  
post #8 of 22 (permalink) Old 05-09-2018, 11:45 PM Thread Starter
Junior Member
 
CowboyMoyer's Avatar
 
Join Date: May 2018
Posts: 19
My Photos: (0)
Feedback Score: 0 reviews
lift pump brand new only 20 miles
CowboyMoyer is offline  
post #9 of 22 (permalink) Old 05-09-2018, 11:48 PM
Member
 
Join Date: Apr 2000
Location: MO
Posts: 45
My Photos: (0)
Feedback Score: 0 reviews
Quote:
Originally Posted by C.MITCHELL View Post
JUST SHOOTING IN THE DARK BUT IF IT RAN FOR 20 MILES AND QUIT, HAVE YOU CHECKED THE LIFT PUMP DRIVE? IM NOT A BIG IDI MECHANIC SO I DON'T RECALL HOW THEY OPERATE... JUST A THOUGHT
When I got my IDI, one of the first things I did was install an electric lift pump (Facet/Duralift 40285) and eliminate the mechanical pump. I made a careless mistake and hooked the relay to the fast idle solenoid instead of the fuel shutoff solenoid. So whenever the truck warmed up enough to come off fast idle, the pump would turn off!

The strange thing is that it never stopped running. There was just a mild bog when accelerating uphill. Anyway I would check the lift pump, but not necessarily first. I am not sure if mechanical pumps can be "sucked-through" but the electric sure can and the truck will start and run
Charles-65F350 is offline  
post #10 of 22 (permalink) Old 05-09-2018, 11:59 PM Thread Starter
Junior Member
 
CowboyMoyer's Avatar
 
Join Date: May 2018
Posts: 19
My Photos: (0)
Feedback Score: 0 reviews
where did you get electric pump at
CowboyMoyer is offline  
post #11 of 22 (permalink) Old 05-10-2018, 01:14 AM
Member
 
genscripter's Avatar
 
Join Date: Feb 2018
Location: Inglewood CA USA
Posts: 72
My Photos: (0)
Feedback Score: 0 reviews
Quote:
Originally Posted by Charles-65F350 View Post

The strange thing is that it never stopped running. There was just a mild bog when accelerating uphill. Anyway I would check the lift pump, but not necessarily first. I am not sure if mechanical pumps can be "sucked-through" but the electric sure can and the truck will start and run

I have an e-pump as well. I didn't install a relay, but rather an on-off switch that I turn on whenever I start up the engine. One day I forgot to turn on the switch and the van drove fine for several miles. I think as long as you don't have any air in the system or major load on the engine, the IP will suck thru the e-pump just fine. (for short occurrences or emergencies, of course)


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
genscripter is offline  
post #12 of 22 (permalink) Old 05-10-2018, 01:43 PM Thread Starter
Junior Member
 
CowboyMoyer's Avatar
 
Join Date: May 2018
Posts: 19
My Photos: (0)
Feedback Score: 0 reviews
got it up and running now
CowboyMoyer is offline  
post #13 of 22 (permalink) Old 05-10-2018, 09:53 PM
Member
 
Join Date: Apr 2000
Location: MO
Posts: 45
My Photos: (0)
Feedback Score: 0 reviews
Great! What was the problem?

Quote:
where did you get electric pump at
I found the lowest price at Aircraft Spruce. Around $102 shipped I think.
Charles-65F350 is offline  
post #14 of 22 (permalink) Old 05-10-2018, 11:09 PM Thread Starter
Junior Member
 
CowboyMoyer's Avatar
 
Join Date: May 2018
Posts: 19
My Photos: (0)
Feedback Score: 0 reviews
i charged both batteries and bleed the air out of the lines and had fuel return leaking fuel luke crazy but i put new set of o rings but didnt work so i put another new set in there and it held it so far, but i got her running now its going monday for new exhaust on it idk what to go with yet
CowboyMoyer is offline  
post #15 of 22 (permalink) Old 05-11-2018, 07:11 AM
Senior Member
 
chuckster57's Avatar
 
Join Date: Apr 2008
Location: Central Valley, Ca.
Posts: 17,604
My Photos: (7)
Feedback Score: 1 reviews
Anything over 3 inch diameter exhaust is a waste of money.

1994 F-350 7.3 IDI Turbo, crew cab, E4OD,4:10 L/S, LB, Dually
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

ATS Turbo upgrades: 3" DP with 3" exhaust Magnaflow XL muffler:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2012 Copper Canyon 273 FWRET w/2 slides, Air Lift 5000 bags
Pillar pod: Autometer C2 Series gauges: pyro,trans, boost, water, oil pressure
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Hypermax Cowl induction, K&N air filter, flex-a-lite 26K trans cooler with fan,Tekonsha prodigy
Train Horns:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


PM please not visitor message
chuckster57 is offline  
Sponsored Links
Advertisement
 
Reply

  Diesel Forum - TheDieselStop.com > Ford Diesels > 7.3L IDI Diesels (Not Power Strokes)

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Forum - TheDieselStop.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome