'88 F-SuperDuty 7.3 IDI Surging - Diesel Forum - TheDieselStop.com
7.3L IDI Diesels (Not Power Strokes) Technical discussion of topics related to vehicles powered by the 7.3 Liter In-Direct Injection Navistar engines.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 08-19-2019, 04:04 PM Thread Starter
Junior Member
 
Join Date: Aug 2019
Posts: 1
My Photos: (0)
Feedback Score: 0 reviews
Question '88 F-SuperDuty 7.3 IDI Surging

Hi there everybody, first time posting but I have found some information useful on this site and so figured it would be a good place to start now that this thing finally has me stumped.

We bought a '88 Super Duty with the 7.3 IDI, I believe to be original, engine. This was back at the end of March. We are using the truck for landscape work and have had problems in the past, almost one after another, but it has done quite a bit of work with all the repairs we have been able to do ourselves. New mechanical lift pump, clear hose from that to the water separator, new injectors and return lines, new strainer in the tank.

About a month ago we had a problem, once or twice, with the truck revving on it's own. Did it in gear or idling in neutral, never really a lot of revving just slightly, maybe 500 rpm. We were also having power issues at the same time and blowing the return lines helped on multiple occasions, never really had any problem after that with it revving on its own until about a week ago.
A couple of the injectors were leaking and the truck would build an air bubble in the clear tube that seemed to be coming from inside the filter after sitting. Truck has almost always needed ether to start after sitting for more than a day since we bought it.
We just recently did the injectors and return lines hoping to prevent having to continue blowing the return lines out and it ran well for a couple of days before the surging came back with a vengeance.
There is still a small air bubble in the hose after sitting after the injectors were changed.

We did the oil change because it needed to be done anyway, no change to the surging. Sprayed the injection pump down with WD-40 because someone who has helped before suggested to and it seemed to fix it for a couple of miles but the problem came right back.

This has finally got us stumped, like I say, we have been able to fix everything before this but I cannot seem to figure out where to go next with this one. Sticking metering valve inside the injection pump?

We're also having problems with the 2006 F-350 6.0 Powerstroke that we just bought, 9 days after bringing it home from the dealership and it's been down since. We just registered a landscape business back in October of last year and so we really need to find a way to get one of these trucks running. I will post about the '06 in the other section of the forums here and add that link to this one.

Thanks in advance for all your time and advice.
Patrick
PatrickHan is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 08-26-2019, 06:00 PM
Senior Member
 
Join Date: Nov 2008
Location: Salina, Kansas
Posts: 1,554
My Photos: (0)
Feedback Score: 0 reviews
If the engine speeds up on its own up after it has been running, that usually means it is running out of fuel. Check fuel pressure at the Schrader valve, should be somewhere around 4 PSI. It is possible that the fuel metering valve in the injector pump is sticking. you can try soaking it with sea foam, by replacing the filter and priming it with sea foam, then let it run for a couple of minutes. Shut it down and let it sit over night. That might clear up the sticky valve...if it isn't completely worn out, that is. I've never heard of a governor "hunting" on one of these engines, but I wouldn't rule that out either. There isn't really any telling how old the injector pump is, is there? It might just be getting tired.

1993 F-350 crew cab non-turbo 5 speed transmission
35 years a mechanic on large stationary engines natural gas and diesel fired, and other industrial equipment.
oldrebuiltdodge is offline  
Sponsored Links
Advertisement
 
Reply

  Diesel Forum - TheDieselStop.com > Ford Diesels > 7.3L IDI Diesels (Not Power Strokes)

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Forum - TheDieselStop.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome