Hard start no wts light. After start, wts light works - Diesel Forum - TheDieselStop.com
7.3L IDI Diesels (Not Power Strokes) Technical discussion of topics related to vehicles powered by the 7.3 Liter In-Direct Injection Navistar engines.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 12-11-2018, 07:01 PM Thread Starter
Junior Member
 
Join Date: Apr 2018
Posts: 4
My Photos: (0)
Feedback Score: 0 reviews
Hard start no wts light. After start, wts light works

Been having an issue. When I go to start my van no wts light and a hard start lots of smoke, like an airleak. Controller clicking.

After van starts I turn it off and when I turn it back on wts light is on for 8 seconds and van starts rite up.
All glow plugs test good and are newer within 1000 miles and controller is same. Good glow plugs not auto lites.
I do have one plug wire that has a bullet connector that stays on plug tip but not super tight maybe that could be the culprit?

Let me know what y’all think
Thanks
Surfnfisher is offline  
Sponsored Links
Advertisement
 
Reply

  Diesel Forum - TheDieselStop.com > Ford Diesels > 7.3L IDI Diesels (Not Power Strokes)

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Forum - TheDieselStop.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome