No start my '1993 Ford E350 7.3L IDI - Diesel Forum - TheDieselStop.com
7.3L IDI Diesels (Not Power Strokes) Technical discussion of topics related to vehicles powered by the 7.3 Liter In-Direct Injection Navistar engines.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 05-03-2018, 06:40 PM Thread Starter
Junior Member
 
Join Date: May 2008
Location: AZ
Posts: 6
My Photos: (0)
Feedback Score: 0 reviews
No start my '1993 Ford E350 7.3L IDI

Hi All
I have a 1993 Ford E350 7.3L It will not start it will fire if you spray diesel fuel in intake, I replaced fuel pump . still nothing, I checked pressure line just before injection pump its fine. I checked fuel getting to injectors , its not spraying fuel to injectors, I unplug wire for injection pump cut off its getting power to the cut off solenoid it clicks. the engine light is not on. is it bad injection pump , I have no code reader to see if giving any code..
rcrick0 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 05-03-2018, 09:59 PM
Senior Member
 
chuckster57's Avatar
 
Join Date: Apr 2008
Location: Central Valley, Ca.
Posts: 17,604
My Photos: (7)
Feedback Score: 1 reviews
Your not going to get any codes, so dont bother trying.

First thing is to check the glow plugs. If any of them are bad, change them all. Use only mororcraft plugs. You can use Wellman just DONT use Autolite. Next is battery(s) need to be up to snuff to spin engine at least 300 RPM. Then check for fuel pressure at the filter header. 4-7 PSI using schrader valve fitting.

At cranking RPM, very little fuel is sent to injectors so you may not see much. Post back after checking what I’ve suggested and we can go from there.

1994 F-350 7.3 IDI Turbo, crew cab, E4OD,4:10 L/S, LB, Dually
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

ATS Turbo upgrades: 3" DP with 3" exhaust Magnaflow XL muffler:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2012 Copper Canyon 273 FWRET w/2 slides, Air Lift 5000 bags
Pillar pod: Autometer C2 Series gauges: pyro,trans, boost, water, oil pressure
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Hypermax Cowl induction, K&N air filter, flex-a-lite 26K trans cooler with fan,Tekonsha prodigy
Train Horns:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


PM please not visitor message
chuckster57 is offline  
post #3 of 4 (permalink) Old 05-03-2018, 10:25 PM Thread Starter
Junior Member
 
Join Date: May 2008
Location: AZ
Posts: 6
My Photos: (0)
Feedback Score: 0 reviews
has new batterys bought month ago, has new glow plugs also. I ran fine . one morning I started it it ran for min. them stalled had no fuel pressure so I put new fuel pump , now it has fuel pressure
rcrick0 is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 05-10-2018, 09:09 AM
Senior Member
 
Join Date: Nov 2008
Location: Salina, Kansas
Posts: 1,554
My Photos: (0)
Feedback Score: 0 reviews
Check power to the fuel shut off solenoid, and that it operates. Also check power to the glow plugs...while they're cycling. I checked one with the system off all ok still couldn't get anything, checked with the system active, nothing. Turned out to be the fusible link.

1993 F-350 crew cab non-turbo 5 speed transmission
35 years a mechanic on large stationary engines natural gas and diesel fired, and other industrial equipment.
oldrebuiltdodge is offline  
Sponsored Links
Advertisement
 
Reply

  Diesel Forum - TheDieselStop.com > Ford Diesels > 7.3L IDI Diesels (Not Power Strokes)

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Forum - TheDieselStop.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome