Diesel Forum - TheDieselStop.com - Reply to Topic
6.4L Power Stroke Engine and Drivetrain Discussion of the 6.4L Power Stroke diesel engine and drivetrain in the 2008-Up Super Duty trucks. No gas engine discussion allowed except on transmissions and drivetrain that pertain to all models. Please confine discussion of topics in this forum to those items that are specific to the 6.4L Power Stroke engine.

Thread: Intermittent Cruise Control Function Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Diesel Forum - TheDieselStop.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
08-07-2019 01:12 PM
Beachlady2009
Quote:
Originally Posted by MPD56 View Post
Mark: if you left click on his name in blue writing (FordCustomerService) a window will come down and then click on “send a private message to FordCustomerService”.

As far as the brake pressure switches, there are two screwed in the bottom of the master cylinder and also a switch on the brake pedal, sorry not sure how they are tied to the cruise control. I do know that the cruise control circuits go through self tests and are monitored by the ECM and if there is an error, it will disable the cruise control and produce a diagnostic code that will be stored in the ECM, but won’t produce the MIL or Wrench light. Chances are you might have a code stored and maybe a reader other then a Dealer’s will tell you. Also there are other codes that will disable the cruise control, for example if the EGR valve sticks and the truck goes into “Limp Home Mode”.
I have a F350 and have replaced the brake pedal switch and the master cylinder switch myself, still not working properly. Had it into my auto repair shop. they dismantled the entire system, could not see a problem, diagnostics found nothing. Had it a week with no luck. Put it all back together and it worked. The cruise worked fine driving around the area. Drove it for 160 miles, shut it down 30 minutes, cruise still working. Drove about 5 miles further, shut it down for about 3 hours and cruise will not work. Craziest thing I have ever seen. Don't know what to do now except try to replace the cruise control buttons in the steering wheel. It's almost like it may be overheating during long trips. Park it overnight, crank her up the next morning and its working.
03-31-2014 09:37 AM
Nomoreram Had the same problem with my 2010 F250. Took it too the dealer and told them to replace the brake pressure switch and that solved my problem.
03-29-2014 01:22 AM
tstpnb I had this happen on my job 1 08 as well. Replaced brake pressure switch and still had problems. I traced my issue to the harness under the steering wheel. There is a connector that is under the plastic cover directly under the wheel on the column, that takes all the signals from the wheel controls. One of the connections was loose, i.e. i could jiggle it while driving and get it to turn on and off. I just played around with it until is was consistently working, and then secured it the best i could. This worked for me and was a fairly easy fix. Hope this helps.
03-12-2014 11:01 AM
thunderace31
Quote:
Originally Posted by rudiak View Post
Here is a list of applications. Motorcraft SW-6350 | Frugal Mechanic
Ford Parts says the Number is SW-6349 is this the same part just with the wires ? Really need to get this fixed not have cruise for long freeway rides sucks really bad
Thanks again
03-12-2014 08:51 AM
rudiak Here is a list of applications. Motorcraft SW-6350 | Frugal Mechanic
03-11-2014 01:25 PM
thunderace31
Quote:
Originally Posted by rudiak View Post
This part doesnt look to be for a 2008-2010 F250 is this the right part or is there an updated one?? My truck has this issue and its starting to drive me nuts!
Thanks for the help
08-04-2013 04:01 PM
tree rooster Thanks for the info. This is my first ford and it seems like every day something else is going bad. Ugh.
08-04-2013 01:16 PM
senix Pm tousely ford, one of the site sponsor about what you need. They give good prices and won't try to sell the whole item when all you need is a piece.
08-04-2013 12:22 PM
rudiak Try this.


08-04-2013 11:11 AM
tree rooster
part #

Anyone have the part # I asked the dealer here wheni was in there getting new washer nozzles and he said I had to buy the whole master cylinder!!!
07-24-2013 04:11 PM
fatboytx
Quote:
Originally Posted by kennyp View Post
My check engine light came on a week or so ago and the code said it was the exhaust temperature sensor bank 1 sensor 3. Soon after the check engine light came on my cruise stoppped working. Could the exhaust temperature sensor problem have any affect on my cruise?
Read my thread "P2033 code" for solution. Easy 15 min fix for EGT sensor.

No, they are not related. The cruise control is a very well known problem and easy fix. Just search this forum. Took me maybe 10 mins.

-FB
07-20-2013 11:27 PM
MPD56 When you get some engine trouble codes the truck's computer will disable the cruise control. Most likely your problem if the cruise control stop working at the same time. For sure the cruise won't work if the truck goes into "Limp Home Mode or reduce power mode.
07-20-2013 10:13 PM
kennyp My check engine light came on a week or so ago and the code said it was the exhaust temperature sensor bank 1 sensor 3. Soon after the check engine light came on my cruise stoppped working. Could the exhaust temperature sensor problem have any affect on my cruise?
11-17-2012 04:00 PM
JohnG3
Cruise control

Had the same problem with my 2010 F250. Dealer fixed it under warranty. Was the pressure switch. In the beginning the CC would not work infrequently. Got progressiveky worse. By the time I took it in the CC wouldn't work at all. The service writer said that the problem may effect the brake controller. I didn't notice that and I towed several time wtih it not working.
11-11-2012 11:14 PM
tickedoff36 i bypassed my switch and i still have problems 99 f350 7.3 6spd. i just tied the two wires together between the fuses on the replacement harness i still have the occasional problem but it works better.
This thread has more than 15 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome