Diesel Forum - TheDieselStop.com - Reply to Topic
E-Series Vans Technical discussion of topics related to vans powered by any of the Navistar engines. This covers a broad number of years, but there isn't enough demand to split it any further.

Thread: Hi, need help hard starting gets worse when it's colder out Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Diesel Forum - TheDieselStop.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
12-04-2015 07:09 AM
dutyhole
Quote:
Originally Posted by Snotzalot View Post
You'll get more than enough help on the 7.3 IDI forum, ask about your starting there. They are also good with trans issues.

7.3L IDI Diesels (Not Power Strokes) - Diesel Forum - TheDieselStop.com
THANK YOU !!
12-03-2015 07:54 PM
Snotzalot You'll get more than enough help on the 7.3 IDI forum, ask about your starting there. They are also good with trans issues.

7.3L IDI Diesels (Not Power Strokes) - Diesel Forum - TheDieselStop.com
11-25-2015 07:11 AM
dutyhole
Quote:
Originally Posted by blageurt View Post
If you look on the original link I posted .....that guy sells parts as well .....
will do ty !
11-24-2015 08:37 PM
blageurt If you look on the original link I posted .....that guy sells parts as well .....
11-24-2015 07:49 PM
dutyhole
Quote:
Originally Posted by jmadigan View Post
https://www.rockauto.com/catalog/mor...nid=522&jpid=0
This is the full injector rebuild kit. Its really simple just be sure to have some sort of seal lube. And try your hardest not to break any injectors off because then it becomes a real pain...
thanx !
11-24-2015 04:33 PM
jmadigan
Quote:
Originally Posted by dutyhole View Post
no the injectors are stock you have the link for the kit ?
https://www.rockauto.com/catalog/mor...nid=522&jpid=0
This is the full injector rebuild kit. Its really simple just be sure to have some sort of seal lube. And try your hardest not to break any injectors off because then it becomes a real pain...
11-22-2015 09:58 AM
dutyhole
Quote:
Originally Posted by jmadigan View Post
I used power service cutaneous boost in the clear bottle but you might want to rebuild your injectors if you never messed with them it's pretty easy there's a kit on rock auto for like 80 bucks
no the injectors are stock you have the link for the kit ?
11-21-2015 05:53 PM
jmadigan I used power service cutaneous boost in the clear bottle but you might want to rebuild your injectors if you never messed with them it's pretty easy there's a kit on rock auto for like 80 bucks
11-20-2015 11:59 PM
bbasso Have you tried a simple fix such as this:
11-20-2015 08:31 PM
dutyhole
Quote:
Originally Posted by jmadigan View Post
My 6.9 idi blew white smoke until warm and under light acceleration. Put some fuel cleaner in it and clean the lines mine ended up being a clogged return line. I just rebuilt the injectors and put all new return lines on. Cant tell if it really fixed my problem though being as i just blew the turbo. Got a spare 7.3 idi going in this weekend.
what kind of cleaner did you use ?
11-20-2015 05:30 PM
jmadigan My 6.9 idi blew white smoke until warm and under light acceleration. Put some fuel cleaner in it and clean the lines mine ended up being a clogged return line. I just rebuilt the injectors and put all new return lines on. Cant tell if it really fixed my problem though being as i just blew the turbo. Got a spare 7.3 idi going in this weekend.
11-20-2015 03:12 PM
dutyhole
Quote:
Originally Posted by blageurt View Post
This guy a has a lot of good tips on your engine...other than that post in the IDI forum......Ford diesel 6.9 7.3 IDI
good luck
THANK YOU I DID CHECK THIS MORNING BEFORE I LEFT FOR WORK JUST TO MAKE SURE AND I DO HAVE REVERSE LIGHTS TOO ... SECONDARY QUESTION ONLY WHEN I START AND THE COLDER OUT THE WORSE THE SMOKE IS IT POURS SMOKE OUT OF THE EXHAUST WHEN FIRST START IN THE MORNING AFTER SHE GETS HEAT IN HER NO MORE SMOKE IS THAT A BAD IJECTOR OR ???? OH AND HERED THIER IS UPDATED NEUTRAL SAFTEY SWITCH TO FOR THE EO4D IS THAT TRUE ?
11-19-2015 02:17 PM
dutyhole WEL I DID THE GLOW PLUGS SOLVED THAT ISSUE SCANNED THE VAN AND NO CODES UGGGGGGGGGG STILL HAVE THIS IN OUT ON THE TRANNY BETWEEN 35-45 MPH ANY IDEAS ????????????????
11-18-2015 07:51 PM
dutyhole
Quote:
Originally Posted by bugman View Post
Nick in his first post he says that it is a 94 non turbo diesel which should mean that the engine is a IDI and not a Powerstroke. The glow plugs will be visible along with the injectors on the top of the engine.

Use on Motorcraft ZD-9 glow plugs on a 7.3 IDI engine.
Quote:
Originally Posted by blageurt View Post
This guy a has a lot of good tips on your engine...other than that post in the IDI forum......Ford diesel 6.9 7.3 IDI
good luck
thank you !!! now i got a shifting issue with the tranny ugggg keeps going in out of third gear betwwen 35 and 45 mph i already changed the the diff sensor grrrrrrr
11-17-2015 08:51 PM
blageurt This guy a has a lot of good tips on your engine...other than that post in the IDI forum......Ford diesel 6.9 7.3 IDI
good luck
This thread has more than 15 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome