Diesel Forum - TheDieselStop.com - Reply to Topic
'11-16 General Questions General questions related to 2011-Up Super Duty trucks. If it doesn't fit the other categories, post it here. Gas engine discussion that pertains to all models is allowed. Specific gas engine questions should use the Gas Engines forum.

Thread: DEF fault related to EGT sensor fault? Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Diesel Forum - TheDieselStop.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
08-07-2017 01:30 PM
CobraDriver Hmm... Went past mileage where speed was supposed to be limited to 50. Even got message that "upon startup speed will be limited to 50mph" but it never happened. Still driving however fast I want. What's up with that?
07-27-2017 05:47 PM
CobraDriver Bank 1 Sensor 2 (first line of initial post). Truck is covered under warranty extension (although dealer conveniently forgot to tell me that. Truck has also had the update done (also not told about by dealer, I had to tell them about it, claimed they had never heard about it)

What is most likely cause of the DEF fault?
07-23-2017 08:48 AM
larrgh Look up the OBDII code here and see which sensor it is.

Download or open the listing for your truck year.

https://www.motorcraftservice.com/freeresources/obd

Also, check to see if you can find out if your truck is still covered under warranty extension for the EGT sensors. Might need the ECU/PCM calibration updated also for issues related to this problem.
07-22-2017 09:06 PM
CobraDriver DEF level is good. There are no codes other than the EGT sensor code.
07-21-2017 04:15 PM
larrgh The EGT sensors are not related to the DEF problem you. EGT sensors haven't be a problem as they once did after Ford updated the calibration of the ECU/PCM a few years ago. Ford, also extended the warranty on the EGT sensors but your truck being a 2012, it might be past the warranty extension.

DEF is injected into the exhaust after the CAT and DPF. Have you check the DEF level? Have you pulled any OBDII codes that might identify the problem?
07-21-2017 03:59 PM
CobraDriver
DEF fault related to EGT sensor fault?

Several days ago the engine threw a bank 1 sensor 2 EGT code. Finally got a chance to go to dealer and pick one up and on the way home got an "Exhaust Fluid System Fault" and "speed limited to 50mph" message. Could the EGT sensor have caused the DEF fault? More importantly, will replacing the sensor fix both problems or should I just go ahead and make an appointment at the dealer?

Thanks for your help.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome