Diesel Forum - TheDieselStop.com - Reply to Topic
7.3L IDI Diesels (Not Power Strokes) Technical discussion of topics related to vehicles powered by the 7.3 Liter In-Direct Injection Navistar engines.

Thread: 7.3L IDI fuel trouble and glow plugs controller Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Diesel Forum - TheDieselStop.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
05-13-2018 04:00 PM
79jasper I would try for 3.5" at a minimum.
Your truck, do whatever you want. Be forewarned, you will be flamed for wanting stacks.....

Sent from my SM-G892A using Tapatalk
05-13-2018 03:20 PM
CowboyMoyer question can i run three inch and put stacks tho the bed
05-13-2018 03:17 PM
CowboyMoyer ok ill check into it, hoping to have new pipe and muffler in morning i got to drop my truck off
05-13-2018 02:31 PM
chuckster57 I bought an off brand at my local AP store.
05-13-2018 01:12 PM
CowboyMoyer ok sweet ill get it for sure where about can i get the muffler
05-12-2018 10:41 AM
chuckster57 Walker BTM is a good muffler. Look for a full flow muffler.
05-12-2018 12:37 AM
CowboyMoyer i got 3 inch off my turbo right now bit its like one 3 foot long pipe, i have to buy pipe and muffler for it
05-11-2018 08:11 AM
chuckster57 Anything over 3 inch diameter exhaust is a waste of money.
05-11-2018 12:09 AM
CowboyMoyer i charged both batteries and bleed the air out of the lines and had fuel return leaking fuel luke crazy but i put new set of o rings but didnt work so i put another new set in there and it held it so far, but i got her running now its going monday for new exhaust on it idk what to go with yet
05-10-2018 10:53 PM
Charles-65F350 Great! What was the problem?

Quote:
where did you get electric pump at
I found the lowest price at Aircraft Spruce. Around $102 shipped I think.
05-10-2018 02:43 PM
CowboyMoyer got it up and running now
05-10-2018 02:14 AM
genscripter
Quote:
Originally Posted by Charles-65F350 View Post

The strange thing is that it never stopped running. There was just a mild bog when accelerating uphill. Anyway I would check the lift pump, but not necessarily first. I am not sure if mechanical pumps can be "sucked-through" but the electric sure can and the truck will start and run

I have an e-pump as well. I didn't install a relay, but rather an on-off switch that I turn on whenever I start up the engine. One day I forgot to turn on the switch and the van drove fine for several miles. I think as long as you don't have any air in the system or major load on the engine, the IP will suck thru the e-pump just fine. (for short occurrences or emergencies, of course)
05-10-2018 12:59 AM
CowboyMoyer where did you get electric pump at
05-10-2018 12:48 AM
Charles-65F350
Quote:
Originally Posted by C.MITCHELL View Post
JUST SHOOTING IN THE DARK BUT IF IT RAN FOR 20 MILES AND QUIT, HAVE YOU CHECKED THE LIFT PUMP DRIVE? IM NOT A BIG IDI MECHANIC SO I DON'T RECALL HOW THEY OPERATE... JUST A THOUGHT
When I got my IDI, one of the first things I did was install an electric lift pump (Facet/Duralift 40285) and eliminate the mechanical pump. I made a careless mistake and hooked the relay to the fast idle solenoid instead of the fuel shutoff solenoid. So whenever the truck warmed up enough to come off fast idle, the pump would turn off!

The strange thing is that it never stopped running. There was just a mild bog when accelerating uphill. Anyway I would check the lift pump, but not necessarily first. I am not sure if mechanical pumps can be "sucked-through" but the electric sure can and the truck will start and run
05-10-2018 12:45 AM
CowboyMoyer lift pump brand new only 20 miles
This thread has more than 15 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome