Diesel Forum - TheDieselStop.com - Reply to Topic
'99 & up Upgrades and Aftermarket - 7.3L Engine Upgrading or adding OEM or aftermarket equipment to your 1999-Up Super Duty or Excursion with 7.3L Power Stroke diesel engine. Please confine discussion of topics in this forum to those items that are specific to the 7.3L Power Stroke engine.

Thread: Oil loss Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Diesel Forum - TheDieselStop.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
10-30-2018 11:13 AM
jmadigan ... Motor blew up. was coming home from work and it lost power and sounded like bad lifters then came a very loud knock sounds like something hitting the oil pan. Bunch of rattling in the exhaust. ect. So it decided for me the crew cab gets the 6 speed.
10-24-2018 09:10 PM
jmadigan Figured out all my problems just now. Its a bad motor. I took the ccv and vented it to atmosphere because i found oil all over the filter. Me thinking it was how i routed it but nope. I ran it over the alternator then took it for a spin and found oil everywhere. So its got to much blow by im assuming. Im going to swap the trans into my other auto truck and keep the motor to rebuild. Any tips or pain in the butt things people ran across when swaping to 6 speed? I can handle the swap its not a big deal but any info is welcome. Thanks!
10-03-2018 03:55 PM
jmadigan
Quote:
Originally Posted by 2000F250-7.3 View Post
I would check the glow plugs make sure they are in good working order. If the glow plugs and batteries are in order then it could be worn injectors or worn o rings on the injectors. I would get a injector buzz test done that will help tell you if you have warn injectors. The turbo can burn oil you can have the stock one rebuilt with updated 360 degree thrust bearing and a wicked wheel for 500-800 bucks or drop in a Gtp38r turbo or a KC 38r turbo they run 1300-1600 bucks.


Sent from my iPhone using Tapatalk
Ok im planning on putting glow plugs in before winter anyway. My brother in law works for power ford so ill have him buzz test it and scan for codes. Ive rebuilt the turbo in my 2001 so im not afraid to do it to my 99. Ill start there. Thanks.
10-03-2018 01:26 PM
2000F250-7.3
Quote:
Originally Posted by jmadigan View Post
Probably beat to death but i couldnt find a thread with my exact symptoms.


Got a new truck having some issues its a late 99 7.3. There is no oil in the coolant checked that out. I got back from a 300 mile trip and discovered i lost about 3 quarts of oil. Its got 1 oil leak in the front of the engine somewhere it leaks on the tie rod. I dont think i lost it all there though it dripps pretty slow. It does smoke under throttle however and is hard to start in the morning. Im guessing it burns oil. Has some blowby but not alot of pressure on my hand and dosent blow the cap off. The fuel in the bowl is bluish but i added 2 strok oil in that tank of fuel. Im guessing turbo seals or injector o rings. Is there any way to tell between the two or should i just do both rebuild the turbo and put o rings on the injectors? The injectors arent the greatest it runs pretty bad until warm. Another thing to mention is it stalls when i downshift if i dont give it some fuel. Only when i downshift though. It almost stalls when i go from 2000 rpm and let off the gas at idle. HPOP?


I would check the glow plugs make sure they are in good working order. If the glow plugs and batteries are in order then it could be worn injectors or worn o rings on the injectors. I would get a injector buzz test done that will help tell you if you have warn injectors. The turbo can burn oil you can have the stock one rebuilt with updated 360 degree thrust bearing and a wicked wheel for 500-800 bucks or drop in a Gtp38r turbo or a KC 38r turbo they run 1300-1600 bucks.


Sent from my iPhone using Tapatalk
10-03-2018 12:14 PM
jmadigan
Oil loss

Probably beat to death but i couldnt find a thread with my exact symptoms.


Got a new truck having some issues its a late 99 7.3. There is no oil in the coolant checked that out. I got back from a 300 mile trip and discovered i lost about 3 quarts of oil. Its got 1 oil leak in the front of the engine somewhere it leaks on the tie rod. I dont think i lost it all there though it dripps pretty slow. It does smoke under throttle however and is hard to start in the morning. Im guessing it burns oil. Has some blowby but not alot of pressure on my hand and dosent blow the cap off. The fuel in the bowl is bluish but i added 2 strok oil in that tank of fuel. Im guessing turbo seals or injector o rings. Is there any way to tell between the two or should i just do both rebuild the turbo and put o rings on the injectors? The injectors arent the greatest it runs pretty bad until warm. Another thing to mention is it stalls when i downshift if i dont give it some fuel. Only when i downshift though. It almost stalls when i go from 2000 rpm and let off the gas at idle. HPOP?

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome