Diesel Forum - TheDieselStop.com - Reply to Topic
'99 & up 7.3L Power Stroke Engine and Drivetrain Discussion of the '99 & up 7.3L Power Stroke diesel engine and drivetrain in the 1999-Up Super Duty trucks and Excursions. No gas engine discussion allowed except on transmissions and drivetrain that pertain to all models. Please confine discussion of topics in this forum to those items that are specific to the 7.3L Power Stroke engine.

Thread: 7.3 eng runs rough then dies Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Diesel Forum - TheDieselStop.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
02-10-2019 07:42 PM
Absolute Or keep it above 1/4 tank until you want to do the job. I pull the box, its easier in my opinion.
02-10-2019 05:21 PM
Jgravel Couldnt get the fittings i needed to plumb gauge into fuel bowl today. unhooked fuel line at pump outlet. turn key to run, pump runs but no fuel, just sounds like its sucking air. Guess im dropping the tank tomorrow. Thanks for the help and assistance, it appreciated
02-10-2019 04:41 PM
Absolute Not sure if your stock or not, but put some fuel in it. 1/4 tank, and your mileage are good indicators your 1/4 tank bypass valve is stuck open or fallen off, meaning every time you hit a 1/4 tank it will suck in air. They usually go around your mileage.
02-10-2019 11:53 AM
Jgravel I will hook up pressure guage and see what i got. what kind of numbers am i looking for?
02-09-2019 09:17 PM
klhansen Maybe a heat issue with the coil on the IPR, although that should throw a code.

Clogged in-tank screens like Denny suggested is a real possibility.

Check fuel pressure at the back of the filter housing. You'll need an SAE o-ring to pipe thread fitting.
02-09-2019 05:32 PM
DENNY If you were on a hill I would suspect a bad foot in the fuel tank. You could have clogged screens in the tank, or a fuel pump going bad. If you can put a pressure gauge on the fuel system and see what the pressure does as it starts to run rough that would help figure it out.
DENNY
02-09-2019 04:08 PM
Jgravel Within past couple years ive replaced ICP and CPS. leaning towards bad IPR or insufficient fuel PSI? not sure or port to verify fuel psi?
02-09-2019 03:55 PM
Jgravel
7.3 eng runs rough then dies

late 99 SD with 225k miles, manual trans. Truck is well maintained, with minimal issues.
Driving yesteday just fine, them truck started to run real rough outta no where. pulled over, it eventually stalled, no restart. No CEL, Good fuel flow out of drain valve w/ key in run (tank 1/4 full), oil level good.
Put in new fuel filter, pulled chip, unhooked ICP sensor with no change. Truck seems to start if let set for 20+ min and will again run rough then stall, almost like not getting fuel? Its 20*F +/- here in SE MI, but ran fine on same fuel last week when it was -15*F. Not one to just throw parts at a vehicle, prefer to troubleshoot and diagnose properly. Any thoughts are much appreciated

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome