Diesel Forum - TheDieselStop.com - Reply to Topic
'99 & up 7.3L Power Stroke Engine and Drivetrain Discussion of the '99 & up 7.3L Power Stroke diesel engine and drivetrain in the 1999-Up Super Duty trucks and Excursions. No gas engine discussion allowed except on transmissions and drivetrain that pertain to all models. Please confine discussion of topics in this forum to those items that are specific to the 7.3L Power Stroke engine.

Thread: Whooshing after ebpv delete Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Diesel Forum - TheDieselStop.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
03-06-2019 03:37 PM
2000F250-7.3 No problem anytime.


Sent from my iPhone using Tapatalk
03-06-2019 03:01 PM
parker4 yeah I have an sct x4 tuner for it. I actually just purchased the one from riff raff haha, so good call on that one, my current wheel isn't chipped but is worn and I have heard that I could get surging with the tuner while towing my 5th wheel that I haven't had a chance to haul until next month. Thanks again though for your help
03-06-2019 01:37 PM
2000F250-7.3
Quote:
Originally Posted by parker4 View Post
also getting a new compressor wheel to rule out any more boost problems, but I am thinking the little bit of boost loss was from that passenger side Y pipe fitting and possibly the clamp a little too. Before I could barley hear the turbo spool up inside the cab when I had the ebpv in. Now it sounds like you are sitting near the end of a plane on takeoff. Way louder than before.


Glad I could help I have done several turbo swaps on 7.3 you learn a few things every time. Questions do you have a tuner on the truck if you do on a stock turbo your probably getting compressor surge a new compressor wheel like wicked wheel 2 will get rid of that or a ported compressor housing will fix that RiffRaff diesel can get you the parts to fix that.


Sent from my iPhone using Tapatalk
03-06-2019 01:01 PM
parker4 also getting a new compressor wheel to rule out any more boost problems, but I am thinking the little bit of boost loss was from that passenger side Y pipe fitting and possibly the clamp a little too. Before I could barley hear the turbo spool up inside the cab when I had the ebpv in. Now it sounds like you are sitting near the end of a plane on takeoff. Way louder than before.
03-06-2019 12:53 PM
parker4 I think you hit the nail right on the head with the up pipes and y connector. Went out and checked the up pipes, because after you said that I thought of one mistake I made after putting on the ped was I didnt shake the Y connector to see if it had play in it. Well I disconnected it today and found a little bit of play on the connections and new soot down the passenger side one. The connection seemed tight but that Y pipe to the turbo is so hard to mess with because of the location that it may have been not all the way on like you said seeing as I didn't loosen the bottom bolts near the manifolds. loosening them is a good suggestion since I just ordered a new set of up pipes just now. Hopefully it will be fixed this weekend. Will post updates when fixed. thank you for your suggestion.
03-06-2019 09:17 AM
2000F250-7.3 I would recheck all intercooler connections make sure clamps are tight. The turbo outlet make sure it and the intake spider are lined up are good way to line that up is to get it in the lower boots the the engine and then tighten the v ban clamp first then the boot clamps. The up pipes y collector lined up with no gap? The down pipe lined up too? The clamps do a good job of help centering the connections up but sometimes you have to center them before you tighten the clamps up.


Sent from my iPhone using Tapatalk
03-05-2019 07:52 PM
parker4 also it is a 2001 f250 with the 7.3l
03-05-2019 07:48 PM
parker4
Whooshing after ebpv delete

Hi there, I am new to this site but I have gotten a lot of useful info from here.

My problem is since I just completed the ebpv delete by getting the non ebpv ped and the closed off adapter. Now I am getting a whooshing noise that was similar to when the valve was closed when it was installed. It is only under acceleration and sounds like a jet engine.

The only other mods that I have is an intake and SCT x4 street tune on it, but I have put it back to the stock tune with the same problem.

It doesn't sound like a surging noise just whooshing if that makes sense. I do not have an egt gauge yet(ordered not yet installed until shipped) so my fear is that something is clogging the system and it is raising them without me knowing too high.

No noticeable coal on the firewall to indicate a clamp leak.

boost is semi normal, but seems like less power(just a little)

I appreciate any help on this

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome